Have I got a broken camera module?
#1
Sad 
https://imgur.com/cM798Yf

I received my pinephone yesterday and found the rear camera acting really weird. Every time after cold boot, when I launch megapixel the preview image will be all blue.
After closing megapixel and launching it again, the color of the image will become normal but with huge glitches as shown in the link above.

I tried manjaro that came with the phone and mobian, both have the same issue. However I haven't try other application other than megapixel. I also took the phone apart and reconnected the rear camera module but to no avail. ( Yeah, I probably broke the warranty sticker for that so not sure it I can ask Pine64 for a new module Sad )

Did I got a faulty module or is this a known issue awaiting to be fixed?

Thx in advance Smile
  Reply
#2
(11-06-2021, 12:20 PM)AKD251 Wrote: https://imgur.com/cM798Yf

...

Did I got a faulty module or is this a known issue awaiting to be fixed?

Something looks faulty to me - that is not normal.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (6.2 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition, daily driver, rk2aw & U-boot on SPI, Arch/SXMO & Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/SXMO on eMMC
  Reply
#3
(11-06-2021, 12:20 PM)AKD251 Wrote: I tried manjaro that came with the phone and mobian, both have the same issue. However I haven't try other application other than megapixel. I also took the phone apart and reconnected the rear camera module but to no avail. ( Yeah, I probably broke the warranty sticker for that so not sure it I can ask Pine64 for a new module Sad )

Wait, there is a warranty? Maybe try updating the OS or install a different one in case it's a software issue. The distro that came with my phone was pretty outdated and a bit broken.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinephone - broken power button rorus 10 9,453 05-18-2023, 09:11 AM
Last Post: kbm
  Keyboard support broken in Mobian? MacarioMorenoUK 2 1,846 06-08-2022, 02:34 AM
Last Post: MacarioMorenoUK
  PostmarketOS Camera and ffmeg rafiki88 1 1,552 03-19-2022, 10:09 AM
Last Post: vap0rtranz
  Would another camera work in the PP? nelstomlinson 2 2,293 11-11-2021, 06:25 PM
Last Post: nelstomlinson
  camera firmware problems kqlnut 25 22,198 09-02-2021, 07:49 PM
Last Post: Zebulon Walton
  [Help] SIM slot contact broken WinstonSmith 3 3,361 07-14-2021, 06:13 AM
Last Post: mouffa
  camera + megaixel and strange behavior streak 0 1,720 06-02-2021, 06:45 AM
Last Post: streak
  Pinephone camera thread ryo 8 8,530 05-29-2021, 03:21 AM
Last Post: ryo
  Camera clicking sound unsatisfactory212 2 2,895 05-07-2021, 02:57 PM
Last Post: megous
  PinePhone won't boot, U-Boot seems to be broken Marcade 8 7,927 04-20-2021, 05:28 PM
Last Post: dsimic

Forum Jump:


Users browsing this thread: 1 Guest(s)