RockPro64 Ethernet NOP After Debian 11 Install...
#1
Tongue 
I just did a fresh install onto a 64gb SDCard for my RockPro64 as described here: https://wiki.pine64.org/wiki/ROCKPro64_S..._Installer


The first time I selected KDE GUI, after the install finished, I got the login dialog and logged in, but I never got the Desktop, nor could I ping the Rockpro64.

Then I started over and selected GOME as my GUI, this time I got logged into the Desktop alright, but after digging in a bit I found the Ethernet seems totally broken.  DHCP doesn’t work, and after configuring a static IPv4 configuration ("IP A" shows valid IP Config), I cannot ping IN or OUT of the rockpro64, nor do anything on the network.

The bootstrap installation went fine and was able to use DHCP to get an IP Address.  But I noted the installation took a LONG time.  Nearly 6-8 hours.

It seems something is wrong with the Ethernet drivers.

As a side note, I downloaded the mrfixit2001 image and the Ethernet works great:

    https://github.com/mrfixit2001/debian_desktop/releases

But, I would rather start with a clean fresh Debian install.

Another issue seems to be that if I install the bootstrap onto an 64GB eMMC as described here ( https://wiki.pine64.org/wiki/ROCKPro64_S..._Installer ) The system doesn’t boot.  However, if I install the mrfix2001 (as described above) image onto the same eMMC card, it boots fine.

Also, how do I manually configure the display resolution?  The RockPro64, does not properly detect my NewHaven 7” LCD NHD-7.0-HDMI-N-RSXN-CTU display, which has been properly detected by the Raspberry Pi 4 and the Asus Tinkerboard 2 and Asus Edge R.  I need to force the resolution to 800 x 480 to work with the NewHaven LCD.

Also, I find that after a soft reboot, I nearly always have to power my Dell monitor off/on, to get any display out of the RockPro64.

Anyway, any help you can led would be most appreciated.

Thank you,

Matt Dralle
  Reply
#2
(10-27-2021, 08:03 PM)MattDralle Wrote: I just did a fresh install onto a 64gb SDCard for my RockPro64 as described here: https://wiki.pine64.org/wiki/ROCKPro64_S..._Installer


The first time I selected KDE GUI, after the install finished, I got the login dialog and logged in, but I never got the Desktop, nor could I ping the Rockpro64.

Then I started over and selected GOME as my GUI, this time I got logged into the Desktop alright, but after digging in a bit I found the Ethernet seems totally broken.  DHCP doesn’t work, and after configuring a static IPv4 configuration ("IP A" shows valid IP Config), I cannot ping IN or OUT of the rockpro64, nor do anything on the network.

The bootstrap installation went fine and was able to use DHCP to get an IP Address.  But I noted the installation took a LONG time.  Nearly 6-8 hours.

It seems something is wrong with the Ethernet drivers.

As a side note, I downloaded the mrfixit2001 image and the Ethernet works great:

    https://github.com/mrfixit2001/debian_desktop/releases

But, I would rather start with a clean fresh Debian install.

Another issue seems to be that if I install the bootstrap onto an 64GB eMMC as described here ( https://wiki.pine64.org/wiki/ROCKPro64_S..._Installer ) The system doesn’t boot.  However, if I install the mrfix2001 (as described above) image onto the same eMMC card, it boots fine.

Also, how do I manually configure the display resolution?  The RockPro64, does not properly detect my NewHaven 7” LCD NHD-7.0-HDMI-N-RSXN-CTU display, which has been properly detected by the Raspberry Pi 4 and the Asus Tinkerboard 2 and Asus Edge R.  I need to force the resolution to 800 x 480 to work with the NewHaven LCD.

Also, I find that after a soft reboot, I nearly always have to power my Dell monitor off/on, to get any display out of the RockPro64.

Anyway, any help you can led would be most appreciated.

Thank you,

Matt Dralle

Although you're posting in the wrong section have you tried Armbian from here https://www.armbian.com/rockpro64/ I wouldn't hold my breath on a successful install of full blown Debian.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 board not working, no HDMI no Ethernet. EDited 2 807 01-26-2022, 08:46 AM
Last Post: TRS-80
Question Constant RockPro64 PCIe SATA Issues Kwarter 0 251 01-22-2022, 05:16 PM
Last Post: Kwarter
  4 Uarts and 2 Ethernet possiblities gops 13 10,607 11-13-2020, 08:51 AM
Last Post: LMM
  USB3 to Ethernet adapter giuseppe 0 1,047 11-11-2020, 05:48 PM
Last Post: giuseppe
  No green Ethernet LED sanis 2 2,524 03-06-2019, 11:21 PM
Last Post: sanis
  Rock64-4gb,Armbian Debian Stretch: Plex, Radarr, NZBGet and Sickchill WOW Baracuda2 1 2,064 02-27-2019, 03:34 PM
Last Post: Luke
  flash image to sd/emmc through ethernet LMM 0 1,536 02-04-2019, 07:36 AM
Last Post: LMM
  Newbie, No GUI interface for Debian Stretch Min 64 (bld 0.7.9) Pajaro 1 1,948 09-10-2018, 07:30 PM
Last Post: evilbunny
  Working desktop on Debian ? Chris66 5 4,395 08-29-2018, 12:21 PM
Last Post: dkryder
  How can I install tvheadend server un rock64? gedas07 12 7,854 08-25-2018, 01:06 PM
Last Post: gedas07

Forum Jump:


Users browsing this thread: 1 Guest(s)