Chatty, SMS does not work - could hardware be at fault?
#11
(09-19-2021, 11:53 AM)AntonReiser Wrote: What to do? Leave it as it is because that is already the optimum and search for another cause? Reinstall the new firmware because you never know? Or install the OLD firmware (if it's available) since it works on the other phone?

Before you do flashing experiments, you could try more distros. I would at least give Manjaro Phosh a try and see how it goes, they are pretty up to date on stuff. Some people have reported problems with sending SMS and could get it to work by switching go 2G only in the settings before sending. Maybe that works for you too. If nothing works, I would open an issue on the bug tracker of the distro of your choice and hope someone with more technical knowledge can help you out on there.I highly doubt this is a hardware problem if the modem is otherwise functional.
If you do decide to flash the alternative firmware at some point (which by the way is also safer than the stock firmware as sudden power loss can't corrupt the modem), you can also revert back to the stock firmware later.
  Reply
#12
(09-19-2021, 12:27 PM)kqlnut Wrote: Before you do flashing experiments, you could try more distros. I would at least give Manjaro Phosh a try and see how it goes, they are pretty up to date on stuff. Some people have reported problems with sending SMS and could get it to work by switching go 2G only in the settings before sending. Maybe that works for you too. If nothing works, I would open an issue on the bug tracker of the distro of your choice and hope someone with more technical knowledge can help you out on there.I highly doubt this is a hardware problem if the modem is otherwise functional.
If you do decide to flash the alternative firmware at some point (which by the way is also safer than the stock firmware as sudden power loss can't corrupt the modem), you can also revert back to the stock firmware later.

That's very valuable info again. I'll assume then that the hardware is OK and hope to fix the issue at some point. So I finally get to keep a 3GB Pinephone! 

I noticed that I do not receive all SMS messages, people told me that they got error messages when trying to write to me. It mostly seems to work but not always.

Setting "2G only" and trying Manjaro (the version on the multi distro image and a new version installed on another SD card) unfortunately has not worked, I still could not send messages.

However, Manjaro shows the error message "Network Management:Modem (quectelqmi_0) The modem shows no carrier" immediately after booting it. Could that be a hint what the problem might be?

If not I guess the next step would be to install the alternative firmware.
  Reply
#13
(09-19-2021, 01:46 PM)AntonReiser Wrote:
(09-19-2021, 12:27 PM)kqlnut Wrote: Before you do flashing experiments, you could try more distros. I would at least give Manjaro Phosh a try and see how it goes, they are pretty up to date on stuff. Some people have reported problems with sending SMS and could get it to work by switching go 2G only in the settings before sending. Maybe that works for you too. If nothing works, I would open an issue on the bug tracker of the distro of your choice and hope someone with more technical knowledge can help you out on there.I highly doubt this is a hardware problem if the modem is otherwise functional.
If you do decide to flash the alternative firmware at some point (which by the way is also safer than the stock firmware as sudden power loss can't corrupt the modem), you can also revert back to the stock firmware later.

That's very valuable info again. I'll assume then that the hardware is OK and hope to fix the issue at some point. So I finally get to keep a 3GB Pinephone! 

I noticed that I do not receive all SMS messages, people told me that they got error messages when trying to write to me. It mostly seems to work but not always.

Setting "2G only" and trying Manjaro (the version on the multi distro image and a new version installed on another SD card) unfortunately has not worked, I still could not send messages.

However, Manjaro shows the error message "Network Management:Modem (quectelqmi_0) The modem shows no carrier" immediately after booting it. Could that be a hint what the problem might be?

If not I guess the next step would be to install the alternative firmware.
You really should bring this into the Mobian Matrix chat because the devs are more active in there and could probably give you some better advice! Best of luck with this though!
  Reply
#14
In your contacts, have you entered the '+' symbol ?

In the USA that would be +1 then area code, then the seven digit phone number. +1 xxx xxxxxxx
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#15
(09-19-2021, 11:36 PM)bcnaz Wrote: In your contacts,  have you entered the '+' symbol ?

In the USA that would be  +1  then area code,  then the seven digit phone number.  +1 xxx xxxxxxx

Yes, unfortunately. Same contacts as on the other phone, all +ed.
  Reply
#16
***
Most sms/text message problems have been not receiving the text,

Receiving the text but not sending them,,,, ?    ... that problem, I have not seen previously.


*****

Settings >  Region Language > 
        Language :  English (United States)    Formats :  United States (English)

Of course your language settings may be different.

But Last year I had text problems when I did not select one of these options.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#17
(09-20-2021, 12:09 AM)bcnaz Wrote: Receiving the text but not sending them,,,, ?    ... that problem, I have not seen previously.


Well, it has just become even crazier: 

Using Manjaro on an SD card, I sent two more text messages this morning. One, sent at 9:55, got lost as usual, another message at 10:31 actually did get to the recipient (my work phone in the same room), but it did so 14 minutes later, at 10:45. Reception here is always fine, so that is neither the reason for the problems nor for this delay.
  Reply
#18
...  Probably about a year or so back,  I think I was still using my Brave Heart as my main phone.

I received a text from my cousin while he was on vacation,  except he had been back home for a week when I received the text.

I don't think it would be possible for the phones software to have caused that,  I 'think' that more than likely that was some kind of carrier fault/error.

Just sharing my own experience....  We do have 'three main possible causes',  new Operating system(s), new hardware, and the carriers.
Possibly a conflict between these items ?

I DO HOPE your problem(s) can be resolved !
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#19
(09-20-2021, 02:39 PM)bcnaz Wrote:  We do have 'three main possible causes',  new Operating system(s), new hardware, and the carriers.

Well, in this case it's neither the operating systems (I tried four) nor the carriers (two). All of them work flawlessly on the old 2 GB Pinephone and none of them send messages from the new 3 GB phone.

So the only causes left are the firmware or the hardware. 

When I have time, I will flash the modem firmware. I hope that will solve it. (I really don't want to have to deal with another defective pinephone.)
  Reply
#20
Strange,
Of the 5 Pine phones I have, * I have not had to flash even one modem... I thought I needed to at one point with my original Brave Heart, but a new OS showed that it was not necessary.

Different releases of one operating system, or using different operating systems have solved any of my problems, from the Brave Heart days to today.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Hardware VIdeo Acceleration on Mobian biketool 3 477 06-21-2022, 01:01 PM
Last Post: biketool
  GPS/location services don't work with Maps after Bookworm upgrade Anna 16 2,930 06-13-2022, 02:37 PM
Last Post: wibble
  Chatty - XMPP receiving photos - inline display doesn't work arkadione 1 134 06-12-2022, 02:39 PM
Last Post: user641
Sad Chatty can no longer start since the last update anonymous 10 698 06-08-2022, 01:03 PM
Last Post: Korac
  chatty v0.6 in Bookworm at last! treebeard 13 2,015 02-13-2022, 05:21 PM
Last Post: treebeard
  Anyone using a hardware token? p121458 13 5,642 01-17-2022, 03:24 AM
Last Post: biketool
  Xbox Series Controller Won't Work beta-user 0 296 01-14-2022, 05:58 AM
Last Post: beta-user
  Recipe for getting OpenVPN to work? county93 1 892 10-04-2021, 12:10 PM
Last Post: county93
  Anyone find a work around for the brightness issues from kernels 5.13/14? ragreenburg 2 1,118 09-01-2021, 08:49 AM
Last Post: ragreenburg
  Kernel fault on adapter connect pinephone.damiano 0 505 08-15-2021, 04:25 AM
Last Post: pinephone.damiano

Forum Jump:


Users browsing this thread: 1 Guest(s)