wwan0 (SIM interface) doesn't work with OpenVPN
#1
I created my own OpenVPN, it works in Manjaro, in mikrotiks, ASUS router and so on, but I can't use it in Pinephone Pro. The connection is establishing and the route is changing (I see it by mtr) but Firefox (and Chromium) continues using the default route without OpenVPN. I have tried to create the MASQUERADE rule in iptables but nothing was changed. What do I need to do? Did anyone face up the same problem?
  Reply
#2
Also I can say that all works in Chrome which is launching in Waydroid. It isn't route table case

DNS over HTTPS is enabled (Also I tried to specify the DNS manually). Proxy is disabled. I couldn't find more settings which I could change.
  Reply
#3
Apparently the browsers used wwan0 interface by default that's why the sites didn't open. When I turned off this interface all begun to work though wifi inteface (wlan0). I tried to reconfigure dns settings how write here: https://forum.pine64.org/showthread.php?tid=16133 and specify nameservers manually but it didn't help.
  Reply
#4
I set up the SIM to another phone and shared wifi to pinephone pro by hotspot from this phone, after that I connected my own OpenVPN and everything has worked. So I can see the conclusion the wwan0 interface (modem of SIM) doesn't work with OpenVPN, it isn't ISP case. The problem somewhere on OSI application layer, routes are correct. Also all works when I use wwan0 interface with OpenVPN in Chrome which is launching in Waydroid, it is possible not only by wifi.

P.S. Moderators rename the title to "wwan0 (SIM interface) doesn't work with OpenVPN", please, it would more correctly.
  Reply
#5
Maybe smite the "Report" button on your OP.
:wq



[ SRA accepts you ]
  Reply
#6
(04-18-2023, 07:36 PM)KC9UDX Wrote: Maybe smite the "Report" button on your OP.

Ok, I have done it.
  Reply
#7
I have turned off ipv6 routing from ISP and resolved this issue.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  The program doesn`t detect the camera blag0rag 2 119 02-15-2024, 08:03 PM
Last Post: Kevin Kofler
  Chatty does not work after suspend mode user641 4 1,720 07-18-2023, 10:43 AM
Last Post: alaraajavamma
  Wifi doesn't work after update nickolas 2 1,094 04-14-2023, 10:07 AM
Last Post: nickolas
  Most recent Mobian image or installer image known to work? DrPlamsa 13 4,371 02-26-2023, 11:47 PM
Last Post: SukiiPooru
Exclamation The webcam doesn't work in Firefox anonymous 0 662 11-06-2022, 01:45 PM
Last Post: anonymous
  Megapixels doesn't work Glenn 4 2,555 08-28-2022, 03:19 PM
Last Post: vortex
  PP Keyboard doesn't charge Pinephone (Mobian) jojuma 1 1,124 08-06-2022, 01:10 AM
Last Post: elode
  Can't Get Nheko To Work [never mind, it's a bug] el.pollo.diablo 0 734 08-02-2022, 02:11 AM
Last Post: el.pollo.diablo
  Chatty - XMPP receiving photos - inline display doesn't work arkadione 2 1,822 07-10-2022, 03:16 AM
Last Post: arkadione
  GPS/location services don't work with Maps after Bookworm upgrade Anna 16 9,633 06-13-2022, 02:37 PM
Last Post: wibble

Forum Jump:


Users browsing this thread: 2 Guest(s)