Stock Debian on original Pinebook
In case anyone is still using their original Pinebook - I pulled mine out of storage couple days ago and installed Debian Sid on it. Everything is working fine so far, except Bluetooth, sound, and deep sleep. The only special thing I had to do is build kernel module separately for WiFi.

I used to create a Debian installer SD card. Generally installer worked, but letting it do it's own thing hands-off resulted in a system that's not bootable without an SD card. To make it bootable 16MiB free space is required in the beginning of the eMMC (I didn't try using SPI flash). So I partitioned eMMC manually, creating a single ext4 partition that starts at 16MiB mark and takes all of eMMC - I didn't want the hassle with any special partitioning. After that I went through the installation, and in the end installed u-boot-sunxi and ran `u-boot-install-sunxi64 /dev/mmcblk0` (make sure you got the right device number) to install u-boot. One thing to note though is I used u-boot-sunxi from experimental - it seems the version in Unstable is not yet able to boot from ext4 partitions. After that the system boots fine on its own, but doesn't have any WiFi. To get WiFi working I cloned, installed basic build dependencies (build-essential, linux-headers-arm64), cd to the folder, `make && sudo make install && sudo modprobe 8723cs`. After that I installed the rest of the packages and got a full working system. For KDE Plasma QML not to glitch all the time I had to set QT_XCB_FORCE_SOFTWARE_OPENGL to 1 (I added `QT_XCB_FORCE_SOFTWARE_OPENGL=1` line to /etc/environment).
This message was created with 100% recycled electrons
Nice! The concatenated installer image booted for me on my 1080P Pinebook. I got online using USB tethering to an Android phone. I also had to partition manually: only a single ext4 partition worked, with the 16MB free at the beginning for u-boot, like you said. The partition table had to be MBR, not GPT.

After installation, before rebooting, chrooted into the target eMMC partition and installed u-boot from the u-boot-sunxi package (version 2022.01+dfsg-1):
TARGET=/usr/lib/u-boot/pinebook u-boot-install-sunxi64 /dev/mmcblk1

I added sections to the wiki pages for Original Pinebook and 1080P Pinebook Software Releases to list this installation option, linking to this thread:

I wasn't able to build the rtl8723cs driver, as it depends on ipx.h which is no longer in Linux:

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook no longer boots rjtanner 12 527 04-13-2023, 01:09 PM
Last Post: tophneal
  Slarm64 on Pinebook [Slackware Arm - 64 bit] KRT 43 45,847 03-15-2023, 12:01 PM
Last Post: mara
  Write image to eMMC - Pinebook 11.6" irongarment 4 2,565 01-04-2022, 09:22 PM
Last Post: irongarment
  DietPi OS for Pinebook MichaIng 2 4,182 10-22-2021, 02:00 PM
Last Post: MichaIng
  E: The repository ' bionic Release' no longer has a Release pixelpaperyarn 3 4,166 05-07-2021, 10:20 AM
Last Post: tophneal no longer has release file?? supermassive 1 3,096 01-20-2021, 11:18 AM
Last Post: tophneal
Question Ran apt update on my Pinebook.. ford442 0 2,315 12-25-2020, 04:40 PM
Last Post: ford442
Information Manjaro ARM for Pinebook erchache2000 88 94,974 11-29-2020, 04:36 PM
Last Post: Mr.Fermer
  Pinebook is going the way of Betamax? trigger 10 13,770 11-01-2020, 02:02 PM
Last Post: leperotero
  Pinebook Pro (i3 WM): Confirm Shutdown on Power Button etothepii 3 6,014 08-14-2020, 06:03 AM
Last Post: loblik

Forum Jump:

Users browsing this thread: 1 Guest(s)