pinephone drops cellular network
#1
hello,

please excuse my ignorance, i'm not really sure sometimes what are hardware issues and what fall under the software category.

i'm using the latest (updated?) version of manjaro-arm and have noticed that my cellular network has disappeared suddenly. after i restart the network reappears. i'm not sure if this relates to my previous post on 'modem shows no carrier messages' which seemed to have stopped after updating. where can i find some log messages to begin to troubleshoot this issue?

i'm using the koodo/telus network in canada.

thanks.
  Reply
#2
it happened again this morning in the middle of a call, my cellular network disappeared! after a reboot the network reappears but explorer sms chat now gives me the message, 'device to use sms with:' with no options to choose. my rudimentary understanding tells me the sms software isn't finding the modem!? any help would be appreciated. thanks.

in the interim tried the AT command,

AT+QMBNCFG="list"

from the pine64 info wiki page and nothing was listed!?
  Reply
#3
Excluding the case that your SIM loses electrical contact maybe due to the  nano-micro SIM adapter or that the SIM has some problem, try again

qdbus --system org.ofono /quectelqmi_0

you will see various operations related to the Network, the SMS etc

for example, unlock the SIM with your pin like this

qdbus --system org.ofono /quectelqmi_0 org.ofono.SimManager.EnterPin pin your_pin
  Reply
#4
(05-13-2021, 09:02 AM)Rainer Wrote: it happened again this morning in the middle of a call, my cellular network disappeared! after a reboot the network reappears but explorer sms chat now gives me the message, 'device to use sms with:' with no options to choose. my rudimentary understanding tells me the sms software isn't finding the modem!? any help would be appreciated. thanks.

in the interim tried the AT command,

AT+QMBNCFG="list"

from the pine64 info wiki page and nothing was listed!?
I am also experiencing the same problem. 
And throughout the week it has become worse.  What started as occasionally losing the phone modem has now become rarely having a mobile connection (with the OS software not even recognizing if there is a cellular modem present).  So, I just stopped using the Pinephone as my daily driver.
I do not believe it is an OS software issue (as I have tried multiple versions of multiple operating systems [most of which use to work fine]); My best (mostly uneducated) guess is that it is a hardware failure (or maybe a firmware failure [that is if the firmware received an updated without me noticing]).
The phone has been known to run hot, and more recently my device has been running hot more often than not.
  Reply
#5
(05-28-2021, 07:22 PM)LaughWithMeOrAtMe Wrote: I am also experiencing the same problem.

What is your modem firmware version?
If it is outdated, you can try updating it to see if it improves the things.
  Reply
#6
Hello,

Same problem for me : https://forum.pine64.org/showthread.php?...1#pid95371

I've change the parameters to reduce the thermal problem from weeks.
  Reply
#7
I would try to recover the firmware but follow the instructions with precision

https://wiki.pine64.org/wiki/PineModems

First try a freshly installed distribution, for example Manjaro Phosh started acting strangely after two days of continuous use. Install the latest release of the distribution.

Both Linux and modem firmware can be corrupted without an apparent reason.

Of course hardware failures are not impossible but if it happens to many users it is probably something with the software/firmware.
  Reply
#8
(05-31-2021, 12:30 AM)Gribouille Wrote: Hello,

Same problem for me : https://forum.pine64.org/showthread.php?...1#pid95371

I've change the parameters to reduce the thermal problem from weeks.

I've noticed a correlation between "my phone is really hot" and "I can't make outbound calls or text". Did changing the parameters help? And if so, what did you change? 
Thank you!
  Reply
#9
(05-31-2021, 07:32 PM)mudflap Wrote:
(05-31-2021, 12:30 AM)Gribouille Wrote: Hello,

Same problem for me : https://forum.pine64.org/showthread.php?...1#pid95371

I've change the parameters to reduce the thermal problem from weeks.

I've noticed a correlation between "my phone is really hot" and "I can't make outbound calls or text". Did changing the parameters help? And if so, what did you change? 
Thank you!

Hello,

Sorry, I haven't found a solution.

I suppose that the temperature is a parameter. I've reduce the temperature, because my screen is 'dying' : https://forum.pine64.org/showthread.php?tid=13636.

After some 'apt dist-upgrade', the modem disappear in standby mode. If the phone is 'called' (after one night off), the modem is seen, but after some time : no modem, even in the menu 'Parameters'.
  Reply
#10
With Mobian, since two days, the modem is operational. It's seems that the problem was mainly a software problem, but some time is needed to be sure.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Offer: PinePhone UB Edition in Germany firefox-58 0 92 09-15-2021, 06:29 AM
Last Post: firefox-58
Heart PinePhone Manufacturer 4hilton@gmail.com 8 354 09-12-2021, 11:17 PM
Last Post: zetabeta
Wink Pinephone IMEI changing info: do you think its OK for a Wiki? mikeb 20 1,156 09-07-2021, 06:56 AM
Last Post: KC9UDX
Thumbs Up Pinephone USB-C Docking Bar (Amazing !!) Gary2003 19 5,561 08-14-2021, 08:01 AM
Last Post: nelstomlinson
  PinePhone Hardware Critique KABA 2 614 08-13-2021, 06:47 PM
Last Post: Zebulon Walton
  pinephone circuit board design, conductive parts zetabeta 1 239 08-12-2021, 05:28 AM
Last Post: wibble
  Replace/Solder USB-C port on Pinephone magdesign 4 415 07-30-2021, 09:24 PM
Last Post: bcnaz
  Unsatisfactory GPS reception on PinePhone? LinAdmin2 43 15,448 07-06-2021, 02:03 PM
Last Post: Benatti
  new PinePhone... dead pixel? ~Daniel~ 5 791 07-04-2021, 09:01 AM
Last Post: kqlnut
  computer doesn't recognize pinephone for OS flashing Xzska-collab 5 1,114 06-29-2021, 09:37 AM
Last Post: Xzska-collab

Forum Jump:


Users browsing this thread: 1 Guest(s)