Speakers not working after repair?
#1
Hi

Recently I repaired the screen on my PinePhone and I had some issues with the USB-C board that are now fixed, now the loud speaker isn't working, any ideas?
  Reply
#2
(03-23-2021, 09:22 AM)ImmyChan Wrote: Hi

Recently I repaired the screen on my PinePhone and I had some issues with the USB-C board that are now fixed, now the loud speaker isn't working, any ideas?

It may be unrelated to your other repairs. I say that because my speaker crapped out after about a week of use. Others have had the same problem. But...

Test the phone:
The speaker has the springs that contact the pads on the flexible pcb under it. Get some audio playing (internal speaker selected in settings) and put a multi-meter on those pads.

Test the speaker:
Use a pair of old headphones, cut off one earbud and touch the +/- wires to the springs on the pinephone speaker and see if it produces sound.
(Testing its impedance is probably the right way but IDK enough about that Big Grin )

I ordered a replacement speaker but it has wire leads so I soldered them to the above mentioned pads. It now works great!

I used these: https://www.walmart.com/ip/Unique-Bargai.../171945776
They are a little thicc for the pinephone but they did fit.

I never tested the old speaker because is sucked anyway and I was happy to have a reason to replace it Smile . (I also needed an excuse to buy a pinecil) Big Grin Big Grin 
The speaker problem was a win win situation for me. Cool

Good luck!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Hardware switch for mic is not working properly submariner 10 3,184 01-25-2022, 07:01 AM
Last Post: wibble
  New vibration motor not working Zebulon Walton 6 3,324 11-13-2021, 03:00 AM
Last Post: kqlnut
  on off power button stopped working dcinoz 3 963 09-01-2021, 03:26 AM
Last Post: dcinoz
  LED not working on 3GB variant IVp 2 1,268 08-21-2021, 02:57 PM
Last Post: IVp
Sad PnePhone Braveheart Edition - Microphone NOT Working valentin 15 2,941 08-09-2021, 07:43 PM
Last Post: tllim
  Help needed: Jump drive not working UsnR2 5 2,633 07-09-2021, 03:22 PM
Last Post: UsnR2
  Digitizer not working Zdanb 1 1,232 03-17-2021, 11:45 AM
Last Post: Zdanb
  Green power LED not working Zebulon Walton 9 4,220 02-18-2021, 10:31 AM
Last Post: Zebulon Walton
  Vibrator not working - Manjaro Community Edition Beta3 Gerhard 2 2,001 11-29-2020, 07:52 AM
Last Post: saba
  Update to 3GB/32GB mainboard not working tlo 2 2,424 11-09-2020, 04:40 PM
Last Post: tlo

Forum Jump:


Users browsing this thread: 1 Guest(s)