Pinebook Pro won't wake up
#1
Hello fellow Pine-pals,

I have a PBP which I've installed Arch on and over all it works great. One annoyance has been that if I shut the lid it'll go to sleep but when I open the lid it doesn't wake up. I've tried pressing keys, tapping the power button, disconnecting and reconnecting the power...  nothing. I haven't tried accessing the serial console but that might be my next step.

Since it sleeps OK I'm thinking this isn't the magnet issue but something else.

Has anyone seen this issue before? I can't recall if it happened with Manjaro or not.

Thanks,

Duck of Death
  Reply
#2
So how do you normally get it to turn back on when this happens? I may be misreading you but I get the impression this has happened more than once.

I don't know about Arch, but there are only a few distrus that handle standby/sleep modes properly.

Probably what has happened is that you do have the magnet problem: when you close the lid, the OS goes into some kind of standby mode, but then comes back out of that mode as soon as the lid is all the way closed. If you don't have the charger connected, the battery will be depleted. Recovering from a depleted battery seems to be troublesome. I haven't had it happen, but some users have reported that you must charge with a USB-C charger to recover from this.

The first thing I'd try is a normal cold reset: hold the power button for twenty seconds to get the PBP to turn off. (It may be in a state where it's "on" but not giving you any indication). Then wait a few seconds and hold it for one second to turn it back on.

Also, if your eMMC is corrupted, you could be hard locked, as above, but with a non-bootable eMMC which will just hard lock the system again. Try booting from an SD card. Depending on the state of your eMMC, you may have to disable the eMMC to do this.
  Reply
#3
Thanks KC9UX, (ham operator?)

Sorry, I should have been clearer, this happens whenever I close the lid, even if I open it a minute later the screen is black (i.e. off, no back light) and I can't get the system to wake.

When this happens I'll just press and hold the power button for a little while and then press it on again and the system boots fine. No MMC issues that I know of. I don't see much in the logs:

Feb 04 19:33:48 sol systemd-logind[472]: Lid closed.
Feb 04 19:33:48 sol systemd-logind[472]: Suspending...
Feb 04 19:33:48 sol systemd[1]: Reached target Sleep.
Feb 04 19:33:48 sol systemd[1]: Starting Suspend...
Feb 04 19:33:48 sol systemd-sleep[14006]: Suspending system...
Feb 04 19:33:48 sol kernel: PM: suspend entry (deep)
-- Boot 2451a5090b8546a1972416e4cf6bae7d --
Feb 04 19:34:41 sol kernel: rk808-rtc rk808-rtc: registered as rtc0
Feb 04 19:34:41 sol kernel: rk808-rtc rk808-rtc: setting system clock to 2021-02-05T02:34:41 UTC (1612492481)


It's like the system doesn't receive the wake up signal at all.

My other thought is maybe I don't have all the systemd components (I just installed the basic systemd package for Arch) to have the system wake, maybe there is some special custom service the other distros use that I'm missing? Not sure...
  Reply
#4
Agreed on all accounts. What I've done when running a distru that has this issue is disable the sleep mode. I had one that I could put in sleep mode from the keyboard, Pine+Esc I think, and recover with the power button, but it would do exactly what you're experiencing with the lid switch. So I would just press the key combination and wait for the power to go out before closing the lid.

I'm not a Linux guy so if there's a way to get it working, I don't know what it is. But I suspect you can, somehow, especially since Manjaro is Arch based (I think). Perhaps someone else here knows what to do.
  Reply
#5
I've wondered the answer to this question quite a while
I suspect it is something in the kernel config or dtb
Anyway, for s3 sleep it has to be a manjaro kernel , 5.7 or 5.8 (linux-pinebookpro)
I don't know about other DE's, for KDE,, systemsettings5,
power, button events handling checked, pwr button, prompt logout dialog,,
ignore lid switch checked (my lid too has misplaced magnet)
In this specific case, the pwr button wakes it (from s3 sleep)
I am sure s2idle is different, it is not nearly as asleep,
but I have no interest in s2idle, it is barely better than screen blanking
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Selling Pinebook Pro (EU) xblack86 4 217 10-14-2021, 08:11 AM
Last Post: vajak
  Up to date guide on factory reset pinebook pro? jcarty 1 107 10-12-2021, 11:02 PM
Last Post: wdt
  Looking to get a ANSI/US Pinebook Pro ajawadmahmoud 1 236 10-09-2021, 04:55 AM
Last Post: ajawadmahmoud
  Content Streaming on the Pinebook Pro! (Netflix, Spotify, Crunchyroll, YouTube!) ImmyChan 1 194 10-07-2021, 11:42 PM
Last Post: tllim
  ANSI Pinebook Pro for sale Hemogoblin 6 388 10-07-2021, 12:41 PM
Last Post: ajawadmahmoud
  Looking to buy a Pinebook Pro US Stucht13 12 1,673 10-01-2021, 07:27 AM
Last Post: Hemogoblin
  Pinebook got wet walterbe 8 520 09-25-2021, 01:12 PM
Last Post: biketool
  ISO/UK Pinebook Pro for sale mstevens 4 485 09-17-2021, 10:49 AM
Last Post: mstevens
  Testing Some More Games on the Pinebook Pro! ImmyChan 3 385 09-16-2021, 07:06 AM
Last Post: poVoq
  Pinebook Pro (ISO) for sale from Germany to Europe and UK 1yk0s 1 545 09-08-2021, 10:55 AM
Last Post: cypresstwist

Forum Jump:


Users browsing this thread: 1 Guest(s)