Wi-Fi Issues (Plasma and Lomiri)
#1
Is anyone else having Wi-Fi trouble connecting on Manjaro?  I've only had the phone a few days (Plasma Mobile CE) and I got the wifi working initially for a couple days, but now it says it's connected to my network but it can't load any websites and there's an ! next to the wifi icon.  Then on Manjaro Lomiri SD card it can't find any nearby networks nor connect when I type it in manually, and the icon shows not connected.

However, I have loaded PostmarketOS and Mobian and they have no problems connecting to wifi.  So it seems to be a Manjaro issue?
  Reply
#2
oddly enough that is one thing i didnt have issues with, however i also have all wifi in my home on static address perhaps try that? i run all my devices threw pi hole to clean out add, thus the reason for statics
  Reply
#3
(02-05-2021, 12:39 PM)radiohead Wrote: oddly enough that is one thing i didnt have issues with,  however i also have all wifi in my home on static address perhaps try that?  i run all my devices threw pi hole to clean out add,  thus the reason for statics
I'm still new to networking so I'm not sure the implications of doing static vs. dynamic ip addressing.  But I still don't see why it should have to be static.  Other distros connect fine dynamically.  
What does running your devices through a pi hole do? Is that a firewall?  What do you mean by "clean out add"?
  Reply
#4
Yeah, I would like to know that too. I am interested about this "clean out add" part.
  Reply
#5
(02-08-2021, 07:45 AM)jamie22 Wrote: Yeah, I would like to know that too. I am interested about this  "clean out add" part.
It's probably supposed to be "clean out ads" since Pi-hole is an ad blocker. You can use a Pi or some other device and set up Pi-hole on it and then use that device as the DNS server for your devices and/or your whole network. Pi-hole filters out unwanted DNS requests based on blocking lists (ads, tracking etc.) and then forwards the "clean" DNS requests to another DNS server of your choice to actually be resolved. I don't know why you would need static IP addresses for your devices in that case. It does make sense however to use a static IP address for the Pi-hole itself so it can be permanently set as a DNS server.
Regarding the problem itself: For me wifi on Manjaro Phosh has also been somewhat unreliable. It does work most of the time, but often it takes a long time to connect after deep sleep and sometimes fails to do so. It's been much more reliable for me on Mobian lately.
  Reply
#6
(02-08-2021, 08:14 AM)kqlnut Wrote:
(02-08-2021, 07:45 AM)jamie22 Wrote: Yeah, I would like to know that too. I am interested about this  "clean out add" part.
It's probably supposed to be "clean out ads" since Pi-hole is an ad blocker. You can use a Pi or some other device and set up Pi-hole on it and then use that device as the DNS server for your devices and/or your whole network. Pi-hole filters out unwanted DNS requests based on blocking lists (ads, tracking etc.) and then forwards the "clean" DNS requests to another DNS server of your choice to actually be resolved. I don't know why you would need static IP addresses for your devices in that case. It does make sense however to use a static IP address for the Pi-hole itself so it can be permanently set as a DNS server.
Regarding the problem itself: For me wifi on Manjaro Phosh has also been somewhat unreliable. It does work most of the time, but often it takes a long time to connect after deep sleep and sometimes fails to do so. It's been much more reliable for me on Mobian lately.
You're probably right about the "clean out ads" statement.   I've been using Mobian too, and the Wi-fi has been working great.  I'm trying to install protonvpn on it but no luck so far.
  Reply
#7
(02-02-2021, 09:55 PM)PineSupporter Wrote: Is anyone else having Wi-Fi trouble connecting on Manjaro?  I've only had the phone a few days (Plasma Mobile CE) and I got the wifi working initially for a couple days, but now it says it's connected to my network but it can't load any websites and there's an ! next to the wifi icon.  Then on Manjaro Lomiri SD card it can't find any nearby networks nor connect when I type it in manually, and the icon shows not connected.

However, I have loaded PostmarketOS and Mobian and they have no problems connecting to wifi.  So it seems to be a Manjaro issue?
Yep, On lomiri (SDcard) first boot finds and connects to wifi networks fine BUT if I ever turn wifi off in settings then it will never find or connect to (including hidden) wifi networks again. I've tested it a few times now so I am reflashing the SD and I plan on not turning off wifi via the settings toggle. Big Grin
  Reply
#8
(02-11-2021, 06:19 PM)MtnSk8 Wrote:
(02-02-2021, 09:55 PM)PineSupporter Wrote: Is anyone else having Wi-Fi trouble connecting on Manjaro?  I've only had the phone a few days (Plasma Mobile CE) and I got the wifi working initially for a couple days, but now it says it's connected to my network but it can't load any websites and there's an ! next to the wifi icon.  Then on Manjaro Lomiri SD card it can't find any nearby networks nor connect when I type it in manually, and the icon shows not connected.

However, I have loaded PostmarketOS and Mobian and they have no problems connecting to wifi.  So it seems to be a Manjaro issue?
Yep, On lomiri (SDcard) first boot finds and connects to wifi networks fine BUT if I ever turn wifi off in settings then it will never find or connect to (including hidden) wifi networks again. I've tested it a few times now so I am reflashing the SD and I plan on not turning off wifi via the settings toggle. Big Grin
Yes exactly what happened to me when I toggled off the Wi-fi, it never recognized any networks again.  Good idea, I guess I'll have to re-flash again too.
  Reply
#9
(02-13-2021, 07:59 PM)PineSupporter Wrote:
(02-11-2021, 06:19 PM)MtnSk8 Wrote:
(02-02-2021, 09:55 PM)PineSupporter Wrote: Is anyone else having Wi-Fi trouble connecting on Manjaro?  I've only had the phone a few days (Plasma Mobile CE) and I got the wifi working initially for a couple days, but now it says it's connected to my network but it can't load any websites and there's an ! next to the wifi icon.  Then on Manjaro Lomiri SD card it can't find any nearby networks nor connect when I type it in manually, and the icon shows not connected.

However, I have loaded PostmarketOS and Mobian and they have no problems connecting to wifi.  So it seems to be a Manjaro issue?
Yep, On lomiri (SDcard) first boot finds and connects to wifi networks fine BUT if I ever turn wifi off in settings then it will never find or connect to (including hidden) wifi networks again. I've tested it a few times now so I am reflashing the SD and I plan on not turning off wifi via the settings toggle. Big Grin
Yes exactly what happened to me when I toggled off the Wi-fi, it never recognized any networks again.  Good idea, I guess I'll have to re-flash again too.

Update: On Alfa3 I was able to configure a connection to my wifi router as a hidden network in the settings gui. Then after a reboot it was connected!
  Reply
#10
I installed Manjaro Plasma Mobile to EMMC yesterday and had the Wifi malfunction, unable to turn on.

I adopted the solution I had for Mobian - remove and reinstall Realtek driver when coming out of suspend:
https://forum.pine64.org/showthread.php?...8#pid87988

That solved the issues I had on Mobian.
Otherwise:
Code:
sudo rmmod 8723cs && sudo modprobe 8723cs
might do the trick if and when it happens to you.
Pinephone v1.2 UBports CE. Adelaide, Australia using Aldimobile SIM with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Plasma Mobile "stable" currently broken acrux 8 220 Today, 02:08 AM
Last Post: mouffa
  Cannot run onionshare-gui on pp manjaro plasma scott_VYuCAbn3k1NFK 0 33 Yesterday, 11:07 PM
Last Post: scott_VYuCAbn3k1NFK
  User Interface (Plasma Mobile) Queries dgiffin 1 45 Yesterday, 06:24 PM
Last Post: ryo
  Manjaro (Plasma OS) bugs/ issues FOSSagent0 24 3,423 06-01-2021, 06:56 AM
Last Post: acrux
  xmpp&jabber client for Manjaro Plasma mobile acrux 8 985 06-01-2021, 02:50 AM
Last Post: acrux
  no unlock screen (plasma mobile) dieselnutjob 6 470 05-26-2021, 05:43 PM
Last Post: CareAgain
  Fixed - Do not use Plasma Mobile Settings -> Screen application for now acrux 2 667 05-12-2021, 06:09 AM
Last Post: acrux
  What is the status of the GPS on plasma mobile? Athansor 0 280 05-09-2021, 04:57 AM
Last Post: Athansor
  Ensure Up To Date - Manjaro Plasma Discover Package Manager Sources Linux2thabone 0 271 05-05-2021, 11:15 AM
Last Post: Linux2thabone
  Manjaro/Plasma Mobile, Lock Screen issues after update gamerminstrel 2 373 05-05-2021, 10:23 AM
Last Post: kat22

Forum Jump:


Users browsing this thread: 1 Guest(s)