(potential) work-around for Playstore authentication issue
#16
This continues to be an issue for my Pine64.

For my Pine64, it occurs consistently, sort of.
  • Affects all Android images -- rooted, so-called "un-rooted", RemixOS
  • GP Store will always work, initially, upon booting for the first time
  • GP Store will eventually stop permitting app downloads and app rating submissions. Even if it's working now,  give it time...
  • Once it fails, it continues to fail, until you apply a work-around fix, or re-image.
  • Once a workaround fix stops working, it continues to fail. You must try a different fix, or re-image.
(The DD images of Android all test as rooted.)

What varies:
  • The length of time that GP Store works. When you boot for the first time, or succesfully apply a workaround fix, it will work... but eventually it stops. You may get downloads & rating submissions working for hours, or only seconds. Typically, you can get in a few installs, while it's working, before it quits again. You many only get 1 install in, though, or none at all. In a one hour session of Android, you may apply fixes several times, without rebooting.
  • Sometimes, workaround fixes stop working. 
  • Pop-up vs. Notification. How the app informs the user of failure varies. A pop-up error message likely mentions DF-DLA-15. An Android notification always mentions authentication failure.
  • Multiple notifications vs. 1 notification maximum -- sometimes, you must clear the notification to be informed of future errors; other times, you can get multiple notifications
  • Various fixes, sorted by speed:
  1. Settings / Accounts / Add New Account / Google
  2. Settings / Accounts / Add New Account / Google / enter gmail of existing Google account
  3. Settings / Accounts / select account / Remove Account / Add New Account / Google / enter gmail of account you just removed
  4. Clearing GP Store and GP services caches, rebooting
  5. Wiping the Dalvik partition, rebooting
  6. Reimaging your microSD card, booting
Other things I've tried, that never helped or seem unrelated to this issue:
  • Gmail accounts with 2-step verification, vs. those without
  • Using only a single Gmail account, vs. using multiple Gmail accounts
  • Using Gmail accounts with Play Store credit, vs. those without a payment method
  • Rebooting
  • Using other images of Android
  • Using a time app to document time clock differences
  • Turning account syncing off/on
  • Various power adapters
What I have not yet tried:
  • Heat sinks / fans / cooling my house more
  • RTC battery
  • Shorter Cat6
What I've had trouble trying:
  • Wi-fi dongle
  • Mock Location -- there doesn't seem to be a way to set this
  • Using a time app to reset the time from NTP
Few have voiced their frustration on pine64.pro, which seems odd, considering the various threads on this issue. Maybe they didn't want to bother registering a new ID there?
NexusDude of Central Texas
  • Setup: Pine64+ 2GB, On/Off button, RTC battery, 5V fan, LG 1.8A power adapter, Cat6 Ethernet, HDMI to TV, USB keyboard & mouse, SanDisk Ultra mSD "32GB" (28.7GB). Using Win32DiskImager.
  • Best OS experiences: Debian XFCE >> Android Lollipop > the rest


Messages In This Thread
RE: (potential) work-around for Playstore authentication issue - by NexusDude - 06-30-2016, 12:45 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  USB GPS dongles that work with Android on Pine64+ ? trondkj 2 4,650 11-16-2017, 02:14 PM
Last Post: Skivholme
  Playstore Selections Limited in 7.1 TV CharlieB 2 3,682 10-19-2017, 12:24 PM
Last Post: Luke
  Does snapchat work on pine64 with android? user875545 1 4,422 08-29-2017, 12:05 AM
Last Post: tllim
  VPN issue on Pine64 pinea64.edison 4 6,751 06-27-2017, 12:25 PM
Last Post: milkaca
  No Intenet Access Need Help Diagnosing Underlying Issue Bob123456789 10 11,722 06-02-2017, 01:32 PM
Last Post: Bob123456789
  anyone make pine64 lcd hdmi work simultaneously bokeer 4 7,251 12-11-2016, 05:57 PM
Last Post: Luke
  ethernet does not work with Android 5.1.1 Image Release 20160711 (Known Problem) mathiraj 18 24,886 10-29-2016, 04:31 AM
Last Post: joe
  pine64 a piece of work water 4 6,185 10-28-2016, 07:41 AM
Last Post: jkmooney
  buring image with 'dd' on linux doesn't work (Solved) mathiraj 2 5,813 10-17-2016, 11:42 AM
Last Post: mathiraj
Sad Airmouse doesn't work on any Android ameth 0 2,696 09-11-2016, 06:29 AM
Last Post: ameth

Forum Jump:


Users browsing this thread: 2 Guest(s)