(potential) work-around for Playstore authentication issue
#4
(06-08-2016, 03:19 PM)Luke Wrote:
(06-08-2016, 12:29 PM)Danja Wrote:
(06-08-2016, 06:55 AM)Luke Wrote: All credit goes to Keex

At the moment this is a potential work-around for the issue since I do not have a spare Pine64 to reproduce the issue. So if you are experiencing this problem please leave feedback below if this solution worked. 

Keex wrote: 

"Haven't read the whole thread, but I encountered a problem with the Playstore before.


The problem was the System Time. The Pine doesn't have a real time clock, and obviously doesn't get the time from the carrier (like smartphones). Hence it's just set to some random value a few years ago.
In my case I couldn't use the playstore (or any other Google apps for this matter). After I set the system time correctly, the apps worked fine. In the end I used an app that set the system time after booting automatically (requires root)." (original post

This didn't work for me, but what does work is if I go to the accounts page and attempt to add a new account using the same email as my existing, it will error and tell you that the account already exists on the device and then allow me to install things again.

Darn it :/ I thought we had a reliable temporary solution. Just for reference - could you write precisely what you did with the clock: manually set current time and date ?

The first thing I did to try and fix it was change the clock to right time, as I saw it was out. With the clock to the right time difference and had it auto set. It still gave me the little triangle in the top corner that in the drop down asked me to re-authenticate. 

The I force stopped the processes and cleared the caches and no luck.

For the hell of it I tried to add my account again with the old one still there to see if it wasn't registering properly and would duplicate, it gave me the error as it should that it was already added and then I re-tried the play store and it worked.

Edit: This fixes the issue repeatedly for me too each time it happens, it wasn't just a one-time thing.


Messages In This Thread
RE: (potential) work-around for Playstore authentication issue - by Danja - 06-08-2016, 04:49 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  USB GPS dongles that work with Android on Pine64+ ? trondkj 2 4,650 11-16-2017, 02:14 PM
Last Post: Skivholme
  Playstore Selections Limited in 7.1 TV CharlieB 2 3,681 10-19-2017, 12:24 PM
Last Post: Luke
  Does snapchat work on pine64 with android? user875545 1 4,421 08-29-2017, 12:05 AM
Last Post: tllim
  VPN issue on Pine64 pinea64.edison 4 6,745 06-27-2017, 12:25 PM
Last Post: milkaca
  No Intenet Access Need Help Diagnosing Underlying Issue Bob123456789 10 11,715 06-02-2017, 01:32 PM
Last Post: Bob123456789
  anyone make pine64 lcd hdmi work simultaneously bokeer 4 7,250 12-11-2016, 05:57 PM
Last Post: Luke
  ethernet does not work with Android 5.1.1 Image Release 20160711 (Known Problem) mathiraj 18 24,879 10-29-2016, 04:31 AM
Last Post: joe
  pine64 a piece of work water 4 6,183 10-28-2016, 07:41 AM
Last Post: jkmooney
  buring image with 'dd' on linux doesn't work (Solved) mathiraj 2 5,812 10-17-2016, 11:42 AM
Last Post: mathiraj
Sad Airmouse doesn't work on any Android ameth 0 2,696 09-11-2016, 06:29 AM
Last Post: ameth

Forum Jump:


Users browsing this thread: 2 Guest(s)