pbp no longer boots
If you get boot logo, then the kernel is starting (if it's the bootsplash), or userspace is running if it's the desktop starting screen. So you've gotten significantly farther than u-boot. That really points to a battery problem. Power draw will go up as the GPU is enabled and all the CPU cores run stuff during start up, where you had the crash. One could try measuring battery cell voltage and see if it's dropping too low. There's an alarm signal for SOC and RTT on the battery monitor. Too bad they don't go to a LED.
(12-02-2020, 06:36 PM)wdt Wrote: I don't know about usbC, but if you leave barrel charger in a long time, red (charge) led WILL go out (pbp off)
Manjaro mounts by label, a fruitful source of (kernel) confusion, if there are 2 partitions with same label ...
and,, manjaro does not seem to have best uboot, do realize that uboot on emmc will be one used
I strongly suggest mrfixit's debian, do his update (NOT apt update) as a recovery SD
Use it with disabled emmc, then flip switch and rebind
If you have a linux box, check that extlinux root= is right, also fstab
If you want to use manjaro as a recovery SD, change label and extlinux and fstab
hi thanks! I have a couple clarifying questions. This release https://github.com/mrfixit2001/debian_de...tag/191226 is the one you mean? I don't understand what you mean by his update? Flip the switch while booted into that debian sd? what do you mean by rebind? I do have another linux machine. I'm not sure how to check that extlinux root= and fstab is right. I know that's a lot of questions if you send pertinent documentation I can read that instead.

okay so after sitting with the barrel charger plugged in for over 36 hours I tried again with my usb c power bank (18 w pd quick charging) plugged that in and it booted! says battery is at 1% (up from 0%) and charging now. Could my barrel charger be defective? or my battery be dead/dying? I did notice that the red charging light blinks with the barrel charger. is that normal? I'm going to leave it on the usb c charger for a while. is there any wiki documentation of these battery issues? I'll submit a PR to update the documentation if there isn't. should this be in the troubleshooting doc? https://wiki.pine64.org/wiki/Pinebook_Pr...ble_switch
Blinking indicates a fault,,info,
Does it blink with usbC?
One person found that with a full charge with usbC, then barrel charger worked OK again
Yes, that is the mrfixit distro, the update is kernel and uboot, uboot IS installed
(IIRR /usr/bin/mrfixit_update.sh,, NOTE, only applies to THIS distro)
bind.... if you don't get switch timing right (emmc off,, 2 second window to switch on,, emmc is present)
then,, emmc switch on
echo fe330000.sdhci >/sys/bus/platform/drivers/sdhci-arasan/{un,}bind
But you don't need to do this, you have a charging problem, not a bad uboot on emmc problem

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook pro no longer boots xsquared93 7 7,250 02-13-2021, 09:39 AM
Last Post: wdt
Shocked My pbp no longer boots sunjam 2 2,989 12-02-2020, 11:05 PM
Last Post: sunjam
  New Pinebook Pro, only boots 50% of the time micnd90 8 7,561 09-08-2020, 01:25 PM
Last Post: wdt
Exclamation [SOLVED] PBP will no longer power on s3rvant 10 9,902 07-04-2020, 01:57 PM
Last Post: prokofiev
  emmc boots intermittently? haziz 7 6,966 06-08-2020, 07:22 PM
Last Post: mammbo3

Forum Jump:

Users browsing this thread: 1 Guest(s)