Getting analog audio/sound to work (headphones socket) on debian
#1
Music 
Hi,

I've finally started playing with my Pine64+ board, and have been able to get both ubuntu and debian systems up and running thanks to the great work by longsleep and lenny. I am setting up a headless system which will probably be a lightweight webserver / database server for sensors and a few other bits and pieces... not 100% sure yet. However, in the meantime, since I have it sat on my desk atm, I thought it would be fun to hook it up to some internet radio, and let it do that for a while... but how do I get the audio to work? I don't have anything plugged into the HDMI, so can't use that for audio. And nothing seems to be coming out of the headphones jack, although mplayer seems to be playing fine, bar an error about the output device!!!

I started with the Debian Base (3.10.65 BSP) image, and applied the Debian Base (3.10.65 BSP) rootfs (although I suspect I didn't actually need too! Rolleyes ) from pine64.pro. I then updated uboot and the kernel with the included scripts. I setup my wireless connection, and ditched the eithernet cord. I changed the built-in user, and have SSH working. So everything else seems to be working so far. I noticed there was a mplayer-play script, but didn't even let mplayer run - mplayer stops due to no hardware device (e.g.  /usr/local/sbin/mplayer-play.sh http://80.237.154.83:8120), whereas a simple mplayer http://80.237.154.83:8120 at least comes back with errors. Does anyone have any thoughts what I should do... is there something else I need to install or configure, or is this one of those "it doesn't work yet" bits? I came across another thread, but it didn't have any useful information anymore as links seem to have changed... I tried installing the alsa-tools alsa-utils libsound2 etc but that didn't send to help... I haven't tried adding pulseaudio yet.

Thanks in advance,
Pete


Code:
Connecting to server 80.237.154.83[80.237.154.83]: 8120...
Name   : Radio Landsberg International from Germany: Inter-cultural & multi-lingual
Genre  : International
Website: http://www.radiolandsberg.international
Public : yes
Bitrate: 128kbit/s
Cache size set to 320 KiB
Cache fill:  0.00% (0 bytes)
Detected file format: Audio only
Selected audio codec: MPEG 1.0/2.0/2.5 layers I, II, III [mpg123]
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
AO: [pulse] Init failed: Connection refused
[AO_ALSA] alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
[AO_ALSA] alsa-lib: conf.c:4259:(_snd_config_evaluate) function snd_func_card_driver returned error: No
 file or directory
[AO_ALSA] alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
[AO_ALSA] alsa-lib: conf.c:4259:(_snd_config_evaluate) function snd_func_concat returned error: No such
 or directory
[AO_ALSA] alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
[AO_ALSA] alsa-lib: conf.c:4259:(_snd_config_evaluate) function snd_func_refer returned error: No such f
or directory
[AO_ALSA] alsa-lib: conf.c:4738:(snd_config_expand) Evaluate error: No such file or directory
[AO_ALSA] alsa-lib: pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
[AO_ALSA] Playback open error: No such file or directory
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
[JACK] cannot open server
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
[AO_ALSA] alsa-lib: conf.c:4259:(_snd_config_evaluate) function snd_func_card_driver returned error: No
 file or directory
[AO_ALSA] alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
[AO_ALSA] alsa-lib: conf.c:4259:(_snd_config_evaluate) function snd_func_concat returned error: No such
 or directory
[AO_ALSA] alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
[AO_ALSA] alsa-lib: conf.c:4259:(_snd_config_evaluate) function snd_func_refer returned error: No such f
or directory
[AO_ALSA] alsa-lib: conf.c:4738:(snd_config_expand) Evaluate error: No such file or directory
[AO_ALSA] alsa-lib: pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
[AO SDL] Unable to open audio: No available audio device
AO: [null] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   2.2 (02.1) of -0.0 (unknown)  0.7% 35%
ICY Info: StreamTitle='Dick Charlesworth _ His City Gents - That_s When I_ll Come Back To You';StreamUrl
tp://www.radiolandsberg.international';
A:  41.2 (41.2) of -0.0 (unknown)  0.6% 45%

Just some further information...

I added pulseaudio, and it got rid of the error, but didn't seem to be able to configure it (had no idea what I was doing though either!!).

I plugged my computer monitor which has HDMI audio output option, rebooted the pine and tried mplayer again... and it worked, but was clicking. I seemed to remember that that exact issue was the bug report I linked above, so I thought I'd just remove pulseaudio and try without it. Another reboot, and HDMI audio does indeed work, but for the steam I'm using as a test, it only plays the intro file, and then mp3123 gives up... whereas if I play from a SSH terminal with no HDMI audio, it get error messages, but at least it seems to continue onto playing the current track....
  Reply


Messages In This Thread
Getting analog audio/sound to work (headphones socket) on debian - by pfeerick - 06-01-2016, 03:15 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian installer on Pine A64+ but no hdmi mrwick 1 1,979 07-28-2020, 01:49 PM
Last Post: kuleszdl
  Debian Pine64 h264/5 Video under vlc ozcy 6 5,631 04-15-2020, 05:27 AM
Last Post: dmitrymyadzelets
  OMV/debian/systemd: how to start the network kittyland 0 1,095 12-10-2019, 05:29 PM
Last Post: kittyland
  Debian 10 (Buster) in deep freeze - includes support for Pine64+ amp 5 4,066 07-22-2019, 09:29 PM
Last Post: amp
  Pine64 Debian Stretch/mainline [4.14.7] CallMeFoxie 50 55,260 07-22-2019, 09:24 PM
Last Post: amp
  Installing Debian with the Debian Installer (Buster RC1) amp 1 1,984 06-28-2019, 12:35 PM
Last Post: Kaarme42
  Script to build pure Debian images for Pine64+ amp 1 1,502 05-01-2019, 09:09 PM
Last Post: tllim
  Debian (Stretch) for Pine64-LTS wgray 2 2,232 04-04-2019, 09:54 PM
Last Post: wgray
  Is there just one fuctioning Debian Desktop image? KNERD 7 5,739 03-29-2019, 02:00 AM
Last Post: desai_amogh
  (ARCHIVED) Debian Jessie Images (3.10.102 BSP Kernel) New Release lenny.raposo-pine64.pro 259 218,936 05-21-2018, 06:30 AM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)