Mobile Data not working
#1
Hello.
I got my pinephone a few weeks ago, played around with different operating systems and environments. But it was only yesterday, that I first tried to use it with a SIM card, because I want to start using it as a daily driver. I'm using the Manjaro 3gb CE.
Calls and SMS work good on postmarketOS, but mobile Internet doesn't. So I'm wondering, if this is just a software problem (I tried various operating systems including the preinstalled and updated Manjaro, postmarketOS, ubports and by using the multiboot image I also tried PureOS, KDE Neon and some other) or if my network provider just isn't supported (using O2 Germany). If the second is the case, I'm willing to change the provider, but I must be sure, if this is really the problem. APN was selected automatically in postmarketOS and seems to be correct according to research I did (pinternet.interkom.de). The status bar shows '4G' and mobile data should work in this area.
There is also a second problem, that the signal gets lost from time to time to an unknown state and gets reconnected after a few minutes, maybe this is related to the non-functional mobile data. I read some older threads describing this problem as well.
Finally, I would like to use the change to thank Pine64 and the community for making all this possible. Thank you!
Greetings
  Reply
#2
Well, it is working now (on pmOS) after manually entering the APN, although I'm not sure why exactly it is working. Testing it since an hour without issues.
  Reply
#3
Things are getting strange ...
It used to work for for a couple of hours (I don't know why) - had constantly mobile internet without any issues - but after I did a reboot it doesn't work anymore ...
  Reply
#4
Hello,

first of all, follow the following:
https://wiki.pine64.org/wiki/PinePhone_APN_Settings

For me the mobile internet works without any problems since I have created new APN (profile) in my pmOS with Phosh as per documentation. Did test it after reboot as well and I see no problems.

Is the APN profile still available after you have rebooted?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Modem stops working after CRUST Trbl 3 298 11-26-2020, 10:28 AM
Last Post: Ph42oN
  Mobile Carriers in the United States aren 105 27,287 11-17-2020, 03:09 PM
Last Post: KC9UDX
  No Voice or Text on Inland Cellular (non-MVNO) but Internet Data Works! calinb 14 639 11-17-2020, 02:57 PM
Last Post: rocket2nfinity
  The questions that mobile phone reviewers never ask amosbatto 6 812 11-03-2020, 04:58 PM
Last Post: ryo
  Mobile Roaming Not Working Lousy Fisherman 2 776 10-13-2020, 12:33 PM
Last Post: bcnaz
  What OS is working? K_Research 10 1,617 09-14-2020, 08:26 PM
Last Post: SwordfishII
  Online account (google) not working RodMyers 0 390 09-02-2020, 10:12 AM
Last Post: RodMyers
  Lucky Mobile Compatibility (Canada) Potts 2 550 08-30-2020, 08:02 PM
Last Post: bcnaz
  The strategic advantages of Phosh for mobile Linux amosbatto 9 2,341 08-25-2020, 12:48 PM
Last Post: Boern
Question Mobile Carriers 67comet 2 1,154 07-29-2020, 05:38 AM
Last Post: 67comet

Forum Jump:


Users browsing this thread: 1 Guest(s)