Mobile Data not working
#1
Hello.
I got my pinephone a few weeks ago, played around with different operating systems and environments. But it was only yesterday, that I first tried to use it with a SIM card, because I want to start using it as a daily driver. I'm using the Manjaro 3gb CE.
Calls and SMS work good on postmarketOS, but mobile Internet doesn't. So I'm wondering, if this is just a software problem (I tried various operating systems including the preinstalled and updated Manjaro, postmarketOS, ubports and by using the multiboot image I also tried PureOS, KDE Neon and some other) or if my network provider just isn't supported (using O2 Germany). If the second is the case, I'm willing to change the provider, but I must be sure, if this is really the problem. APN was selected automatically in postmarketOS and seems to be correct according to research I did (pinternet.interkom.de). The status bar shows '4G' and mobile data should work in this area.
There is also a second problem, that the signal gets lost from time to time to an unknown state and gets reconnected after a few minutes, maybe this is related to the non-functional mobile data. I read some older threads describing this problem as well.
Finally, I would like to use the change to thank Pine64 and the community for making all this possible. Thank you!
Greetings
#2
Well, it is working now (on pmOS) after manually entering the APN, although I'm not sure why exactly it is working. Testing it since an hour without issues.
#3
Things are getting strange ...
It used to work for for a couple of hours (I don't know why) - had constantly mobile internet without any issues - but after I did a reboot it doesn't work anymore ...
#4
Hello,

first of all, follow the following:
https://wiki.pine64.org/wiki/PinePhone_APN_Settings

For me the mobile internet works without any problems since I have created new APN (profile) in my pmOS with Phosh as per documentation. Did test it after reboot as well and I see no problems.

Is the APN profile still available after you have rebooted?


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Mobile Carriers 67comet 22 4,472 Today, 05:08 AM
Last Post: AwHereWeGoAgain
  After flashing UT on eMMC Convergence package not working anymore dfjdw8 0 104 06-11-2021, 12:28 AM
Last Post: dfjdw8
  T-mobile USA region celluar issue FOSSagent0 6 710 06-07-2021, 06:02 AM
Last Post: FOSSagent0
  Cellular Data, Mobian - "No WWAN Adapter Found" justneedsomedatathanks 2 357 05-03-2021, 03:08 PM
Last Post: awaittrot
  New Zealand network providers mobile data Linux2thabone 2 487 04-30-2021, 07:54 PM
Last Post: Linux2thabone
  LG is shutting down their mobile production daniel_mazurkiewicz 4 607 04-07-2021, 05:16 PM
Last Post: dsimic
  Data downloading not working with SIM IMSAI8080 4 775 03-15-2021, 08:39 AM
Last Post: IMSAI8080
  Problems updating KDE Plasma Mobile OS IMSAI8080 1 407 03-07-2021, 01:12 PM
Last Post: mark1250
  Working modem? Barugon 34 4,396 03-05-2021, 07:07 PM
Last Post: Barugon
  4G VoLTE calls confirmed working with carrier x dcinoz 4 1,937 02-19-2021, 06:38 AM
Last Post: zetabeta

Forum Jump:


Users browsing this thread: 2 Guest(s)