My Daily QA - 2020-09-02
#1
Be aware, these tests are being executed using an out-of-box testing methodology. All tests are preformed with minimal interaction/setup of devices outside of: OS imaging/updating,  SIM installation, Wifi Configuration,  and Power Cycling the devices.

Results: ubports/2020-09-02-TMobile

Conclusion: This OS is not ready for the device to become a daily driver.

Notes: Had bamboozeled myself this morning, I thought that 4g outbound calls were finally fixed..... plot twist I left the phone in 3g mode from yesterdays testing...... Damn. Anyways, no real progress. Not much action on the issues tracker. (to be expected to be honest.) Overall the OS hasn't been laggy for some time. The new settings application updates are nice. Worked out a lot of bugs that caused the settings menu to hang when opening. All in all, this OS is making progress. Please feel free to hit up the ubports forum to apply a little 'pressure' to the OS development side.  Also, please feel free to leave your feedback on this post. Let us know what your seeing and we will at least attempt to confirm the behavior to validate your experience.

Issues:
Failed outbound 4G calls kills call audio.
Unable to send 3G SMS Since Dev-158
4G outbound calls broken.
Phone gets stuck in a weird lock state when spamming power button.
#2
(09-02-2020, 09:04 AM)plainenough Wrote: Be aware, these tests are being executed using an out-of-box testing methodology. All tests are preformed with minimal interaction/setup of devices outside of: OS imaging/updating,  SIM installation, Wifi Configuration,  and Power Cycling the devices.

Results: ubports/2020-09-02-TMobile

Conclusion: This OS is not ready for the device to become a daily driver.

Notes: Had bamboozeled myself this morning, I thought that 4g outbound calls were finally fixed..... plot twist I left the phone in 3g mode from yesterdays testing...... Damn. Anyways, no real progress. Not much action on the issues tracker. (to be expected to be honest.) Overall the OS hasn't been laggy for some time. The new settings application updates are nice. Worked out a lot of bugs that caused the settings menu to hang when opening. All in all, this OS is making progress. Please feel free to hit up the ubports forum to apply a little 'pressure' to the OS development side.  Also, please feel free to leave your feedback on this post. Let us know what your seeing and we will at least attempt to confirm the behavior to validate your experience.

Issues:
Failed outbound 4G calls kills call audio.
Unable to send 3G SMS Since Dev-158
4G outbound calls broken.
Phone gets stuck in a weird lock state when spamming power button.
All the same sentiment, glad you feel they have been polishing the stuff that already functions. I think it would be better for them to drop by here once in a while to check for our feedback rather than posting to ub ports forum. For one their forum is not very intuitive, but also we have so much useful data and feedback here as well as success from other distros that each of us couldnt possibly remember all of or deliver to them concisely. I did send Luke a pm asking him to extend them an invite to join our forum. Hopefully they do!
#3
(09-02-2020, 09:04 AM)plainenough Wrote: Be aware, these tests are being executed using an out-of-box testing methodology. All tests are preformed with minimal interaction/setup of devices outside of: OS imaging/updating,  SIM installation, Wifi Configuration,  and Power Cycling the devices.

Results: ubports/2020-09-02-TMobile

Conclusion: This OS is not ready for the device to become a daily driver.

Notes: Had bamboozeled myself this morning, I thought that 4g outbound calls were finally fixed..... plot twist I left the phone in 3g mode from yesterdays testing...... Damn. Anyways, no real progress. Not much action on the issues tracker. (to be expected to be honest.) Overall the OS hasn't been laggy for some time. The new settings application updates are nice. Worked out a lot of bugs that caused the settings menu to hang when opening. All in all, this OS is making progress. Please feel free to hit up the ubports forum to apply a little 'pressure' to the OS development side.  Also, please feel free to leave your feedback on this post. Let us know what your seeing and we will at least attempt to confirm the behavior to validate your experience.

Issues:
Failed outbound 4G calls kills call audio.
Unable to send 3G SMS Since Dev-158
4G outbound calls broken.
Phone gets stuck in a weird lock state when spamming power button.
I know you have been having issues on T-mobile and verizon for a while with regards to calls and SMS. For some reason i havent had any issues for a while so i am not sure how the providers are different. 

I do agree the current functions are being polished which is a good thing. I tried version #179 earlier and it seems the camera doesnt have as much lag when updating the screen. There is still a lag but its definitely snappier for me. I am looking forward to getting the mms and camera functioning as i make documentaries.
#4
(09-02-2020, 10:39 AM)Hobgoblin Wrote:
(09-02-2020, 09:04 AM)plainenough Wrote: Be aware, these tests are being executed using an out-of-box testing methodology. All tests are preformed with minimal interaction/setup of devices outside of: OS imaging/updating,  SIM installation, Wifi Configuration,  and Power Cycling the devices.

Results: ubports/2020-09-02-TMobile

Conclusion: This OS is not ready for the device to become a daily driver.

Notes: Had bamboozeled myself this morning, I thought that 4g outbound calls were finally fixed..... plot twist I left the phone in 3g mode from yesterdays testing...... Damn. Anyways, no real progress. Not much action on the issues tracker. (to be expected to be honest.) Overall the OS hasn't been laggy for some time. The new settings application updates are nice. Worked out a lot of bugs that caused the settings menu to hang when opening. All in all, this OS is making progress. Please feel free to hit up the ubports forum to apply a little 'pressure' to the OS development side.  Also, please feel free to leave your feedback on this post. Let us know what your seeing and we will at least attempt to confirm the behavior to validate your experience.

Issues:
Failed outbound 4G calls kills call audio.
Unable to send 3G SMS Since Dev-158
4G outbound calls broken.
Phone gets stuck in a weird lock state when spamming power button.
I know you have been having issues on T-mobile and verizon for a while with regards to calls and SMS. For some reason i havent had any issues for a while so i am not sure how the providers are different. 

I do agree the current functions are being polished which is a good thing. I tried version #179 earlier and it seems the camera doesnt have as much lag when updating the screen. There is still a lag but its definitely snappier for me. I am looking forward to getting the mms and camera functioning as i make documentaries.


My issues stem from forcing 4G as far as calls are concerned. Since both of my carriers support LTE calling in my area it gets set as the preferred. Chances are, you are being downgraded on the fly, as far as the texting goes though; it is interesting to see the outbound issues on 3G. Could be carrier specific, I'm not sure. At this point in time I am just hoping to get more confirmation out of the development group.

The camera has seen improvements. I have noticed subtle improvements over time, although those notes are not often captured in my test cases.  It is really hard to describe 'less laggy' four times in a row and retain some meaning that differentiates the results from the last week.
#5
(09-02-2020, 10:54 AM)plainenough Wrote:
(09-02-2020, 10:39 AM)Hobgoblin Wrote:
(09-02-2020, 09:04 AM)plainenough Wrote: Be aware, these tests are being executed using an out-of-box testing methodology. All tests are preformed with minimal interaction/setup of devices outside of: OS imaging/updating,  SIM installation, Wifi Configuration,  and Power Cycling the devices.

Results: ubports/2020-09-02-TMobile

Conclusion: This OS is not ready for the device to become a daily driver.

Notes: Had bamboozeled myself this morning, I thought that 4g outbound calls were finally fixed..... plot twist I left the phone in 3g mode from yesterdays testing...... Damn. Anyways, no real progress. Not much action on the issues tracker. (to be expected to be honest.) Overall the OS hasn't been laggy for some time. The new settings application updates are nice. Worked out a lot of bugs that caused the settings menu to hang when opening. All in all, this OS is making progress. Please feel free to hit up the ubports forum to apply a little 'pressure' to the OS development side.  Also, please feel free to leave your feedback on this post. Let us know what your seeing and we will at least attempt to confirm the behavior to validate your experience.

Issues:
Failed outbound 4G calls kills call audio.
Unable to send 3G SMS Since Dev-158
4G outbound calls broken.
Phone gets stuck in a weird lock state when spamming power button.
I know you have been having issues on T-mobile and verizon for a while with regards to calls and SMS. For some reason i havent had any issues for a while so i am not sure how the providers are different. 

I do agree the current functions are being polished which is a good thing. I tried version #179 earlier and it seems the camera doesnt have as much lag when updating the screen. There is still a lag but its definitely snappier for me. I am looking forward to getting the mms and camera functioning as i make documentaries.


My issues stem from forcing 4G as far as calls are concerned. Since both of my carriers support LTE calling in my area it gets set as the preferred. Chances are, you are being downgraded on the fly, as far as the texting goes though; it is interesting to see the outbound issues on 3G. Could be carrier specific, I'm not sure. At this point in time I am just hoping to get more confirmation out of the development group.

The camera has seen improvements. I have noticed subtle improvements over time, although those notes are not often captured in my test cases.  It is really hard to describe 'less laggy' four times in a row and retain some meaning that differentiates the results from the last week.
Ive had my calls data and text on 4G over a month. Im on freedom mobile in canada though. Ive seen other people having problems with both T-mobile and verizon across a few distros, though it looks like some other distros are fairing better with the issues a bit more intermittent. Not sure why its these 2 carriers exactly, but even within the 4g spectrum there are different bandwidths different carriers use. Might be that. Or it might be about other telecom signaling stuff that devs need to tailor for these specific companies
#6
(09-02-2020, 12:02 PM)Cree Wrote: My issues stem from forcing 4G as far as calls are concerned. Since both of my carriers support LTE calling in my area it gets set as the preferred. Chances are, you are being downgraded on the fly, as far as the texting goes though; it is interesting to see the outbound issues on 3G. Could be carrier specific, I'm not sure. At this point in time I am just hoping to get more confirmation out of the development group.

The camera has seen improvements. I have noticed subtle improvements over time, although those notes are not often captured in my test cases.  It is really hard to describe 'less laggy' four times in a row and retain some meaning that differentiates the results from the last week.
Ive had my calls data and text on 4G over a month. Im on freedom mobile in canada though. Ive seen other people having problems with both T-mobile and verizon across a few distros, though it looks like some other distros are fairing better with the issues a bit more intermittent. Not sure why its these 2 carriers exactly, but even within the 4g spectrum there are different bandwidths different carriers use. Might be that. Or it might be about other telecom signaling stuff that devs need to tailor for these specific companies

This is very true, I have a rudimentary understanding of mobile telecom at best. Those two providers unfortunately are the only ones I am able to obtain service from at the moment, due to limitations from other providers (phone activations, etc. etc.)
#7
(09-02-2020, 12:33 PM)plainenough Wrote:
(09-02-2020, 12:02 PM)Cree Wrote: My issues stem from forcing 4G as far as calls are concerned. Since both of my carriers support LTE calling in my area it gets set as the preferred. Chances are, you are being downgraded on the fly, as far as the texting goes though; it is interesting to see the outbound issues on 3G. Could be carrier specific, I'm not sure. At this point in time I am just hoping to get more confirmation out of the development group.

The camera has seen improvements. I have noticed subtle improvements over time, although those notes are not often captured in my test cases.  It is really hard to describe 'less laggy' four times in a row and retain some meaning that differentiates the results from the last week.
Ive had my calls data and text on 4G over a month. Im on freedom mobile in canada though. Ive seen other people having problems with both T-mobile and verizon across a few distros, though it looks like some other distros are fairing better with the issues a bit more intermittent. Not sure why its these 2 carriers exactly, but even within the 4g spectrum there are different bandwidths different carriers use. Might be that. Or it might be about other telecom signaling stuff that devs need to tailor for these specific companies

This is very true, I have a rudimentary understanding of mobile telecom at best. Those two providers unfortunately are the only ones I am able to obtain service from at the moment, due to limitations from other providers (phone activations, etc. etc.)
I think it comes down to how the individual carriers manage VOLTE at this point. Based on one of the Ubuntu Touch Q&A sessions (https://ubports.com/blog/ubports-blogs-n...-a-82-3715) they do not fully support it yet.

Excerpt from above site:
"VOLTE news

Florian reported on discussions about VOLTE with Jolla, which took place at the beginning of the year. In some countries 2g networks have not been maintained alongside newer networks, so VOLTE technology is relatively more important to users. PinePhone can support it in principle but we are not there yet with implementation. Jolla had a guy from Sony at the meeting. The position at the moment is that all of the alternative mobile operating systems lack it. That is mainly because it is highly proprietary. Jolla are part of the Sony open device programme so there is potentially a way forward for Sony devices, in the first instance. We already have a few Sony devices that run Ubuntu Touch, so they might provide an option for those in our community who are struggling. In addition, we need to think about the necessary middleware for the PinePhone. There is no timeline for this but we have not forgotten about the issue. We are listening and there are some promising strands emerging."

Currently I am able to connect to Mobile Mint (T-Mobile's network) and have incoming and outgoing calls work as well as sending and receiving texts/SMS using both Mobian and Manjaro Phosh running from a SD in a UBports CE PinePhone. This is with the phone settings at 2G/3G/4G. I still cannot make outbound calls using the UT OS but I can send and receive texts and receive phone calls. Running Manjaro Plasma from a SD, it did show a connection to the network but I could not make or receive calls.
PinePhone UBports CE and Mobian on SD, Mint Mobile, Pinebook Pro Manjaro
#8
I am also using Mint Mobile with UBPorts CE Edition and I am able to make and receive calls as well as sending and receiving SMS on 4G using Mobian.

But, using UT I can receive calls, send and receive SMS in 2G/3G/4G but cannot make any calls. I can make/receive calls in and receive SMS in 3G but cannot send SMS.

So, the Pinephone is capable of using 4G but the different distros are handling differently.

I really want to be able to use UT as I find the UI very pleasing and snappier but not being able make calls is deal breaker for me so I use Mobian. It's more sluggish but it works.

Currently the battery life is an issue on all distros that I've used.
#9
(09-03-2020, 07:52 AM)livanti21 Wrote: I am also using Mint Mobile with UBPorts CE Edition and I am able to make and receive calls as well as sending and receiving SMS on 4G using Mobian.

But, using UT I can receive calls, send and receive SMS in 2G/3G/4G but cannot make any calls. I can make/receive calls in and receive SMS in 3G but cannot send SMS.

So, the Pinephone is capable of using 4G but the different distros are handling differently.

I really want to be able to use UT as I find the UI very pleasing and snappier but not being able make calls is deal breaker for me so I use Mobian. It's more sluggish but it works.

Currently the battery life is an issue on all distros that I've used.

This is consistent with my testing.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Ordered my 3 phones on April 20, 2020 and only 1 arrived! bndoug66 9 5,816 10-09-2020, 05:56 PM
Last Post: bndoug66
  My Daily QA - 2020-10-01 plainenough 1 2,130 10-02-2020, 09:56 PM
Last Post: Phillip Bell
  My Daily QA - 2020-09-30 plainenough 0 1,418 09-30-2020, 01:48 PM
Last Post: plainenough
  My Daily QA - 2020-09-28 plainenough 3 3,522 09-29-2020, 10:51 AM
Last Post: LinAdmin2
  My Daily QA - 2020-09-29 plainenough 0 1,390 09-29-2020, 08:32 AM
Last Post: plainenough
  My Daily QA - 2020-09-01 plainenough 2 2,693 09-29-2020, 07:51 AM
Last Post: plainenough
  My Daily QA - 2020-09-10 plainenough 13 11,059 09-20-2020, 05:07 AM
Last Post: firefox-58
  My Daily QA - 2020-09-09 plainenough 1 1,969 09-09-2020, 11:37 PM
Last Post: bcnaz
  My Daily QA - 2020-09-08 plainenough 0 1,422 09-08-2020, 03:58 PM
Last Post: plainenough
  My Daily QA - 2020-09-03 plainenough 0 1,465 09-03-2020, 12:09 PM
Last Post: plainenough

Forum Jump:


Users browsing this thread: 1 Guest(s)