[SOLVED] Brand new pinephone bricked almost immediately out of box...
#1
Just got my new pinephone with ubports. Set it up, everything worked great. Then i decided to put a new sd card in. Literally brand new empty sd card. Immediately phone would no longer boot. Pine64 logo comes up, then there is a click sound (every time) then black screen. Sometimes with a redlight sometimes without. Have tried resetting, starting when plugged in, Flashed UB touch for pinephone to a new sd to attempt to boot from SD. No luck.
  Reply
#2
(07-21-2020, 02:05 PM)Cree Wrote: Just got my new pinephone with ubports. Set it up, everything worked great. Then i decided to put a new sd card in. Literally brand new empty sd card. Immediately phone would no longer boot. Pine64 logo comes up, then there is a click sound (every time) then black screen. Sometimes with a redlight sometimes without. Have tried resetting, starting when plugged in, Flashed UB touch for pinephone to a new sd to attempt to boot from SD. No luck.

I haven't had much time to tinker, but the ubports edition should have ubports installed on the eMMC, so can you confirm the following:
- You've removed the plastic tab which stops the battery from connecting to the phone? 
- Remove the SD card (the phone will naturally try boot from SD card first) and try to boot again?
- Install something like Manjaro or Mobian via balenaEtcher to both your SD cards, install each SD card for each try, have it on charge, wait for a few minutes, turn it on by holding the power button for 5 seconds, wait for a minute to boot.
- Sometimes it takes a minute just to show the boot logo.
- How are you charging it? Have you tried other chargers and cables?

Good luck
  Reply
#3
(07-21-2020, 02:48 PM)SpoofyKid Wrote:
(07-21-2020, 02:05 PM)Cree Wrote: Just got my new pinephone with ubports. Set it up, everything worked great. Then i decided to put a new sd card in. Literally brand new empty sd card. Immediately phone would no longer boot. Pine64 logo comes up, then there is a click sound (every time) then black screen. Sometimes with a redlight sometimes without. Have tried resetting, starting when plugged in, Flashed UB touch for pinephone to a new sd to attempt to boot from SD. No luck.

I haven't had much time to tinker, but the ubports edition should have ubports installed on the eMMC, so can you confirm the following:
- You've removed the plastic tab which stops the battery from connecting to the phone? 
- Remove the SD card (the phone will naturally try boot from SD card first) and try to boot again?
- Install something like Manjaro or Mobian via balenaEtcher to both your SD cards, install each SD card for each try, have it on charge, wait for a few minutes, turn it on by holding the power button for 5 seconds, wait for a minute to boot.
- Sometimes it takes a minute just to show the boot logo.
- How are you charging it? Have you tried other chargers and cables?

Good luck
I can confirm per your checklist all was done correctly. Plastic tab was removed and phone booted from mmc correctly. It was fine with the initial set up and through the first few hours. Phone worked fine on battery. It is only when i decided to inserta blank sd card purely for storage purposes this happened.

Flashing UB touch on another sd card to boot from SD was only a later attempt at restoring it.

However; quick update. I was in fact able to start it again and boot from the sd by following a specific bunch of steps: 1) instert sd. 2) power on, wait for pine64 screen to pass and get stuck on black screen. 3) power off. 4) repeat step 2. 5) remove back cover and hold reset button until fresh boot begins.

It now seems to boot fine from sd however cellular signal isnt working correctly anymore (it was working when first received) now it recognizes my network but the calls dont get placed. will tinker some More. I did see someone mention a similar issue caused by an update and they found a way to recover the mmc OS. I may attempt this shortly to see if that helps get back the cellular service.

(07-21-2020, 02:48 PM)SpoofyKid Wrote:
(07-21-2020, 02:05 PM)Cree Wrote: Just got my new pinephone with ubports. Set it up, everything worked great. Then i decided to put a new sd card in. Literally brand new empty sd card. Immediately phone would no longer boot. Pine64 logo comes up, then there is a click sound (every time) then black screen. Sometimes with a redlight sometimes without. Have tried resetting, starting when plugged in, Flashed UB touch for pinephone to a new sd to attempt to boot from SD. No luck.

I haven't had much time to tinker, but the ubports edition should have ubports installed on the eMMC, so can you confirm the following:
- You've removed the plastic tab which stops the battery from connecting to the phone? 
- Remove the SD card (the phone will naturally try boot from SD card first) and try to boot again?
- Install something like Manjaro or Mobian via balenaEtcher to both your SD cards, install each SD card for each try, have it on charge, wait for a few minutes, turn it on by holding the power button for 5 seconds, wait for a minute to boot.
- Sometimes it takes a minute just to show the boot logo.
- How are you charging it? Have you tried other chargers and cables?

Good luck
I can confirm per your checklist all was done correctly. Plastic tab was removed and phone booted from mmc correctly. It was fine with the initial set up and through the first few hours. Phone worked fine on battery. It is only when i decided to inserta blank sd card purely for storage purposes this happened.

Flashing UB touch on another sd card to noot from SD was only a later attempt at restoring it.

However; quick update. I was in fact able to start it again and boot from the sd by following a specific bunch of steps: 1) instert sd. 2) power on, wait for pine64 screen to pass and get stuck on black screen. 3) power off. 4) repeat step 2. 5) remove back cover and hold reset button until fresh boot begins.

It now seems to boot fine from sd however cellular signal isnt working correctly anymore (it was working when first received) now it recognizes my network but the calls dont get placed. will tinker some More. I did see someone mention a similar issue caused by an update and they found a way to recover the mmc OS. I may attempt this shortly to see if that helps get back the cellular service.
  Reply
#4
(07-21-2020, 02:05 PM)Cree Wrote: I can confirm per your checklist all was done correctly. Plastic tab was removed and phone booted from mmc correctly. It was fine with the initial set up and through the first few hours. Phone worked fine on battery. It is only when i decided to inserta blank sd card purely for storage purposes this happened.

Flashing UB touch on another sd card to noot from SD was only a later attempt at restoring it.

However; quick update. I was in fact able to start it again and boot from the sd by following a specific bunch of steps: 1) instert sd. 2) power on, wait for pine64 screen to pass and get stuck on black screen. 3) power off. 4) repeat step 2. 5) remove back cover and hold reset button until fresh boot begins. 

It now seems to boot fine from sd however cellular signal isnt working correctly anymore (it was working when first received) now it recognizes my network but the calls dont get placed. will tinker some More. I did see someone mention a similar issue caused by an update and they found a way to recover the mmc OS. I may attempt this shortly to see if that helps get back the cellular service.

Great to hear you got it working. The operating systems are quite alpha at this point, so your cellular signal issue is likely something that will go away with a future update. Try another OS and see how you go. The others are pretty cool as well. 

Apparently people are mentioning not to pull the battery out without powering down first, as the firmware on the modem can be corrupted by removing the battery; something to note.

Enjoy your new phone!
  Reply
#5
So is it best to hold off putting an SD card in? I have a 128 Samsung scheduled for delivery next week. I also have my Mint Mobile SIM card enroute too that is supposed to be here on Tuesday.
  Reply
#6
(07-25-2020, 07:22 PM)Lt. Dillinger Wrote: So is it best to hold off putting an SD card in?  I have a 128 Samsung scheduled for delivery next week.  I also have my Mint Mobile SIM card enroute too that is supposed to be here on Tuesday.
That's my experience. I got it working again, but may not be worth the risk. My thoughts now based on the above answers is that when a blank sd card is inserted the pinephone automatically thinks it must have a OS loaded to boot from, even if its empty and you intend to boot from the eMMC. Im guessing when it went into boot from an empty SD card it obviously ran into issues and corrupted the eMMC image and boot sequence. Would be good if the pinephone prompted you on startup as to whether you intend to boot from eMMC or SD card.
  Reply
#7
(07-26-2020, 02:19 PM)Cree Wrote: Would be good if the pinephone prompted you on startup as to whether you intend to boot from eMMC or SD card

That is unfortunately impossible as A64 boot order is SD first, then eMMC.
Find me in the forest, when I'm at my lowest. I don't really think you should continue..

HOLD YOUR BREATH.
  Reply
#8
(07-30-2020, 07:36 AM)Danct12 Wrote:
(07-26-2020, 02:19 PM)Cree Wrote: Would be good if the pinephone prompted you on startup as to whether you intend to boot from eMMC or SD card

That is unfortunately impossible as A64 boot order is SD first, then eMMC.
Well...you'd need the u-boot on the SD to have the option to boot whatever's on the eMMC. Since uBoot can't write to this display you'd have to make the choice using the volume and power buttons, possibly using the LED as an indicator. I've not got round to making up a serial cable to investigate further.

Or have a kernel and initrd on the SD that can load and kexec from partitions on the eMMC or SD.
  Reply
#9
(07-30-2020, 12:02 PM)wibble Wrote:
(07-30-2020, 07:36 AM)Danct12 Wrote:
(07-26-2020, 02:19 PM)Cree Wrote: Would be good if the pinephone prompted you on startup as to whether you intend to boot from eMMC or SD card

That is unfortunately impossible as A64 boot order is SD first, then eMMC.
Well...you'd need the u-boot on the SD to have the option to boot whatever's on the eMMC. Since uBoot can't write to this display you'd have to make the choice using the volume and power buttons, possibly using the LED as an indicator. I've not got round to making up a serial cable to investigate further.

Or have a kernel and initrd on the SD that can load and kexec from partitions on the eMMC or SD.
Great idea! Worth further digging. Unfortunately unless something like this is done we're not going to have expandable storage. Sure we can always flash new larger SD cards, but we'd always need to set up all our personal stuff from scratch. A way to keep the OS on eMMC and have storage on SD would truly be ideal.
  Reply
#10
(07-31-2020, 10:15 AM)Cree Wrote:
(07-30-2020, 12:02 PM)wibble Wrote:
(07-30-2020, 07:36 AM)Danct12 Wrote:
(07-26-2020, 02:19 PM)Cree Wrote: Would be good if the pinephone prompted you on startup as to whether you intend to boot from eMMC or SD card

That is unfortunately impossible as A64 boot order is SD first, then eMMC.
Well...you'd need the u-boot on the SD to have the option to boot whatever's on the eMMC. Since uBoot can't write to this display you'd have to make the choice using the volume and power buttons, possibly using the LED as an indicator. I've not got round to making up a serial cable to investigate further.

Or have a kernel and initrd on the SD that can load and kexec from partitions on the eMMC or SD.
Great idea! Worth further digging. Unfortunately unless something like this is done we're not going to have expandable storage. Sure we can always flash new larger SD cards, but we'd always need to set up all our personal stuff from scratch. A way to keep the OS on eMMC and have storage on SD would truly be ideal.
That's actually a whole lot easier since you don't need to get user input, just use a uboot config on the SD that boots the eMMC. I'm not sure even that's necessary though - i think you just have to make sure there's no bootloader in the boot sector of the SD, causing it to fall back to booting from the eMMC.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Article: NuttX RTOS for PinePhone: Blinking the LEDs lupyuen 0 45 09-21-2022, 02:48 AM
Last Post: lupyuen
  Article: NuttX RTOS for PinePhone: UART Driver lupyuen 0 70 09-09-2022, 10:35 PM
Last Post: lupyuen
  Article: NuttX RTOS on PinePhone: Fixing the Interrupts lupyuen 0 111 08-31-2022, 07:58 PM
Last Post: lupyuen
  Trouble building (& using) pinephone-keyboard tools 64_Tesseract 6 636 08-28-2022, 09:42 PM
Last Post: 64_Tesseract
  Article: PinePhone boots Apache NuttX RTOS lupyuen 0 106 08-27-2022, 05:31 AM
Last Post: lupyuen
  Pinephone: OpenGL support? orbital 2 579 08-25-2022, 04:09 PM
Last Post: vortex
  Article: Apache NuttX RTOS on PinePhone lupyuen 0 110 08-24-2022, 06:15 PM
Last Post: lupyuen
  Issues with PinePhone Pro Glenn 1 288 07-28-2022, 11:56 AM
Last Post: Airdale
  Latest firmware for PinePhone modem! Subsentient 104 85,254 07-20-2022, 05:32 AM
Last Post: zetabeta
  Article: Build a PinePhone App with Zig and zgt lupyuen 2 439 06-26-2022, 02:20 AM
Last Post: lupyuen

Forum Jump:


Users browsing this thread: 1 Guest(s)