Battery usage in stock v1.2 UBPorts edition
Received my UBPorts edition with v1.2 hardware(?) yesterday. The 14hrs runtime that this post mentions is nowhere near what I get:

[EDIT: Added Version and "top -H" output]
Version: "About" says Ubuntu 16.04 (FACTORY).

- The battery was disconnected with the plastic sheet when phone arrived. Battery was then around 40% so I removed it and gave it a full charge. 
- All DIP switches ON
- Wifi/BT turned off in OS
- No SIM or MicroSD inserted
- Restarted phone just before test and only opened the Settings - Battery page.
- Screen off the entire time, except for a few seconds now and then to check the battery.

Lost half the charge in 4.5 hours. It actually loses charge when idle FASTER than it charges. See pic.
- Started charging around 20:00 @37%  and left it alone until 13:00 the day after
- Reached @100% around 01:45, then charging was stopped until it was automatically restarted around 06:45
- Left it with charger disconnected and screen off around 07:30
- Discharged to around @35% at 13:00.

[Image: top-H.png]

[Image: v1.2-ubuntutouch-default-battery.png]
Are you on the Stable or Development channel? What build version are you running?
I noticed some times the charge level plot does not update immediately. After overnight charging indicated only 83%, however, checking the battery levels several times forced to update it and suddenly jumped to ~95%
On stable (wihich is default) my battery depleted while the phone was conected to the PC.
Overnight charging (starting at 20%) with an 1A charger ended with a fully depleted battery in the morning.
6 hours charging with a 2A charger did not change anything.
Using the official Raspberry Pi 4 charger (3A) worked well.
But even after shutting down the phone the battery depleted rather quickly.

I changed to RC channel and Ubuntu touch updated from v3 to v4 and now to v5
This brings decent power management and now the phone works well enought (active, in standby and switched off).
(07-21-2020, 12:05 PM)doelf Wrote: Using the official Raspberry Pi 4 charger (3A) worked well.

This is a good point in itself.

TL mentioned in another thread that the charging cable packaged with the PinePhone uses a thick wire, the same is true of Raspberry Pi power supplies. Both are high quality and ideal for consistent power delivery.

While difficult to source, using a 15V 5W 3A block is the way to go. Or the new battery charger in the store.
Same here.
When connected to PC, does not charge or uncharge
When connected to UPS then got a full charge in few hours
(07-21-2020, 07:18 AM)YepYepperson Wrote: Are you on the Stable or Development channel? What build version are you running?

I feel stupid asking this, but how am I supposed to tell? 
"About" menu says Ubuntu 16.04 (FACTORY) and the only updates I have pending are for Wather App and Calculator.
"uname -a" tell me "Linux ubuntu-phablet 5.6.0-pine64", and  "lsb_release -a" tells me Ubuntu 16.04.6 LTS", xenial.

The Terminal app causes so much CPU usage and lag that I'm reluctant to use it - the whole UI freezes for seconds at a time.
You're probably on Stable then. There's been a number of improvements on the Development channel, but you risk having to reflash if things go wrong.

Possibly Related Threads…
Thread Author Replies Views Last Post
  PinePhone UBPorts Edition stuck on PINE64 logo screen Giovanni Iannotti 4 5,150 09-01-2021, 01:20 PM
Last Post: Giovanni Iannotti
  online accounts in UBports Uturn 2 4,326 03-30-2021, 09:12 AM
Last Post: Uturn
  UBPorts Not Working Pinoideae 7 9,990 03-13-2021, 01:51 PM
Last Post: KNERD
  How to enable Ethernet with UBPorts and convergence dock? piney-tim 1 3,117 11-27-2020, 07:40 PM
Last Post: piney-tim
  UBPorts Convergence MonCon 0 2,419 11-24-2020, 04:25 PM
Last Post: MonCon
  Looks like I found a mild reason why UBPorts for pinephone hasn't seen much progress. plainenough 13 18,092 11-21-2020, 06:30 PM
Last Post: Nooblife
  "No network" on new UBPorts community edition pinephone professorsnapper 6 8,161 10-19-2020, 10:27 PM
Last Post: htc_tattoo
  UBPorts doesn't boot even after booting into recovery defekto 2 4,629 09-30-2020, 12:16 PM
Last Post: defekto
  Dekko on UBPorts PinePhone usable? djvinniev77 13 15,844 09-17-2020, 03:45 PM
Last Post: yurievitch
  How to enable SSH on UBPorts Ubuntu Touch? eaglecup 12 20,637 09-15-2020, 03:42 PM
Last Post: voidmain

Forum Jump:

Users browsing this thread: 1 Guest(s)