issues with keyboard/trackpad in Manjaro, can't test other OSs
#1
Got my new PB Pro yesterday, and for the most part, I'm really happy with it.  There is an incredibly irritating issue with the trackpad, however.  In most cases, as soon as I stop using the keyboard or touchpad for 2-3 seconds, when I use either again there is about a 500ms lag before the input registers, similar to an older wireless mouse that goes to sleep after a few minutes and doesn't respond immediately when you use it.  The problem here is, in the case of the trackpad, when the initial movement is detected, it sees the movement during that 500ms as happening -instantly-, so the pointer jumps most of the way across the screen.  Situations where this do not occur include the login screen, if the KDE start menu is clicked and active, or if I change trackpad settings in System Settings (though it comes back soon after).

I decided to try flashing an alternate OS to an SD card, but so far the only one I could get to run was Manjaro XFCE, and that has the same problem.  Every other OS image I've tried from https://wiki.pine64.org/index.php/Pinebo...re_Release has failed in one way or another:

Ubuntu Bionic - no video at all, but system does boot as I hear the Ubuntu login sound.  Ctrl-Alt-F1 does not bring up a visible console.
Ubuntu Focal - eventually was able to get to a text console with Ctrl-Alt-F1
Q4OS - no video, can't tell if it actually booted
Debian Desktop - boots with video, but video is extremely distorted and unreadable.  can see mouse pointer moving though, and it dosen't exhibit the problem.
Chromium - same as Debian, boots with extremely distorted video

In addition, I'm seeing this message repeated in dmesg in Manjaro (I also caught it on the Ubuntu Focal text console):
Code:
[  712.933099] rockchip-dp ff970000.edp: Failed to apply PSR -110
[  712.933141] [drm:analogix_dp_bridge_atomic_enable [analogix_dp]] *ERROR* Failed to disable psr -110
[  715.931970] rockchip-dp ff970000.edp: Failed to apply PSR -110
[  715.932011] [drm:analogix_dp_bridge_atomic_enable [analogix_dp]] *ERROR* Failed to disable psr -110
[  716.548933] rockchip-dp ff970000.edp: Failed to apply PSR -110
[  716.548974] [drm:analogix_dp_bridge_atomic_enable [analogix_dp]] *ERROR* Failed to disable psr -110

I've tried reflashing the trackpad firmware, however that did not affect the problem (unsurprising, since this unit just shipped it should have the latest FW).  Also tried different SD cards and USB sticks to boot alternate OSs, with identical results from each.  Also tried re-flashing uboot.  I think my next step may be trying to flash the old uboot from the previous default Debian image, but I'm a little leery to pull the trigger on that one just yet.

Any help would be greatly appreciated!

Thanks,
Josh


Messages In This Thread
issues with keyboard/trackpad in Manjaro, can't test other OSs - by joshw - 06-19-2020, 09:21 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro i3 Edition not booting mtndew 0 162 08-23-2021, 06:21 PM
Last Post: mtndew
Information 3rd party keyboard review golbinex 4 456 08-17-2021, 06:15 AM
Last Post: boteium
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 200 156,928 08-01-2021, 04:30 PM
Last Post: wpeckham
  Manjaro KDE dolphin not showing usb device straightwalker 0 208 07-30-2021, 09:51 AM
Last Post: straightwalker
  Trackpad firmware update Luke 263 191,732 07-28-2021, 12:52 PM
Last Post: Luke
  printing -- Manjaro ARM KDE plasma straightwalker 8 942 07-04-2021, 10:55 PM
Last Post: KC9UDX
  MAC Spoofing failing in manjaro slow_motion 6 2,776 07-02-2021, 10:59 PM
Last Post: user526
  Trackpad film clockcycles 5 864 06-18-2021, 09:34 PM
Last Post: KC9UDX
  ISO keyboard Pinebook pro for sale tgrauss 2 668 06-08-2021, 12:05 AM
Last Post: tgrauss
  HArdware issues while charging user18130814200115 2 712 05-01-2021, 04:13 AM
Last Post: gabeeg

Forum Jump:


Users browsing this thread: 1 Guest(s)