Unable to boot from SD or USB
I've been trying to change the default debian (mrfixit) installed on the eMMC to a new Manjaro. As part of that process, I've been trying to boot from an SD card, and failing to do so. 

* MrFixit's updater says "There are no updates"
* I've tried writing the image to the SD using dd on linux, and Etcher on windows
* I've tried booting from a USB drive

I've been using the manjaro eMMC installer images from osdn

Whaterver I do, the pinebook pro only boots into the debian on the eMMC.

What can I do to troubleshoot this?

Just to be sure, when you are booted into Debian and insert the SD card, can you see the directories on the SD card?
(06-11-2020, 04:05 AM)jiyong Wrote: Just to be sure, when you are booted into Debian and insert the SD card, can you see the directories on the SD card?

Yes, indeed. I can see the ROOT_MNJRO and BOOT_MNJRO partitions, on both the sdcard and the usb drive. The directories are navigable and files readable in there.
I've been unable to make any headway on this, so still stuck on the stock debian. Would be nice to figure out why I can't boot from an SD card or USB. Any troubleshooting ideas would be most welcome.
@aviks There is no ability to boot a USB flash drive on the Rockchip RK3399 SoC. (Well their is, but it's not usable in the normal sense...)

That said, the boot loader U-Boot CAN have a module that allows booting off a USB flash drive. But, the OS on the flash drive needs to know about the USB drives... So, not just one step. Since their are literally dozens of U-Boot images out their in the wild, it's no certainty which you have loaded. And if it has USB support.

As for the SD Card boot, it's possible you have a bug in the U-Boot loaded. Or, if I remember correctly, the original Debian U-Boot did not give preference to SD Cards over the eMMC. Later updates "fix" this boot device priority. You could try to update the Debian and make sure it updates the U-Boot too.

Another way to deal with this, is to make a bootable SD Card and disable the eMMC via the internal switch.

There are other ways, but it gets complicated pretty fast.

Ideally a newer U-Boot could be installed. One version supports a boot device menu, and then a second menu to select which kernel to boot. I've played with it, and it's quite nice but has it's quirks. So it's "not ready for prime time".

In essence, the Pinebook Pro is still under software development, (by us community members...).
Arwen Evenstar
Princess of Rivendale
Maybe you already did this....
For the mrfixit distro, if you login as rock, there is an update icon, lower right, near time
Any other login does not have this
This update (mrfixit_update.sh,, in /usr/bin,, IIRR) update kernel and uboot, actually installs uboot (uniquely)
Later uboots have some capability to usb boot, doesn't always work, try both sockets
Do be aware that a LOT, majority of uSD are crap, at least as a hd for OS, OK for cameras etc
Did you try to boot into Debian, insert the SD card and restart?
Sometimes the SD card won't boot from a cold boot.
^ This.

Sometimes with that Uboot, I have had to reboot a dozen times to get it to boot from SD. I don't know why, and it doesn't make much sense. Sometimes it just wouldn't do it at all, sometimes powering down and rebooting a couple of times would just make it work.
Thanks for all you responses, folks. That helped me to troublehsoot this, and I can now confirm that I have Manjaro installed on my pinebook.

So it turns out there was something wrong with the SDCard I was using (it was a kingston 8GB SDHC). I got a new Sandisk 128GB SDXC card, and that worked first time. Of course, a bad SD card was not surprising, and I'd thought of that before, but in this case, I could mount and read the card, but it would not boot for some reason. Also to rule out a bad SD card, I was trying to use an USB drive, and I hadn't realised that USB is not in the boot path in the default uboot.

Possibly Related Threads…
Thread Author Replies Views Last Post
Question Can't boot any operating system other than Fedora after following the nullr0ute guide TDC_PBP 1 396 10-09-2021, 07:35 PM
Last Post: TangoZuluTango
  Kernel panic on boot with danielt's Debian installer hjalfi 11 2,371 07-09-2021, 08:52 AM
Last Post: moonwalkers
  PostmarketOS - Why swap file not on at boot? stozi 3 852 06-24-2021, 12:27 AM
Last Post: craftyguy
  Official openSUSE: U-Boot, dtb and graphics Jojonintendo 1 679 06-12-2021, 08:38 AM
Last Post: Jojonintendo
  Boot problems jessef 11 1,431 05-16-2021, 11:13 AM
Last Post: djhnsn
  PBP won't boot from eMMC or SD card: a saga archaicmeander 18 3,977 02-06-2021, 07:40 PM
Last Post: wdt
Question Changeing boot animation on Manjaro Anarethos 2 1,732 12-31-2020, 04:46 PM
Last Post: Anarethos
  Ubuntu MATE 18.04 Can't boot after update hankg 2 1,166 12-15-2020, 01:53 AM
Last Post: BryanF
  My PBP does not boot anymore. Please help Bocanila 1 1,074 11-21-2020, 01:38 PM
Last Post: xyzzy
Sad Can't boot from SDCARD anymore... bryanpaget 2 1,467 11-16-2020, 10:50 PM
Last Post: ab1jx

Forum Jump:

Users browsing this thread: 1 Guest(s)