Unable to make a bootable microSD card
#1
I read several posts about this issue, but I was unable to make it work. I want to try the factory/most stable OS image that comes preloaded with the latest PBP, along with other OSs.

In Manjaro ARM Flasher, I selected the following:

pbpro-bsp, kde-plasma, factory_22.06, mmcblk1 (SD card)

When I reboot, I press Ctrl+C to bring up the boot selection menu, then choose "Boot from SD". A blinking cursor appears in the top left corner which freezes after awhile, and the power LED will start flickering with green and red color.

I also tried manjaro-arm-installer with minimal install, and it shown the spinning circle below the Manjaro logo, and when pressing Esc, it said something about failed boot and threw me into tty.

Generic image (as offered in Manjaro-ARM download section) shown only a black screen with backlit LCD.



I am a noob here. Can anybody show me how to make "any" PBP approved OS image work via SD, so I can try different OSs?

Thanks in advance!
  Reply
#2
Here is a video and some pictures:

https://imgur.com/a/XfI0qgb
  Reply
#3
I'll assume you got one of the new batch, since I had many of the exact same issues over the last week with mine. To start with, the Fedora 32 images on the wiki (at least the KDE one) was one of the only images I got to work, initially. Armbian minimal also worked, but as I was in a flurry of experimentation, I stuck with what worked first and ran with it.

Before I could get much of anything else to boot, I had to flash Tow-Boot to the SPI. Then I managed to get the manjaro-arm-installer functioning in Fedora by installing the dependencies (a bit of trial and error there) and then I was finally able to run it to install Manjaro on the eMMC. The current official Debian SD images don't appear to have any of the correct drivers for the PBP, so I still haven't gotten that to work, but the Debian installer from the wiki works once Tow-Boot was installed (and many modifications were made to the script), as well.

Now I've got an encrypted Manjaro install on NVMe and everything works great, except for sleep, which I have not been able to get functioning properly in ANY OS/storage combo; I always have to set the suspend state to 'freeze', which sucks down nearly as much battery life as haven't the whole system powered on, but is fine for moving to/from work and back, at least.

This newest revision definitely has some new hardware that hasn't been thoroughly documented yet. For example, the WiFi will not work in ANY OS I've installed out-of-the-box, with the exception of a clean installation from the manjaro-arm-installer script. You need to download the brcmfmac43455 firmware blob (from a repo like this one) and copy them to /lib/firmware/brmc/ to get it functional.
  Reply
#4
I tried booting Fedora 32 KDE, but it stopped at a failed firmware load (rockchip/dptx.bin). I want to replace the system as the pre-flashed Gnome system is unstable (the device is overheating, mpv video playback is micro stuttering, etc.). This device is frustratingly hard to work with, nothing works!
  Reply
#5
I know there are some issues with other images and the bootloader for the PBP. I have had good luck getting these images to boot.

https://github.com/manjaro-arm/pbpro-images/releases

These are a little bit older but still specific images for the Pinebook Pro. If you don't mind doing a update once its installed its a good starting point. As for other images being ready to boot out the box I do not know. I have been happy sticking with Manjaro.

Maybe look into installing UBOOT or TOW-BOOT on your SPI...I see that does the trick for others.

Hopefully this helps point you in the right direction.
  Reply
#6
To add to what Shad0w said, Gnome is basically unusable in any distro I've tried outside of Manjaro (where I have to keep a very vigilant eye on memory usage.) KDE or XFCE seem to run pretty well in pretty much every environment.
  Reply
#7
I succeeded installing Tow-Boot onto the SPI, which allowed me to boot and flash generic Manjaro-ARM KDE-Plasma 22.08 image to eMMC. Thanks for all the feedback!
  Reply
#8
(09-11-2022, 07:47 AM)myself600 Wrote: I tried booting Fedora 32 KDE, but it stopped at a failed firmware load (rockchip/dptx.bin). I want to replace the system as the pre-flashed Gnome system is unstable (the device is overheating, mpv video playback is micro stuttering, etc.). This device is frustratingly hard to work with, nothing works!

Beginning to think, after numerous failures, that Manjaro, nicely as it works, IS in fact the problem.  I suggest that in future, Pinebook Pros be shipped with only a totally generic uboot or towboot written to the machine, plus one of maybe three popular distributions, all absolutely known to boot and run properly, already written to a microSD.  It would be the customer's choice, on the included microSD.  Personally, I would happily pay the extra cost to save the frustration of dealing with this current idiotic situation.  The Pinebook Pro is a lovely little box, one  deserving of better treatment than this current mess. As to Manjaro, my personal aim is to get away from KDE's bloatware and back to xfce or even lxde on an o/s more faithful to true Unix, like Debian (Armbian?) or Slackware or one of the BSDs. BTW, I have sufficient confidence in this Pinebook pro that it is now my main box, as I begin to configure my new RockPro64 to replace my HP desktop box.  Eventually, another RockPro64, or perhaps a Quartz64 will be added as the server for a wired, in-house secure net for art and film scanners, SDR and Ham radio, RAID, etc.
 while(!(succeed=try()));
  Reply
#9
Frankly, it appears that the main issue is the U-Boot that all of these distros use. It is clearly an older version meant for the prior hardware revision, which explains why the factory image works, but the exact same image re-flashed from Manjaro's git fails to boot - they clearly modified the U-Boot and and it's not the main version yet.

Anyway, first piece of advice for anyone getting a new Pinebook Pro: Flash Tow-Boot to the SPI then you can get busy.
  Reply
#10
@steeb
>Now I've got an encrypted Manjaro install on NVMe and everything works great, except for sleep
4 requirements for S3 (s2mem,, or suspend which is what dmesg calls it)
Actually 5, there is no suspend code for nvme, so can't be done with an installed nvme
1) the right uboot,, towboot will work, but only 1/2 as good as a bsp uboot(6-7d vrs 13-14d),
(I use mrfixit)
2) 5.8 or 5.7 manjaro kernel,,, later kernels don't have sleep code (1 fedora had good sleep but very fragile)
3) expliciot statement in /etc/systemd/sleep.conf,,,, SuspendState=mem
4) systemsetting5 ,, power->power button->log out dialog
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Bootloader: SD card boot quirks crazyquark 1 282 10-04-2022, 12:27 PM
Last Post: elitegamercody
  Unable to install Debian Bullseye because of missing wifi firmware Pino64 3 1,274 09-10-2022, 02:07 PM
Last Post: cypresstwist
  100% SD bootable img untitled 9 757 08-22-2022, 12:15 PM
Last Post: snorwood
  what is the magic dd incantation to copy the system from the sd card to the emmc? geokon 18 1,994 08-18-2022, 11:26 PM
Last Post: calinb
  How to make manjaro sleep or hibernate? KDE? regretfulpineuser 0 438 06-20-2022, 12:56 AM
Last Post: regretfulpineuser
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 0 853 01-10-2022, 03:58 PM
Last Post: zackw
  Debian/unstable SD card rescue image vajak 4 2,432 10-28-2021, 02:53 PM
Last Post: vajak
  Disable the Power Button or make it do something else User 22018 6 4,205 08-20-2021, 06:36 PM
Last Post: xmixahlx
  PBP won't boot from eMMC or SD card: a saga archaicmeander 18 9,516 02-06-2021, 07:40 PM
Last Post: wdt
  UBOOT - Mainline not booting from SD card / BSP OK Anarethos 1 2,216 01-10-2021, 12:33 AM
Last Post: Anarethos

Forum Jump:


Users browsing this thread: 1 Guest(s)