WiFi on Armbian problem
#1
I was on Debian Stretch, but the WiFi went wrong so Im trying different OS's, Im now on Armbian because it seems to have good tools for wifi like nmtui.

I have the official USB wifi from the Pine website, its the Realtek one.

I flashed Ambian Ubuntu Xenial using the PINE64 flash tool.

I started it set the passwords. 

iwconfig shows the wlx0013ef800c2c and p2p0 as wifi devices.

I try nmtui-connect <my ssid> enter the PSK and it fails to connect.

I go to nmtui and multiple wifi networks are available, select mine, enter the PSK and it still fails to connect.  I set the PSK to viewable and confirm it is correct, still no luck.

I try iwconfig wlx0013ef800c2c essid <my ssid> key <my psk>, this gives no output, but on checking the ifconfig, no connection has been made.

Please can anyone help me to troubleshoot this.
  Reply
#2
(08-19-2018, 04:49 AM)scalextrix Wrote: I was on Debian Stretch, but the WiFi went wrong so Im trying different OS's, Im now on Armbian because it seems to have good tools for wifi like nmtui.

I have the official USB wifi from the Pine website, its the Realtek one.


Which chipset/device, as there is 2 on the store.
  Reply
#3
(08-19-2018, 05:00 AM)evilbunny Wrote:
(08-19-2018, 04:49 AM)scalextrix Wrote: I was on Debian Stretch, but the WiFi went wrong so Im trying different OS's, Im now on Armbian because it seems to have good tools for wifi like nmtui.

I have the official USB wifi from the Pine website, its the Realtek one.


Which chipset/device, as there is 2 on the store.

Its the RTL8188EU model

EDIT: I took another old WiFi dongle from my Pi2, plugged it into the Rock64 and it worked immediately, is this a hardware fault?
  Reply
#4
(08-19-2018, 05:08 AM)scalextrix Wrote:
(08-19-2018, 05:00 AM)evilbunny Wrote:
(08-19-2018, 04:49 AM)scalextrix Wrote: I was on Debian Stretch, but the WiFi went wrong so Im trying different OS's, Im now on Armbian because it seems to have good tools for wifi like nmtui.

I have the official USB wifi from the Pine website, its the Realtek one.


Which chipset/device, as there is 2 on the store.

Its the RTL8188EU model


That one should work just fine, the other needs a driver installing.

Did you try nmtui and going through the text interface rather than the command line?
  Reply
#5
(08-19-2018, 05:18 AM)evilbunny Wrote:
(08-19-2018, 05:08 AM)scalextrix Wrote:
(08-19-2018, 05:00 AM)evilbunny Wrote:
(08-19-2018, 04:49 AM)scalextrix Wrote: I was on Debian Stretch, but the WiFi went wrong so Im trying different OS's, Im now on Armbian because it seems to have good tools for wifi like nmtui.

I have the official USB wifi from the Pine website, its the Realtek one.


Which chipset/device, as there is 2 on the store.

Its the RTL8188EU model


That one should work just fine, the other needs a driver installing.

Did you try nmtui and going through the text interface rather than the command line?
Yes nmtui-connect and nmtui both fail, all the wifi details are correct but it just fails to make a connection
  Reply
#6
OK left it off for a few hours, tried starting it again, now I cant even get to a login prompt. Its said something about 'dead4ead', restarted and now I cant get any display at all, the red and white LEDs just stay on and nothing happens. Will try re-flashing the SD card, but I have a nasty feeling something is badly wrong with the ROCK64; I put the USB WiFi card in my Pi2 and it worked, well it was a bit intermittent but it did get a network.
  Reply
#7
OK I got Ambian Stretch on there now, the desktop has started as well! But I still cant get the WiFi to connect, my local wifi hotspots are listed, but on entering credentials in the dektop ikon the connection never succeeds.

I tried a differnt USB wireless adapter and it works perfectly. I think part of the problem is that the 8188eu presents two wireless adapters 'p2p0' and 'wlx0013ef800c2c', I have tried connecting on both but no luck.
  Reply
#8
So more info, I have another RTL8188CUS Wifi adapter, that has the same problem as the RTL8188EU adapter. However if I use a Ralink RT5370 based adapter it works without problems. What is going on here, why will the 'official' WiFi USB version not work, while some random 3rd party one does?
  Reply
#9
Do you have a spare Raspberry Pi wifi dongle. If so give it a try. I didn't bother purchasing the Rock64 wifi dongle or power supply. Sourced my own.
  Reply
#10
I got the RTL8188EU working on PiZero with no initial problems, but after 10 minutes connection gets lost, honestly I think its jus a **** adapter. Clearly its either that or something about the drivers in the ROCK64.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 Debian 11 (Bullseye) install problem jbize 15 7,652 10-12-2023, 05:14 PM
Last Post: tpaul
  RXDP from Win10 to Armbian on Rock64 Transportsicherung 0 505 05-27-2023, 06:11 AM
Last Post: Transportsicherung
  USB3.0 Issues at DietPi(Armbian) #22.02.1 t4_4t 3 2,205 08-15-2022, 06:58 PM
Last Post: TRS-80
  Armbian for Rock64 pineadmin 57 69,277 04-01-2022, 03:16 PM
Last Post: TRS-80
  Armbian 22.02 Release Announcement TRS-80 0 962 02-28-2022, 05:06 PM
Last Post: TRS-80
  Armbian/Ubuntu for Rockbox Wizzard 5 4,103 05-18-2021, 08:18 AM
Last Post: Wizzard
  External hard drive problem k8Va 17 21,941 03-09-2021, 02:31 PM
Last Post: calinb
  Arch Linux Arm - external RTC problem max 1 2,880 08-17-2020, 10:35 AM
Last Post: max
  Armbian 5.4.43: Network is unreachable; Red LED blinking; RNG failure? aves 1 2,849 07-27-2020, 02:04 PM
Last Post: aves
  Read-only problem mikedhoore 5 6,680 07-14-2020, 11:41 AM
Last Post: zein

Forum Jump:


Users browsing this thread: 1 Guest(s)