(ARCHIVED) Ubuntu Xenial Image (BSP Kernel)
Sad 
I am not sure why, but sudo apt-get update for my board always got stuck at 0% [Working]

I have the latest version of the image in my 16 GB sdcard, with a 2GB board.
I built a new Ubuntu Xenial image with latest software and Kernel (includes GbE fix).

Get 20161217-1 from https://www.stdin.xyz/downloads/people/l...es/ubuntu/

As always, for a list of changes and full details see the first post in this thread.
(12-17-2016, 08:37 AM)longsleep Wrote: I built a new Ubuntu Xenial image with latest software and Kernel (includes GbE fix).

Get 20161217-1 from https://www.stdin.xyz/downloads/people/l...es/ubuntu/

As always, for a list of changes and full details see the first post in this thread.

This is only needed if we are starting from scratch right? Just running the update scripts is enough to match this, right?
I do it live!
(12-17-2016, 08:42 AM)apple4ever Wrote: This is only needed if we are starting from scratch right? Just running the update scripts is enough to match this, right?

Yes.
I decided to roll a new Ubuntu Xenial image which is not using the proposed repository. Starting from 20161218-1, Xenial images now use the latest released rootfs to improve repository compatibility. Eg. this makes it possible again, to install the mate desktop environment (whose dependencies are broken when using the proposed repo like before).

Get 20161218-1 from https://www.stdin.xyz/downloads/people/l...es/ubuntu/

As always, for a list of changes and full details see the first post in this thread.
(12-18-2016, 11:56 AM)longsleep Wrote: I decided to roll a new Ubuntu Xenial image which is not using the proposed repository. Starting from 20161218-1, Xenial images now use the latest released rootfs to improve repository compatibility. Eg. this makes it possible again, to install the mate desktop environment (whose dependencies are broken when using the proposed repo like before).

Get 20161218-1 from https://www.stdin.xyz/downloads/people/l...es/ubuntu/

As always, for a list of changes and full details see the first post in this thread.

Bravo !!!
Dear all,

Thanks you for the Ubuntu image, working fine on the Pine64 motherboard since some months hosting my owncloud server ! I use a second SDcard in order to have another use of the board (Kodi, using the HDMI output). I would like now to have a third use : try to run the "Jarvis" script, but after long time tests, I can't use the jack output ... I use an USB microphone, but this is another game ... Could somebody help me in order to use the audio jack connector (using the standard alsa driver) ?

Many thanks in advance,
Best regards,
Jean
Thank you for putting this image together, much appreciated.

I would like to run my pine as a pure network device, no monitor, keyboard or mouse. I cannot get the pine to boot without a keyboard which is less than ideal for the physical location where it will reside.

Any tricks for getting it working without a keyboard? I guess I may be able to plug a keyboard every time before I reboot, and then unplug once it's up and running but that's not ideal.
@longsleep: First of all thx for great images - greatly appreciated!

I was upgrading today from 20160716-1 to 20161217-1 and 20161218-1. I've read that those builds contains fix for GbE which is great.

When I'm booting to fresh 20160716-1 dhclient gets ip for eth0 and on newer ones I see only dhcp broadcasts and ip is never assigned. What do I need to tweak then (I've tried both 100Mbit and 1Gbit switches - same failure)?
For whatever reason, this update kills my Emby server setup. Emby server runs great on the older versions, but when I update, it ceases to function.

Here is the information I get when using Putty to install the Emby server.  

Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 3.10.104-2-pine64-longsleep aarch64)

* Documentation:  https://help.ubuntu.com
* Management:     https://landscape.canonical.com
* Support:        https://ubuntu.com/advantage
Last login: Mon Jan  2 21:08:51 2017 from 192.168.10.102
[email protected]:~$


For xUbuntu 16.04 run the following:

sudo sh -c "echo 'deb http://download.opensuse.org/repositorie...ntu_16.04/ /' > /etc/apt/sources.list.d/emby-

server.list"
sudo apt-get update
sudo apt-get install emby-server

[email protected]:~$ sudo apt-get install emby-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
              Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed
              Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
              Depends: libmono-system-transactions4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
              Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libembysqlite3-0 but it is not installable
              Depends: embymagick but it is not installable
              Depends: mono-devel (>= 4.6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:~$


Possibly Related Threads...
Thread Author Replies Views Last Post
  USB Wireless Drivers with Longsleep Linux Kernel jacobscarter 15 2,787 03-06-2019, 02:26 PM
Last Post: tllim
  Allwinner A64 RTC bug fix on bionic image? tkaivola 1 226 02-01-2019, 05:09 AM
Last Post: tllim
  Xenial Minimal Image (PINE A64(+)) 0.6.2-77 pineadmin 3 6,054 01-14-2019, 01:46 PM
Last Post: brigmohan
  SPI on ubuntu IlyaM 4 1,366 07-16-2018, 03:00 AM
Last Post: kingflab
  Ubuntu password not working joemassimino 4 786 05-18-2018, 03:33 PM
Last Post: Luke
  How can I get a wireless dongle working on Xenial Desktop latest build Rocklobster 1 527 04-16-2018, 03:09 PM
Last Post: Rocklobster
  After flashing Ubuntu- how to get graphical desktop Partymack711 6 1,719 02-01-2018, 09:45 AM
Last Post: Partymack711
  PPTP doesnt work with ubuntu escovedo 2 2,157 08-23-2017, 09:28 AM
Last Post: gilbertotcc
Question HELP Ubuntu Mate password recovery procedure Captain Anni Hilator 5 2,058 08-03-2017, 03:52 PM
Last Post: Luke
  Ubuntu boot very slow with wifi driver remainder 9 2,197 08-03-2017, 07:23 AM
Last Post: victorssantos

Forum Jump:


Users browsing this thread: 1 Guest(s)