[May 11] LibreELEC(KODI) - 20190324 - Pine A64 (+) |[May 11] LibreELEC(KODI) - 20190324 - PINE A64-LTS / SOPINE | [May 09] NEMS Linux 1.5 - Build1 - Pine A64 (+) | [May 09] NEMS Linux 1.5 - Build 1 - Rock64 | [May 09] NEMS Linux 1.5 - Build 1 - PINE A64-LTS / SOPINE | [May 09] NEMS Linux 1.5 - Build 1 - RockPro |[April 23] Q4OS ver 2.7-r5 - 1080P Pinebook / Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


SPI on ubuntu
#1
Hey everyone! I found that SPI is disabled in Ubuntu kernel, and I need to turn it on rebuild the kernel. I'm going to use SPIdev. Is any step by step tutorial how to do this one? Or maybe is there completed built Ubuntu with enabled SPI? I don't have an experience for rebuilding kernel. 

Thanks in advance!
Reply
#2
Hi IlyaM,

I saw your messages on the Rock64 IRC channel. 
I also like to use SPI to connect a 868Mhz transceiver on my Rock64 and don't have enough knowledge about how to change device trees and stuff like that. Can you tell me what I have to do to activate spidev on the Rock64 with the ubuntu image? I googled the last 2 month but can't get it working. The most posts just tell how to use the SPI flash  :/

thanks in advance
Smile
Reply
#3
(01-10-2018, 03:24 AM)kingflab Wrote: Hi IlyaM,

I saw your messages on the Rock64 IRC channel. 
I also like to use SPI to connect a 868Mhz transceiver on my Rock64 and don't have enough knowledge about how to change device trees and stuff like that. Can you tell me what I have to do to activate spidev on the Rock64 with the ubuntu image? I googled the last 2 month but can't get it working. The most posts just tell how to use the SPI flash  :/

thanks in advance
Smile

Hi, sorry for the late message, unfortunately I don't have a success to use spidev. You can use sudo mod probe spidev to activate this module and lsmod shows you loaded spidev module, but ls /dev/spi* shows no such file or directory, also you can rebuild device tree to enable spidev (follow this link http://linux-sunxi.org/SPIdev)
Reply
#4
Hi, I have the same problem - missing /dev/spidev. Did anyone of you figure anything more out? 


Cheers,
Kappuchino
Reply
#5
(07-15-2018, 05:10 PM)Kappuchino Wrote: Hi, I have the same problem - missing /dev/spidev. Did anyone of you figure anything more out? 


Cheers,
Kappuchino

Not yet. Dodgy
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Ubuntu password not working joemassimino 4 609 05-18-2018, 03:33 PM
Last Post: Luke
  After flashing Ubuntu- how to get graphical desktop Partymack711 6 1,385 02-01-2018, 09:45 AM
Last Post: Partymack711
  (ARCHIVED) Ubuntu Xenial Image (BSP Kernel) longsleep 337 143,149 01-31-2018, 11:58 AM
Last Post: Luke
  PPTP doesnt work with ubuntu escovedo 2 1,926 08-23-2017, 09:28 AM
Last Post: gilbertotcc
Question HELP Ubuntu Mate password recovery procedure Captain Anni Hilator 5 1,780 08-03-2017, 03:52 PM
Last Post: Luke
  Ubuntu boot very slow with wifi driver remainder 9 2,004 08-03-2017, 07:23 AM
Last Post: victorssantos
  Recovering root access in Ubuntu Scientomancer 3 631 07-28-2017, 02:53 PM
Last Post: Scientomancer
  Pine64 2Gb Ubuntu Mono not updating and stuck petec 0 538 07-08-2017, 09:34 AM
Last Post: petec
  Ubuntu Xenial - Firefox add support for H264 and EAC3 klode 1 1,380 05-26-2017, 11:10 AM
Last Post: Gnx
Brick Rootfs Encryption on Ubuntu 16.04 saro 7 1,394 05-17-2017, 06:49 PM
Last Post: pfeerick

Forum Jump:


Users browsing this thread: 1 Guest(s)