Announcement: DietPi for PineA64
#21
(07-01-2016, 04:13 PM)Er0l Wrote: Could someone please test iperf -t 60 -c <remoteip> -d since I am getting very bad results, inbound speed is ok, but outbound is awful?

Hi Er0l,

Seems fine for me. Tests below:

Pine A64+ 2GB <> Odroid C2 on 1Gbit network.
In previous tests against other devices, Odroid C2 can sustain 880Mbit. So Pine A64+ network bandwidth is impressive.
Code:
root@DietPi:~# iperf -c 192.168.0.140 -p 45678 -t 30 -d
------------------------------------------------------------
Server listening on TCP port 45678
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.0.140, TCP port 45678
TCP window size:  204 KByte (default)
------------------------------------------------------------
[  5] local 192.168.0.113 port 33208 connected with 192.168.0.140 port 45678
[  4] local 192.168.0.113 port 45678 connected with 192.168.0.140 port 48410
[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-30.0 sec  2.12 GBytes   607 Mbits/sec
[  4]  0.0-30.0 sec  1.89 GBytes   542 Mbits/sec

What kernel are you running?
Code:
root@DietPi:~# uname -a
Linux DietPi 3.10.102-0-pine64-longsleep #7 SMP PREEMPT Fri Jun 17 21:30:48 CEST 2016 aarch64 GNU/Linux

Also, might be worth checking your connection is not in half duplex mode:
Code:
apt-get install ethtool

root@DietPi:~# ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Advertised pause frame use: No
       Advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: external
       Auto-negotiation: on
       Link detected: yes

Failing that, might be worth trying another network cable and different RJ45 socket on router/switch.
  Reply
#22
Hi and thanks for the reply.

Kernel is the same:

Code:
uname -a
Linux DietPi 3.10.102-0-pine64-longsleep #7 SMP PREEMPT Fri Jun 17 21:30:48 CEST 2016 aarch64 GNU/Linux

ethtool:

Code:
ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  1000baseT/Full
       Advertised pause frame use: No
       Advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: external
       Auto-negotiation: on
       Link detected: yes

Changed power adapters, two of them 2.5A for RPI3 both working perfectly. No changes in results.

Changed 2 CAT5e and 1 CAT6 no changes to the results.

Tried two times to tests and results are only one-directional:

Code:
iperf -c 192.168.254.1 -t 30 -d
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.254.1, TCP port 5001
TCP window size: 45.1 KByte (default)
------------------------------------------------------------
[  5] local 192.168.254.2 port 39679 connected with 192.168.254.1 port 5001
[  4] local 192.168.254.2 port 5001 connected with 192.168.254.1 port 38392
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-30.0 sec  2.18 GBytes   625 Mbits/sec

Code:
iperf -c 192.168.254.1 -p 45678 -t 30 -d
------------------------------------------------------------
Server listening on TCP port 45678
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.254.1, TCP port 45678
TCP window size: 22.5 KByte (default)
------------------------------------------------------------
[  5] local 192.168.254.2 port 42685 connected with 192.168.254.1 port 45678
[  4] local 192.168.254.2 port 45678 connected with 192.168.254.1 port 42005
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-30.0 sec  1.77 GBytes   505 Mbits/sec

very strange. I will test again later with different ports on the router and with fresh set of cables. but I do not think this is it. I am testing with my NAS which usually gets 600+Mbits when testing with my pc.
Pine64+ 2GB
  Reply
#23
Again changed the network cable and also port on my router result baffles me:

 
Code:
root@DietPi:/home/erol# iperf -c 192.168.254.1 -t 30 -d
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.254.1, TCP port 5001
TCP window size: 49.6 KByte (default)
------------------------------------------------------------
[  5] local 192.168.254.2 port 50784 connected with 192.168.254.1 port 5001
[  4] local 192.168.254.2 port 5001 connected with 192.168.254.1 port 49709
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-30.0 sec  2.64 GBytes   754 Mbits/sec
[  5]  0.0-30.1 sec  8.75 MBytes  2.44 Mbits/sec

Code:
root@DietPi:/home/erol# ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  1000baseT/Full
       Advertised pause frame use: No
       Advertised auto-negotiation: Yes
       Speed: 1000Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: external
       Auto-negotiation: on
       Link detected: yes
Code:
root@DietPi:/home/erol# iperf -c 192.168.254.1 -t 30
------------------------------------------------------------
Client connecting to 192.168.254.1, TCP port 5001
TCP window size: 22.5 KByte (default)
------------------------------------------------------------
[  3] local 192.168.254.2 port 50786 connected with 192.168.254.1 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-30.2 sec   351 MBytes  97.4 Mbits/sec
root@DietPi:/home/erol# iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[  4] local 192.168.254.2 port 5001 connected with 192.168.254.1 port 60016
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec   931 MBytes   780 Mbits/sec
Pine64+ 2GB
  Reply
#24
(07-02-2016, 03:17 PM)Er0l Wrote: Again changed the network cable and also port on my router result baffles me:

 
Yep, very strange, everything looks fine.
It might be worth checking for packet loss. 
Following lists total number of retransmitted packets (can be used to assume packet loss):
Code:
netstat -s | grep retransmited
  Reply
#25
Code:
root@DietPi:~# netstat -s |grep retransmited
   23122 segments retransmited

Raspberry Pi 3 <-> DNS320 NAS:

Code:
iperf -c 192.168.254.1 -d -t 30
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.254.1, TCP port 5001
TCP window size: 78.8 KByte (default)
------------------------------------------------------------
[  5] local 192.168.254.3 port 41672 connected with 192.168.254.1 port 5001
[  4] local 192.168.254.3 port 5001 connected with 192.168.254.1 port 50004
[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-30.0 sec   296 MBytes  82.6 Mbits/sec
[  4]  0.0-30.0 sec   319 MBytes  89.0 Mbits/sec

Pine64 2GB <--> DNS320 NAS just after rebooting Pine64:

Code:
iperf -c 192.168.254.1 -d -t 30
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.254.1, TCP port 5001
TCP window size: 67.6 KByte (default)
------------------------------------------------------------
[  5] local 192.168.254.2 port 41445 connected with 192.168.254.1 port 5001
[  4] local 192.168.254.2 port 5001 connected with 192.168.254.1 port 44944
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-30.0 sec  2.53 GBytes   724 Mbits/sec
[  5]  0.0-30.1 sec  9.12 MBytes  2.55 Mbits/sec

Pine64 2GB <--> Raspberry Pi 3

Code:
iperf -c 192.168.254.3 -d -t 30
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.254.3, TCP port 5001
TCP window size: 63.1 KByte (default)
------------------------------------------------------------
[  5] local 192.168.254.2 port 49467 connected with 192.168.254.3 port 5001
[  4] local 192.168.254.2 port 5001 connected with 192.168.254.3 port 38282
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-30.0 sec   327 MBytes  91.4 Mbits/sec
[  5]  0.0-30.1 sec  57.0 MBytes  15.9 Mbits/sec
Pine64+ 2GB
  Reply
#26
(07-03-2016, 07:39 AM)Er0l Wrote:
Code:
root@DietPi:~# netstat -s |grep retransmited
   23122 segments retransmited
Thats far too high.
As a comparison, my XU4 runs PiHole and file server, alot of daily traffic:
Code:
root@DietPi-XU4:~# netstat -s |grep retransmited
   6 segments retransmited
root@DietPi-XU4:~# uptime
14:52:59 up 2 days, 19:15,  2 users,  load average: 0.76, 0.43, 0.36

Check MTU size:
Code:
ifconfig eth0 | grep MTU:

Try running this to check for optimal MTU size:

Code:
/DietPi/dietpi/func/dietpi-optimal_mtu
  Reply
#27
Fourdee first of all thanks for the help so far.

Code:
root@DietPi:~# uptime
22:48:23 up  7:10,  1 user,  load average: 0.26, 0.23, 0.23

Code:
root@DietPi:~# netstat -s |grep retransmited
   7502 segments retransmited

Code:
root@DietPi:~# ifconfig eth0 | grep MTU:
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

Code:
root@DietPi:~# /DietPi/dietpi/func/dietpi-optimal_mtu
DietPi - MTU optimal size tool
- Finding optimal MTU size, please wait...
Testing MTU: 1500

Completed:
- MTU optimal size = 1500

Too bad I do not have another gigabit switch, but I will replace the network cable with fresh one tomorrow and repeat the tests.

Other thing that comes to mind is to use cross cable to connect Pine64 to my PC gigabit ethernet port and re-run the tests to check if the issue with this Cisco cable modem I am using.

From software point of view I really do not see what could be the issue.
Pine64+ 2GB
  Reply
#28
(07-03-2016, 02:54 PM)Er0l Wrote: Fourdee first of all thanks for the help so far.

Other thing that comes to mind is to use cross cable to connect Pine64 to my PC gigabit ethernet port and re-run the tests to check if the issue with this Cisco cable modem I am using.

From software point of view I really do not see what could be the issue.

Yep, definitely looks like a local network issue, especially with the high packet loss. I'd be surprised if it was anything else.

Crossover cable is a good idea to exclude network, but as you know, half-duplex can only send or receive at any one time (those were the days of cheap 2 player LAN lol).
  Reply
#29
Repeated results with fresh set of Cat5e and Cat6 cables.

When running server on laptop with gigabit Ethernet:

Code:
root@kali:~# iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[ 4] local 192.168.254.250 port 5001 connected with 192.168.254.2 port 52691
------------------------------------------------------------
Client connecting to 192.168.254.2, TCP port 5001
TCP window size: 254 KByte (default)
------------------------------------------------------------
[ 6] local 192.168.254.250 port 38190 connected with 192.168.254.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 6] 0.0-30.0 sec 3.21 GBytes 920 Mbits/sec
[ 4] 0.0-30.1 sec 3.00 MBytes 837 Kbits/sec
[ 5] local 192.168.254.250 port 5001 connected with 192.168.254.2 port 52692
[ 5] 0.0-30.0 sec 403 MBytes 113 Mbits/sec

When server is running on Pine64 and on laptop sequentially:

Code:
root@kali:~# iperf -c 192.168.254.2
------------------------------------------------------------
Client connecting to 192.168.254.2, TCP port 5001
TCP window size: 43.8 KByte (default)
------------------------------------------------------------
[ 3] local 192.168.254.250 port 38192 connected with 192.168.254.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.0 sec 1.07 GBytes 918 Mbits/sec
Code:
iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[ 4] local 192.168.254.250 port 5001 connected with 192.168.254.2 port 52694
[ ID] Interval Transfer Bandwidth
[ 4] 0.0-30.0 sec 557 MBytes 156 Mbits/sec

I even tried using more powerful power supply 3.5A, but that also does not make a difference.

I also tried running Debian Jessie image from another thread and the results are slight worse.

I even found this article on CNX-Software where reviewer has faced similar issues, so I know I am not alone with this.
Pine64+ 2GB
  Reply
#30
Need help to install a external USB sound card.

How do I disable the Internal Sound Card ?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Installing DietPi to EMMC on Rock64 rrosenheim 0 1,410 05-29-2019, 10:13 PM
Last Post: rrosenheim
  Announcement: OMV (OpenMediaVault) for PINE64 DuDu371 11 17,639 12-07-2018, 09:52 PM
Last Post: flinkazoid
  Cannot install Dstat on Debian Base PineA64 image ywoody 6 3,812 07-11-2016, 07:15 PM
Last Post: dkryder

Forum Jump:


Users browsing this thread: 1 Guest(s)