Rock64 Rev3 doesn't boot and leds blinking fast
#2
(08-11-2019, 07:57 PM)dishins Wrote: Hello,

I just purchased a 4gb Rock64 Rev3 model and i'm struggling in getting any image to boot properly, i tried latest Armbian, mrfixit and ayufan's image. Whenever i plug my power supply (5v 4A) the white, red and ethernet led starts blinking very fast while the green blink slowly. If i plug in and out my power supply it will eventualy boot, but never from the first time. Maybe my board is defective? Anyone else has this issue?


Sounds like a power issue, the green LED should be on solid when plugged in regardless if the board is booted or shutdown as it's hardwired to the power socket..
  Reply


Messages In This Thread
RE: Rock64 Rev3 doesn't boot and leds blinking fast - by evilbunny - 08-11-2019, 11:03 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Centos 8 Stream on Rock64 ayoungdukie 1 134 06-07-2021, 11:50 AM
Last Post: zer0sig
  Talos on ROCK64 cjyar 2 141 06-04-2021, 11:50 AM
Last Post: cjyar
  CentOS 7 for Rock64 pineadmin 3 2,696 05-30-2021, 08:20 AM
Last Post: ayoungdukie
  Rock64 CRUX-ARM (aarch64) mara 0 110 05-27-2021, 02:22 PM
Last Post: mara
  DietPi OS for ROCK64 MichaIng 15 3,925 05-24-2021, 07:46 AM
Last Post: MichaIng
  openwrt for the rock64 wilsonYan 14 5,990 05-23-2021, 07:53 AM
Last Post: stamasd
  RETRO-GAMING: UPDATED RELEASE OF RECALBOX FOR THE ROCK64 Mrfixit2001 32 24,403 05-22-2021, 07:01 AM
Last Post: fartadeadrian
  Armbian for Rock64 pineadmin 31 20,677 05-08-2021, 09:35 AM
Last Post: Wizzard
  Screen blinking pRcCjl4 0 151 05-08-2021, 12:16 AM
Last Post: pRcCjl4
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 113 60,707 05-02-2021, 04:48 AM
Last Post: mara

Forum Jump:


Users browsing this thread: 1 Guest(s)