Update 22.02.2019 Feature-complete Debian build - SDIO WiFi/BT / PCIe / 3D / 2D
#70
(02-28-2019, 12:28 PM)Mrfixit2001 Wrote: MisterA - Jan - thanks for reaching out. I see you actually have this error in your dmesg: "bad mode: 0 [#1] SMP". So far I've only had one other user with this issue, others are having good success with pcie. My research in this error suggests a power issue. Can you confirm your power supply, and that you're powering your pcie disks externally? If you gather more logs from boots where pcie does not work for you, please provide them.

Hi Mrfixit, MisterA,

First off: thanks for all your hard work MrFixit Smile Really happy to see that a stable build for the RockPro64 is being worked on!
Just tried your latest build (22.02.2019) and it runs smooth from eMMC here. I can SSH into it and it has internet access, so I can install packages and play around with it.

I have two issue though:
- The white indicator LED keeps blinking instead of burning steadily. I don't know if this indicates a problem as the system seems to be running fine, and I couldn't find anything about this in the documentation.
- My RAID controller (a HighPoint Rocket 640L, which I believe uses the Marvell 88SE9230 chipset), connected through PCI-e, is also not recognized:

Code:
root@localhost:/home# lspci
00:00.0 PCI bridge: Device 1d87:0100

The RAID controller chipset gets extremely hot (as in: can't touch it) after a short while though, and I see the same error showing up in my dmesg log as MisterA:

Code:
[ 1.743287] Internal error: Oops - bad mode: 0 [#1] SMP

Attached you can find my dmesg output. The error can be found on line 1035.

My RockPro64 is powered by the 'official' (EU) 12v 5A PSU and the two hard drives I have connected receive power from the RockPro itself through the 'official' power cable for SATA drives.

An interesting fact may be that I had Arch-ARM running on the RockPro64 before, and it seemed to be able to at least recognize the RAID controller; it showed up when I typed lscpi.

Do you have any idea what might be going wrong? If there's anything I can do to help/test any furter, please let me know Smile

Thanks in advance!


Attached Files
.txt   dmesg.txt (Size: 77.24 KB / Downloads: 152)
PinePhone (BH 2GB + CE 3GB) // RockPro64 4GB (rev. 2.1) - OMV NAS // PineH64 3GB (model B) - off-prem OMV NAS // Pine64-LTS 2GB (rev. 1.2 + Playbox) - Domotics server


Messages In This Thread
RE: Update 22.02.2019 Feature-complete Debian build - SDIO WiFi/BT / PCIe / 3D / 2D - by p1x3l3d - 03-05-2019, 09:24 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Vanilla mainline Debian 11 (Bullseye) on the RockPro64 Pete Tandy 0 17 6 hours ago
Last Post: Pete Tandy
Question Booting official Debian on RP64 arteeh 6 1,414 07-06-2021, 10:16 AM
Last Post: TRS-80
Big Grin Feature Complete Debian Desktop Release Mrfixit2001 158 79,190 05-29-2021, 04:05 AM
Last Post: twilite
  WiFi not working with PCIe SSD installed mikeD 0 340 05-25-2021, 07:48 AM
Last Post: mikeD
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 1,302 05-20-2021, 10:04 PM
Last Post: t4_4t
  ayufan kernel update unbootable TheHunter 2 825 03-12-2021, 05:17 PM
Last Post: LMM
  Booting Linux/Debian from the eMMC linuxha 4 1,129 03-02-2021, 07:01 PM
Last Post: linuxha
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 15,963 02-14-2021, 02:37 PM
Last Post: foresto
  How To Lay Hands on a True 64-bit Debian Install? vandys 4 1,398 12-01-2020, 06:12 AM
Last Post: as365n4
  Kernel Update from 4.4 (Ayufan) on Ubuntu 20.04 db579 3 2,124 10-22-2020, 01:12 PM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)