PXE Boot example?
#4
If you're still around and looking for how to do this... I'm in the process of working on that, and am half-way there Wink

I also have a dnsmasq (proxyDHCP) PXE setup, and have gotten my rock64 to start booting from it.

You basically need the following in your pxe boot menu, and the matching files -
Code:
default rock64-kernel-4.4
prompt 0
timeout 3

menu title Boot options

label rock64-kernel-4.4
   kernel /Image
   initrd /initrd.img
   fdt /dtb
   append earlycon=uart8250,mmio32,0xff130000 rw root=/dev/nfs nfsroot=${serverip}:/data/rootfs/rock64-1 rootwait init=/sbin/init mtdparts=spi32766.0:32k(system),4064k(loader),3840k(reserved),256k(vendor),4M(uboot),4M(atf)

As I noticed once the rock64 started it's PXE requests that it was requesting via it's MAC, I created it's own config file with menu containing that, so that once I'm done it will have both a boot menu and auto-boot config.

I then created (I'm still trying to piece how this goes together so I can transfer this over to the clusterboard... so could be way off the mark here...)

boot.scr.uimg - empty - Becase uboot keeps looking for it. I suspect it allows for custom uboot commands, so it merely existing allowed things to continue
Image -> /boot/vmlinuz-4.4.114-rockchip-ayufan-193 (ln -s'd from running system but copying would be more better in the long term due to upgrades)
initrd.img -> /boot/initrd.img-4.4.114-rockchip-ayufan-193 (ln -s'd from running system  - above applies)
dtb -> /boot/dtb

and it essentially works now... rock64 will pull down the kernel via the network and boots. And it also now pulls down its root filesystem over the network via NFS.  After going back and editing the /etc/fstab as distributed and commenting out the /boot mount point which was now completely wrong, it seems to be booting up to a usable system just fine so far.

You can also extract those files from the boot.img contained within any of ayufan's minimal images, etc... just keep unpacking the file Wink

One oddity in my setup so far though... it doesn't get the serverip for the TFTP/PXE server automatically like it should... remains 0.0.0.0, although a laptop and VMs on my desktop boot just fine (so I know dnsmasq IS working)... so I have to set it manually until I manage to lock it into the uboot environment properly or work out why the rock64 is misbehaving - just need to work out how to save it to the SPI since it's also booting from that... that plus the PXE menu doesn't autoselect, but that could be because I have to manually intervene atm... work in progress! Wink


Edit (a little while later...):

After frittering around with the settings and it seems to be behaving itself now with the exception of the need to set the serverip at boot... i.e. doing the following on a boot/reboot: 

Code:
set serverip 192.168.0.210
boot

In pursuing an issue which appeared to be resulting from the network interface being disabled before everything was properly written, and thus poweroff/reboot just grinding to a halt... I 
  • added "ASYNCMOUNTNFS=no" to /etc/default/rcS, and
  • commented out both lines of "eth0" in /etc/network/interfaces.d/eth0
and it now seems to be working perfectly. The first change may not be needed, but I'm almost certain the second is so that systemd doesn't try to manage the networking. If things like a static IP are needed that can be specified as part of the kernel arguments, but I didn't want that anyway so it looks good so far.
  Reply


Messages In This Thread
PXE Boot example? - by lewis - 03-05-2018, 02:38 PM
RE: PXE Boot example? - by coldfish - 03-07-2018, 01:12 AM
RE: PXE Boot example? - by lewis - 03-07-2018, 02:02 AM
RE: PXE Boot example? - by pfeerick - 04-05-2018, 05:09 AM
RE: PXE Boot example? - by lewis - 04-05-2018, 06:17 AM
RE: PXE Boot example? - by ansic - 04-08-2018, 03:38 PM
RE: PXE Boot example? - by pfeerick - 05-03-2018, 08:37 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 Rev3 doesn't boot and leds blinking fast dishins 6 5,137 06-30-2022, 06:28 PM
Last Post: rookie_267
  my rock64 can't boot rookie_267 0 402 06-27-2022, 06:52 PM
Last Post: rookie_267
  Setting a MAC on Rock64 U-Boot kiriakos 2 2,496 03-23-2021, 04:51 AM
Last Post: kiriakos
  Boot from USB 3.0 with hub Turbo 0 1,521 12-20-2020, 02:24 PM
Last Post: Turbo
  Unable to boot armbian fchazal 2 2,845 05-19-2020, 06:43 PM
Last Post: Rocklobster
  Rock64s will not boot any OS camosoul 2 2,508 05-19-2020, 06:38 PM
Last Post: Rocklobster
  Help me understand the boot up process olivercfc 0 1,488 11-10-2019, 08:30 AM
Last Post: olivercfc
Brick Rock64 stuck in boot, please help! Malmgren 7 6,508 11-05-2019, 07:02 AM
Last Post: Malmgren
Question [SOLVED] Alpine Linux won't boot rock7 1 4,134 10-22-2019, 04:30 PM
Last Post: rock7
  Forcing u-boot to detect USB3 storage jandastroy 8 8,440 04-02-2019, 10:06 PM
Last Post: t4_4t

Forum Jump:


Users browsing this thread: 1 Guest(s)