Power light flashes on then nothing
(08-08-2016, 01:43 AM)foxy82 Wrote:
(08-05-2016, 11:07 PM)pfeerick Wrote:
(08-05-2016, 02:47 AM)foxy82 Wrote: Hi thanks both for the info.

A picture tells a thousand words (or in this case a video) https://www.youtube.com/watch?v=nTUit2Wfnoo this is the problem shown with no SD card, no monitor, no touch screen, no network connection and no keyboard / mouse, no battery. Just power...

I've never connected anything other than the LCD touchscreen and an SD card to this board. It has never had Keyboard/mouse connected and never had any network connected. Images were burnt with DD in Cygwin and also using Win32DiskImager. However I think that might be a mute point if the power light is meant to remain on when there is no SD card and mine doesn't?

I will try to get on IRC and will consider a serial terminal but I think we are getting beyond what I'd expect to have to do with a brand new board and it does seem that this one might be DOA?

I'm with Mark on this on... I think it's the power supply. You'd be able to tell more if you check the power at the 5v pins of the Raspberry Pi header / Euler DC IN, to see if the board is really getting 5v (or less), or the power supply is some stupid 'green' one that switches off if there isn't a big enough load on it...  And yes, how you did the disk image is a moot point if it will stay on when the USB power is plugged in without a microSD card plugged in Wink Wink 

I just tried mine again (which appears to be the exact same model, but I needed to unplug the wifi module), and it stays on for at least three minutes without the card inserted (and, unsurprisingly, no serial activity), so unless that is unusual behaviour, I'd be blaming the power supply first, and then the board!  Angel

Hi - I've just tried with the Rasberry Pi 2.5a supply on the 5v I'm getting 5.27v and whilst the red light is on I got 2.99v on the 3.3v. 

So I've now tried 5 power supplies including both the 2.0a and 2.5amp Raspberry Pi ones:


All produce the same behaviour power light comes on for about 8 seconds and then goes off then nothing...

Oh booey!  Sad Sad

Unless some else has some more debugging ideas, I'm calling that a DOA pine64. The 5v voltage is more than sufficient (and you're using well spec'ed PSU, so it won't fold on you). You'll need to get in touch with the pine64 guys (trying PMing tllim) and work out how to get a replacement sent out to you.

Messages In This Thread
Power light flashes on then nothing - by foxy82 - 08-02-2016, 09:40 AM
RE: Power light flashes on then nothing - by pfeerick - 08-08-2016, 02:03 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  New RockPro64 Power Up Problem enorbet2 6 2,882 05-15-2022, 04:15 PM
Last Post: TRS-80
  Pinecil power Erincka 0 1,516 03-21-2021, 11:52 AM
Last Post: Erincka
  Session fails to fully start after unexpected power off during initial upgrade Avron 0 1,578 03-18-2021, 11:52 AM
Last Post: Avron
  Power button sdziuba 1 1,943 03-14-2021, 09:05 AM
Last Post: xalius
  PBP won't power. Charge light solid orange/red but turns off. cmicallef 15 9,460 03-12-2021, 07:08 PM
Last Post: cmicallef
  howto power hdd via usb3 on rockpro64 hanscees 2 4,246 06-17-2020, 02:00 AM
Last Post: hanscees
  User Screen Black After Changing Power Settings 0b51Gekko 2 3,969 07-03-2019, 07:53 AM
Last Post: 0b51Gekko
  5.25 V _ ... 2A Power USB Adapter Guest2000 4 6,073 02-12-2017, 09:34 PM
Last Post: tllim
  Power Switch for Pine64 512MB Board MonarchOfLight 0 2,252 10-24-2016, 04:33 PM
Last Post: MonarchOfLight
  Power Ribbon for LCD Display Plot 3 5,242 10-23-2016, 12:16 PM
Last Post: dkryder

Forum Jump:

Users browsing this thread: 2 Guest(s)