U-Boot, video console, and visual artifacts
#16
My apologies for the delayed response.

(07-17-2021, 08:01 AM)pkubaj Wrote: we previously talked on IRC about how I don't get a display. I use Gentoo with Manjaro kernel 5.11.16 and that works, but using even vanilla 5.11.16 fails to display anything. I found that using I have to use two Manjaro patches to get display working and they are still present in Manjaro's repo:
https://gitlab.manjaro.org/manjaro-arm/p...hack.patch
https://gitlab.manjaro.org/manjaro-arm/p...tcpm.patch

I'm not sure how the screen behaves on 5.13, my experience is with 5.11.16. I'm now planning to upgrade to 5.13. I use uboot 2021.07.

Thank you very much for providing this feedback!  I've had a rather detailed look at those two patches, but I'm still not exactly sure why are they required to make the video output work.  I'll have another look at that.

(07-19-2021, 07:22 AM)zackw Wrote: I investigated the scary-looking message about a bad SPI CRC checksum; it turns out to be unrelated and harmless.  It just means that there isn't any U-Boot configuration stored in the SPI flash.  Unfortunately I don't think it can be gotten rid of except by moving the entire bootloader into the SPI, or by code changes to U-Boot. See https://lists.denx.de/pipermail/u-boot/2...53338.html (no response, alas)

Right, that's a rather benign error message, as I've already explained in one of my earlier posts.
  Reply


Messages In This Thread
RE: U-Boot, video console, and visual artifacts - by dsimic - 07-28-2021, 09:37 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 120 109,757 09-11-2021, 02:16 PM
Last Post: calinb
  My pbp is a sleek, black, flat brick, and won't boot from any kind of media rotwang 15 2,322 08-24-2021, 04:25 PM
Last Post: bkenn
  How can I flash SPI so that I can boot from NVMe? codingpanic 5 585 08-24-2021, 05:07 AM
Last Post: codingpanic
  boot order straightwalker 6 657 07-22-2021, 12:31 AM
Last Post: wdt
  Video : Review of the PineBook Pro with Armbian NicoD-SBC 1 456 07-06-2021, 10:10 PM
Last Post: tllim
Tongue Hello my frend. How to fix my boot problem? carinosa 6 764 07-04-2021, 04:01 AM
Last Post: jiyong
  cannot boot SD card : "unable to select a mode" alchemist 0 332 06-18-2021, 02:03 AM
Last Post: alchemist
  Pinebook Boot CharlesBunders 14 3,011 06-15-2021, 07:40 PM
Last Post: James Good
  PBP won't boot alchemist 5 959 06-07-2021, 09:31 AM
Last Post: alchemist
  Broken Boot djhnsn 15 2,517 05-05-2021, 04:14 PM
Last Post: djhnsn

Forum Jump:


Users browsing this thread: 1 Guest(s)