[Jan 14] KDE Neon (20190113-1500) - Pinebook1080P / Pinebook |[Jan 14] Q4OS (2.7-r1) - Pinebook1080P / Pinebook | [Dec 07] DietPi(v6.18) - Pinebook / Manjaro KDE (preview3) / Manjaro LXQT (preview3) - Pinebook |[Dec 06] Armbian Debian Stretch (5.67) / Armbian Ubuntu 18.04 Bionic Desktop (5.67) - RockPro64 |[Dec 05] DietPi(v6.18) - 1080P Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 9,765
» Latest member: Mark
» Forum threads: 5,053
» Forum posts: 40,495

Full Statistics

Latest Threads
Rock64 OMV help needed
Forum: General Discussion on ROCK64
Last Post: Luke
37 minutes ago
» Replies: 1
» Views: 19
Making progress
Forum: General Discussion on ROCK64
Last Post: evilbunny
4 hours ago
» Replies: 3
» Views: 44
GPIO specifications in de...
Forum: Linux
Last Post: ramstadt
4 hours ago
» Replies: 0
» Views: 3
WARNING: internal 10|100...
Forum: Hardware and Accessories
Last Post: WrongWorld
10 hours ago
» Replies: 32
» Views: 3,882
My other media board pack...
Forum: General Discussion on ROCK64
Last Post: thatguyyouknowtheone
11 hours ago
» Replies: 0
» Views: 9
Feature-complete Debian b...
Forum: Linux
Last Post: Luke
Yesterday, 04:46 PM
» Replies: 2
» Views: 130
Download RetroPie for you...
Forum: General Discussion on ROCK64
Last Post: va88
Yesterday, 01:15 PM
» Replies: 2
» Views: 154
rtc battery check
Forum: General Discussion on ROCKPRO64
Last Post: rahulsharma
Yesterday, 09:05 AM
» Replies: 0
» Views: 24
Archlinux (mainline) for ...
Forum: Linux
Last Post: Luke
Yesterday, 08:15 AM
» Replies: 44
» Views: 9,814
DietPi not booting
Forum: Linux
Last Post: karlitos
Yesterday, 03:37 AM
» Replies: 4
» Views: 124

 
  Cannot get RockPro64 to boot
Posted by: randyc - 01-05-2019, 11:02 PM - Forum: General Discussion on ROCKPRO64 - Replies (5)

I just got a brand new RockPro64 yesterday and I have not been able to get it to boot. I've tried several different OS images (OMV, Ubuntu, Debian, and Armbian). I've tried 2 different microSD cards. I've tried prepping the microSD cards using Ubuntu and MacOS, using built in tools and Etcher.

I get the same results no matter what I do:

  • The green power LED turns on
  • Ethernet lights turn on, and blink as if there is activity but never appears on my network.
  • If I hold down the power button the ethernet lights turn off
I am definitely using RockPro64 OS images.


Am I doing something wrong or did I get a bad board?

::UPDATE::
I sent the board back to the store I bought it from and they determined that it had a faulty MicroSD card reader.

Print this item

  eMMC replacement problems.
Posted by: frank-zappa - 01-05-2019, 04:20 PM - Forum: Hardware and Accessories - Replies (3)

I recently ordered a 64Gb eMMC and tried to install it using this guide    http://files.pine64.org/doc/pinebook/gui..._Guide.pdf

All I got was a blank screen. When I inserted the micro SD card containing the linux image it started but I got a message on the screen saying "No eMMC detected."

I took it out and reinserted it in a few times but got the same result. 
When I put the old eMMC back in it worked.

Do I have a defective eMMC?
Does anyone know how to return a faulty unit?

Any help appreciated. 
Thanks in advance.

Print this item

  GCC 7.2 ///// veriumMiner
Posted by: QLEMAC - 01-04-2019, 07:33 PM - Forum: Linux - No Replies

Hi guys,

Running Armbian Stretch - Legacy kernel 4.4.y

Trying to get this veriumMiner work on the rockpro64 but keep crashing after 3sec...
I build it with ./build.sh script available in veriumMiner folder and this script suppose to
enable the ARMv8 (Soon as you see the stratum difficulty apear it crashing and reboot the kernel)

So I try to do it fancy by compile it by my self with the CFLAG="mfpu=neon"

Compiler C++ is not working can't compile it. Let's download GCC 7.2 to make the job done.

BUT...... make -j 8  ..... command make it crash....and reboot

What the next step? You can use my command to start the miner anytime.

Have Fun [Image: smile.png]

QLEMAC
[email protected]


To build and install GCC 7.2
Code:

Code:
apt-get -y install unzip flex
wget https://github.com/gcc-mirror/gcc/archive/gcc-7_2_0-release.zip
unzip gcc-7_2_0-release.zip
cd gcc-gcc-7_2_0-release
sudo ./contrib/download_prerequisites
mkdir build && cd build
../configure --enable-languages=c,c++ --disable-multilib
make -j 8
make install

veriumMiner
This is a multi-threaded CPU miner for Verium using scrypt²

Dependencies:

Code:
Code:
apt-get install automake autoconf pkg-config libcurl4-openssl-dev libjansson-dev libssl-dev libgmp-dev zlib1g-dev

Build from source easy:

Code:
Code:
git clone https://github.com/fireworm71/veriumMiner
cd veriumMiner
./build.sh
./cpuminer -n 1048576 -o stratum+tcp://eu.vrm.n3rd3d.com:3402 -O QLEMAC.user:password -t X

Build from source: Advanced:
Code:
Code:
git clone https://github.com/fireworm71/veriumMiner
cd veriumMiner
./autogen.sh
perl nomacro.pl
./configure CFLAGS="-mfpu=neon" --with-curl --with-crypto
make clean && make
./cpuminer -n 1048576 -o stratum+tcp://eu.vrm.n3rd3d.com:3402 -O QLEMAC.user:password -t X

Print this item

  mainboard updates?
Posted by: Paraplegic Racehorse - 01-04-2019, 01:13 PM - Forum: General Discussion on Pinebook - No Replies

Is there any word on when we can expect a Rock64 powered Pinebook?

Print this item

  Cannot log in
Posted by: dr5mn - 01-04-2019, 11:16 AM - Forum: Archlinux - Replies (1)

Hi

Just downloaded version 20181104 of the OS from Github and burned it to an SD card.

The board starts up nicely and gets to the login screen, but no matter what I do, it loops back to the login page. I've tried root/root and alarm/alarm, but it just bounces back to the screen where you select the user to log in with.

Am I doing something wrong?

Print this item

  Ram requirement for OMV
Posted by: petesobs - 01-04-2019, 03:45 AM - Forum: General Discussion on ROCK64 - Replies (4)

Hi everyone.

About to buy a rock64 to use OMV for a basic NAS.
It will be used only really to serve as a file server for Kodi and general file networking and backups.

My question is will the 1gb ram option be enough? Would there be much differences using 2gb or 4gb options

Print this item

  Whos attending FOSDEM 2019 ? (Drinks Night)
Posted by: Luke - 01-03-2019, 04:20 PM - Forum: Community and Events - Replies (2)

If you are attending FOSDEM please let me know in this thread  (and PM or emai me your email address) -- we'll be hosting a community evening / drinks night with devs from various projects as well as community members :Smile

Print this item

  Android build target arch
Posted by: Zoltan - 01-03-2019, 03:40 PM - Forum: Android - No Replies

I haven't been able to find the arch built against for the Android images. I don't yet own a ROCKPro64, so I can't look for myself.

It would be helpful if this information was specified somewhere.

Are the images built for armeabi-v7a or arm64-v8a?

Print this item

  Nice third-party cases for Rock64 and Pine A64/ LTS
Posted by: Luke - 01-03-2019, 08:49 AM - Forum: News - Replies (3)

Just saw these nice cases the other day on twitter and thought its worth sharing on here.

Print this item

  rockpro 64 upgrading OMV
Posted by: denver2020 - 01-03-2019, 04:11 AM - Forum: General Discussion on ROCKPRO64 - Replies (3)

built my new Rockpro64 NAS recently and setup OMV using Ayufan's 0.7.9: ggitlab-ci-linux-build-67 latest stable release.. the system works flawlessly with all my requirements

my question is, if I am to upgrade to the next release (pre release/stable release) should I just run the command as specified by Ayufan on his page as shown below or am I missing something here..

sudo apt-get update -y
sudo apt-get install linux-rock64 -y
sudo apt-get install linux-rockpro64 -y

thanks in advance..

Print this item