debian+phosh running on PinePhone
Are you certain of your sim card ?
Does it work in another phone ?
You did say Modem Manager saw it, but the modem is "not ready"
  Reply
Hi, hoping I can get a little help. I just received my PinePhone today and was trying to get Mobian running on it. I believe I've done all the steps correctly, downloaded the image, flashed it to an SD card with belenaEtcher on Windows 10, popped it into the SD slot on the PinePhone and turn it on. The green status light turns on but then it's just blank. I've let it sit for "a while" (don't have exact time) thinking there might be something running in the background. Originally I used a 64gb SD card, I swapped it out for an 8gb card, both are exactly the same behavior. Did I miss a step? What is supposed to happen right after I flash the card on first boot, should it boot up instantly or is it going to take a while to do something? Maybe I'm being impatient but I expected something to show up even it it was just a prompt of some sort. Any tips?
  Reply
I have never used Windows to flash a card but I have not seen anyone mention that as a problem.

I have noticed it can take a few minutes to start on a first start from a freshly flashed sd card.
"Log-in" is 1 2 3 4   then it will go to desktop screen,  ...   wait 2 to 4 minutes...
Then it will walk you thru a few first time set up items.
and it runs pretty slow the first time through... you may wait a few seconds after clicking/touching the icons
before it moves on.
One of the items you should do early after finishing the start up menu is the settings for "Region & Languages"
Then after touching 'restart' on that page.  You need to do a manual 'shut down' using the power icon in the very top right corner of the screen.
Restart function seems to hang, until after the system has done a few power cycles.
Next I go through all the items on the settings page, to at least look at everything.
And make some adjustments where needed.
During this process you can set up your APN, that varies with whatever carrier you use.
  but you only need the APN for cell data.
(Settings > Mobile > Access Point Names > + sign then fill-in blanks, click 'save' )
Your sim card should be all that is needed for phone calls & sms/text to work.

It does run slower from an sd card than from the eMMC, but it is very usable.

Note about APN: you may need to "Save" multiple times before it stays after rebooting the phone.
  Reply
(09-01-2020, 07:57 PM)thisishuey Wrote: Hi, hoping I can get a little help. I just received my PinePhone today and was trying to get Mobian running on it. I believe I've done all the steps correctly, downloaded the image, flashed it to an SD card with belenaEtcher on Windows 10, popped it into the SD slot on the PinePhone and turn it on. The green status light turns on but then it's just blank. I've let it sit for "a while" (don't have exact time) thinking there might be something running in the background. Originally I used a 64gb SD card, I swapped it out for an 8gb card, both are exactly the same behavior. Did I miss a step? What is supposed to happen right after I flash the card on first boot, should it boot up instantly or is it going to take a while to do something? Maybe I'm being impatient but I expected something to show up even it it was just a prompt of some sort. Any tips?
With the last few batches a few of us encountered a similar problem. I believe we all got it working again through various methods. Read some of the threads regarding blank screen on boot in various os sub forums. Im sure one of the posted answers will work for you. From my experience i believe the bootloader automatically chooses sd card over emmc but if there was any  corruption on your sd card, or maybe even its not in right, it can cause the bootloader to try booting from the sd using the bios in a partition of the emmc and get stuck when it encounters the issue, corrupting the original emmc. There could also be a software issue in the bootloader as Ive noticed it even picks the emmc on some random occassions instead of the SD, which i know its not supposed to. I Believe putting a freshly flashed sd with your os of choice and pressing some combination of power and volume buttons will get it to boot from the new SD. Once it boots up the pinephone will correct whatever corruption you caused the emmc image.
  Reply
@bcnaz I gotcha, I do have Windows, Mac, and Linux machines aplenty so I'll give some other machines a try but I think the flash is sound, I'm not even getting to the login step and have definitely waited for more than 4 minutes on boot. I think @Cree's hunch is probably in line with what I'm seeing in that I'm having a similar issue as others with blank screen startup. I'll go dig through forum posts and see if I can find anything there.

Thank you both for the quick response, I will dig deeper now that I know that I should at least get a login shortly after boot.
  Reply
(09-02-2020, 08:38 AM)thisishuey Wrote: @bcnaz I gotcha, I do have Windows, Mac, and Linux machines aplenty so I'll give some other machines a try but I think the flash is sound, I'm not even getting to the login step and have definitely waited for more than 4 minutes on boot. I think @Cree's hunch is probably in line with what I'm seeing in that I'm having a similar issue as others with blank screen startup. I'll go dig through forum posts and see if I can find anything there.

Thank you both for the quick response, I will dig deeper now that I know that I should at least get a login shortly after boot.
I have been using Etcher on an iMac to flash Mobian, Manjaro Phosh, and Manjaro Plasma on two different SD cards and have not had any issues with the cards booting. I just usually flash directly over whatever OS is currently on the SD without wiping the card beforehand. Currently running Manjaro Phosh on a SD and it works fairly well but seems to run a little slower than Mobian. They are definitely slower during the first initial boot process.
PinePhone UBports CE and Mobian on SD, Mint Mobile, Pinebook Pro Manjaro
  Reply
Yeah, normally I have no problem 'just flashing' to an sd card, but on occasion when it does not boot,
I have found that a good zero wipe of the sd card, then a re-flash and it does work.
  Reply
(09-02-2020, 04:33 PM)bcnaz Wrote: Yeah,  normally I have no problem 'just flashing' to an sd card, but on occasion when it does not boot,
I have found that a good zero wipe of the sd card, then a re-flash and it does work.
I second that.  A good wipe seems to often clear up problems with a bad flash.  I have begun routinely
'cleaning' the uSD before flashing a new image to it.  Of course, we know that these cards only have so
many 'writes' to them so this does add wear and tear and probably reduces the useful life of the media
to some degree.  However, doing the prophylactic wipe seems to avoid frustration and wasted time.
No doubt this is anecdotal so take it for what its worth.
  Reply
So apparently it was an issue with the 3gb CE version of the pinephone, U-boot needed to be patched to run on the pinephone ce.

Found details here: https://forum.pine64.org/showthread.php?tid=11259 and https://gitlab.com/mobian1/issues/-/issues/86

The 20200903 nightly was the first to patch so I now have Mobian up and running!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Lightbulb Thorough Overview of Mobian on Pinephone as Main Driver food 0 168 11-27-2020, 02:17 PM
Last Post: food
  Tor with Mobian on Pinephone dRateNWAytORy 5 398 11-24-2020, 03:34 PM
Last Post: RTP
  Axolotl on PinePhone / Mobian arno_nuehm 7 731 11-18-2020, 02:38 PM
Last Post: marcih
  Anbox for Debian nas 43 13,121 11-11-2020, 06:37 PM
Last Post: Baggypants
Lightbulb Video Tut: Set Up SSH Access To Your Own Pinephone .onion (security enhancement) RTP 0 263 10-24-2020, 01:10 AM
Last Post: RTP
Wink Rockbox as an Application on Pinephone c3l@ 2 390 10-14-2020, 06:46 PM
Last Post: visiblink
  Mobian running config for baresip? lipkowski.be 0 235 10-12-2020, 03:05 AM
Last Post: lipkowski.be
  Enabling nighlight in mobian phosh joz_mak 2 540 09-18-2020, 06:11 PM
Last Post: joz_mak
  Mobian won't boot on convergence package Pinephone Mark53 11 1,865 09-05-2020, 08:51 PM
Last Post: SwordfishII
  Xwayland on Phosh works? paju1986 1 511 08-03-2020, 08:06 AM
Last Post: wibble

Forum Jump:


Users browsing this thread: 2 Guest(s)