Keyboard issue: Debian
#1
I'm a new Linux user and I've had a PinebookPro for several months now, using the Manjaro KDE that it came with.  It's been great, and I'm lucky to not have any issues aside from a not so smooth trackpad.

I just flashed Debian onto an SD card, and it loaded fine, and I updated it.  However, I have some keyboard issues that aren't present when I'm using Manjaro.  I wonder if anyone else has had this problem with Debian? 

Certain key functions are not accurate.  Here are some examples:

1.  When I try to do the | (pipe) key, it will do ~ (tilde) instead. 
2.  @ will do "
3.  # will do some other obscure symbol not even on the keyboard
4.  ~ will also do another obscure symbol.


Everything else on the keyboard works fine in Debian, at least from what I've tried.  Anyone else have this issue or have any ideas on how I can resolve it?
Thank you
  Reply
#2
You either have an ANSI keyboard, but settings for UK English, or an ISO keyboard, but settings for USA English.
  Reply
#3
(01-31-2021, 11:33 PM)KC9UDX Wrote: You either have an ANSI keyboard, but settings for UK English, or an ISO keyboard, but settings for USA English.
aaaahhh!  You're right.  I just looked at the keyboard setting.  On first startup of Debian it didn't go through initial set up process.  I'm guessing it doesn't do that on SD images?
Well anyway, you've solved my puzzle.  Thank you!
  Reply
#4
Correct. You don't get an installer, you get the installed system. So whomever made the image made an assumption about the keyboard. At one time, all PBPs had ISO keyboards, so it was a safe assumption.

This is the Debian problem. The Manjaro problem is that it changes your keyboard to Catalan after installation, before log in with hidden password!
  Reply
#5
(02-01-2021, 12:21 AM)KC9UDX Wrote: This is the Debian problem.  The Manjaro problem is that it changes your keyboard to Catalan after installation, before log in with hidden password!


Yikes! That's 100x worse!  Lucky my Manjaro was okay when I first received it.
  Reply
#6
Yes! That's how many of us received them. Set up in English, reboot, can't type the password, don't know why. The ******* password is all the wrong letters! A=K, B=R, C=O, etc.
  Reply
#7
(02-01-2021, 07:27 PM)KC9UDX Wrote: Yes!  That's how many of us received them. Set up in English, reboot, can't type the password, don't know why.  The ******* password is all the wrong letters!  A=K, B=R, C=O, etc.
How were you able to fix it?
  Reply
#8
"Thinking out of the box"

I put the cursor into the username field, and typed every key until I could find the ones with the letters in the password. Smile
  Reply
#9
(02-01-2021, 08:23 PM)KC9UDX Wrote: "Thinking out of the box"

I put the cursor into the username field, and typed every key until I could find the ones with the letters in the password. Smile
Genius Idea
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Debian emmc installer db579 4 94 08-15-2022, 08:19 PM
Last Post: TRS-80
  install debian on pbp jsch 0 330 06-19-2022, 02:29 AM
Last Post: jsch
  Unable to install Debian Bullseye because of missing wifi firmware Pino64 2 667 05-27-2022, 11:00 PM
Last Post: Pino64
  PBP won’t boot from eMMC after Debian update / Tow-Boot installer won’t boot from SD Pino64 21 2,054 05-12-2022, 05:00 AM
Last Post: Pino64
  Dual boot Manjaro and Debian? dieselnutjob 3 759 03-26-2022, 07:17 AM
Last Post: dieselnutjob
  Unsuccessful using danielt's unofficial Debian installer on the PBP joeDoe 1 708 03-25-2022, 08:15 AM
Last Post: danielt
  Installing debian on pinebook pro (deb installer/emmc) ljones 14 4,262 02-08-2022, 02:47 AM
Last Post: Humid Stylus
  Debian GPU Support Atton 5 3,309 12-02-2021, 05:37 PM
Last Post: cobratbq
  Solution for issue with 'panfrost' module not initializing due to missing dependency cobratbq 0 629 12-02-2021, 05:26 PM
Last Post: cobratbq
  Official Debian support moonwalkers 62 26,796 11-19-2021, 09:49 AM
Last Post: alpopa

Forum Jump:


Users browsing this thread: 1 Guest(s)