SD won't boot
#1
I'm new to the Pinebook Pro. I bought a used one a few days ago. I decided to update to Manjaro; no problem. Now I'd like to re-install using
Manjaro-ARM-kde-plasma-pbpro-20.04-emmc-installer-20.04.img

When I insert the SD and power cycle, it wouldn't boot. I thought that maybe I needed to install the original software and then try. I couldn't boot the original SD.

Any ideas?

Thanks.
#2
When you have booted the PBP and insert the SD, can you access the SD and see the directories?
Can you check with something like GParted if the SD is showing any problems?
#3
With an SD inserted, gparted doesn't show the SD.
#4
(05-29-2020, 03:26 AM)jiyong Wrote: When you have booted the PBP and insert the SD, can you access the SD and see the directories?
Can you check with something like GParted if the SD is showing any problems?

With and SD inserted, gparted does not show the device. Strange.
#5
Strange indeed.
Another SD is visible in GParted?
#6
(05-29-2020, 02:18 PM)jiyong Wrote: Strange indeed.
Another SD is visible in GParted?

I can't boot off SD as well. I tried 2 different 128 GB cards with different PBP images (mrfixit and armbian). I can format and also see my SD cards within Gparted. After inserting, it goes straight into the default Manjaro OS. Any tips would be appreciated.
#7
Do you have a SD card without PBP image, or can you format it with another machine?
Boot your PBP with eMMC and see if you can access the SD card.
Just checking if your SD slot is still working.
#8
I'm not sure if I should hop on this thread, or start my own.
I just received my brand new PBP this week.  I'm really not a fan of Manjaro.
I've been playing with Ubuntu on an SD Card.  At first, I didn't think I could get it to boot an SD Card at all, but I saw some posts talking about running the MrFixIt script, so I downloaded the newest version of the script and ran it in Manjaro, and it seemed to do some stuff.  After that, I rebooted and found that I booted into Ubuntu on my SD Card and thought that all of my problems were solved; however since then I've discovered that the machine will never COLD boot from the SD Card.   If I completely power off the machine, and power it back on, it always boots to Manjaro on the eMMC, then if I reboot from Manjaro with the SD Card inserted, it boots Ubuntu from the SD Card.
Any ideas?
#9
(05-30-2020, 05:14 PM)ALBNC1974 Wrote: I'm not sure if I should hop on this thread, or start my own.
I just received my brand new PBP this week.  I'm really not a fan of Manjaro.
I've been playing with Ubuntu on an SD Card.  At first, I didn't think I could get it to boot an SD Card at all, but I saw some posts talking about running the MrFixIt script, so I downloaded the newest version of the script and ran it in Manjaro, and it seemed to do some stuff.  After that, I rebooted and found that I booted into Ubuntu on my SD Card and thought that all of my problems were solved; however since then I've discovered that the machine will never COLD boot from the SD Card.   If I completely power off the machine, and power it back on, it always boots to Manjaro on the eMMC, then if I reboot from Manjaro with the SD Card inserted, it boots Ubuntu from the SD Card.
Any ideas?

ALBNC1974 - what MrFixit script did you use?

At first I used this one on my May 2020 PBP:
https://github.com/mrfixit2001/updates_repo/tree/v1.1

At that time, I was still able to boot into the default Manjaro without the SD card.

I then updated using uboot.img 2.0 from here:
https://github.com/mrfixit2001/updates_r...filesystem

After that, I was no longer able to boot into Manjaro or through an SD card.

Right now, I'm using an OS off of the SD card without the eMMC.
#10
I used the 2.0 script


Possibly Related Threads…
Thread Author Replies Views Last Post
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 120 109,767 09-11-2021, 02:16 PM
Last Post: calinb
  My pbp is a sleek, black, flat brick, and won't boot from any kind of media rotwang 15 2,323 08-24-2021, 04:25 PM
Last Post: bkenn
  How can I flash SPI so that I can boot from NVMe? codingpanic 5 585 08-24-2021, 05:07 AM
Last Post: codingpanic
  U-Boot, video console, and visual artifacts dsimic 15 2,262 07-28-2021, 09:37 AM
Last Post: dsimic
  boot order straightwalker 6 657 07-22-2021, 12:31 AM
Last Post: wdt
Tongue Hello my frend. How to fix my boot problem? carinosa 6 765 07-04-2021, 04:01 AM
Last Post: jiyong
  cannot boot SD card : "unable to select a mode" alchemist 0 332 06-18-2021, 02:03 AM
Last Post: alchemist
  Pinebook Boot CharlesBunders 14 3,012 06-15-2021, 07:40 PM
Last Post: James Good
  PBP won't boot alchemist 5 959 06-07-2021, 09:31 AM
Last Post: alchemist
  Broken Boot djhnsn 15 2,517 05-05-2021, 04:14 PM
Last Post: djhnsn

Forum Jump:


Users browsing this thread: 1 Guest(s)