Phosh Black Screen
#1
Bug 
Okay, so I have been having this issue for close to 2 months now, and I finally have enough time to play with.

I am a big fan of phosh DE, but I have been having this issue where, since March, I have had a problem where after start up I get a black screen, backlight on, that persists even through pushing the power button (sleep). Pushing the power button just cycles the backlight on and off, but the black screen remains. (though it did help me find a dead pixel). The only way to get it to stop has been to hard shutdown the phone and restart. This however, just restarts the cycle. It shows be the PmOS splash screen, flashes me the desktop menu and then shortly afterward, (usually before I can access the menu and turn on wifi) it does the black screen again.

So I have been doing random updates to new images since, only every few weeks due to class, with no change. I finally got done with the semester and have actually started messing with it again, and nothing has changed.

I have now tried building from pmbootstrap and using an image, they both do it. I have used USB network to get the wifi started and updated, it didn't solve the issue. Finally, I noticed that it seemed like the camera made a whole lot of noise shortly before the death, so I tried hardware kill-switching the cameras to see if that helped. It seemed to have worked for a bit, I could get into the menu and open settings, and even get into the terminal before it froze up and died. It also seemed to always be after I changed the brightness (not too low, just touching it), but it still happened, just later, if I never touched it.

Now it is still happening as soon as I touch the screen with the newest pmbootstrap build even with the switches flipped. The closest I ever got was with the pmbootstrap build and the switches flipped and I used usb network ssh to turn on wifi and seemed to have everything working until the update, and it started again. 

I have also tried phosh with pureOS and it does the same thing, (they called it the black screen of death) and they told me it could be fixed with hitting the vol+ and vol- 3 times each in under 5 sec. This did not work for their OS, nor for PmOS. So at this point, I'm really not sure what to do. Everything on the phone works fine with the terminal and ssh, but it wont let me use the screen with phosh.

Also, when this first started I tried PmOS with KDE plasma, and it worked fine. That was months ago and I haven't tried again since. I'm 90% sure it is something in phosh, but no one else seems to be having this issue. So, I'm not sure if it's something wrong with my hardware (would be weird since it doesn't break in other DEs) or something weird happening with me writing the images, even though I have done it a few different ways now...

Any help would be appreciated, cause I am really hoping to get to play with the phone some while I have this bit of free time. Thanks!

PS: If it's not obvious, I'm on a Braveheart.

PPS: Don't know if this is due to the voltage change to the screen, but it happened around the same time.
#2
Update 1: I just installed the newest factory test image from PmOS, and I get a similar crash every time I do the touchscreen test. This also occured with phosh, but was less consistent then the black screen bug. So, I thought they were 2 outcomes of the same problem. As I do the touchscreen test, the screen flickers to a screen of:
^@^@^@^@
Then resets to the test screen forgetting all previously passed tests, like a logout or DE reset.

Sometimes varying in number (2-4), though with the factory test image there's always 4. Also, it didnt always recover with phosh.

Also, phosh used to have the screen flash go to a blinking cursor (ttyl style). Though that seems to have stopped with the more recent updates.

Update 2: I just tried the original stock factory image and it didn't crash or flash on the touchscreen test, so it is definitely a change that occurred around March and not a hardware thing.

Update 3: I just tried Debian Phosh for the first time since I don't think it uses the same base as PmOS like PureOS does, but I ran into the exact same issue...so, yea...definitely thinking phosh or the touchscreen due to the voltage change is somehow killing the LCD to black, cause it seems to always wait for me to touch it first.
#3
@gotomech maybe something worth trying here ?
#4
(05-19-2020, 08:07 AM)a-wai Wrote: @gotomech maybe something worth trying here ?

Thanks @a-wai , that was the only other post that popped up when I searched black screen before I posted my thread. I figured it was people playing with overclocks and I was just running stock. Guess I should've dove a little deeper into the thread. I'll see if any of that helps and report back.
#5
(05-19-2020, 08:07 AM)" ma-wai Wrote: @gotomech maybe something worth trying here ?

So, I went straight for the slowest speed and I think the RAM speed seems to have helped the permanent black screen issue, but now, it seems to be showing that there was another issue. I now seem to just have full freezes occurring without the black screen hiding it and still getting screen flashes with the random "^@"s in varying numbers and sudden reboots and locked up OS. I still do get the black screens sometimes too, but it seems to reboot through them now.

I'm going to try it again and make sure I didn't mess anything up, but it seems to have worked correctly as the problems aren't as instantaneous as they previously were and are more varied.
#6
I just installed pmOS on my pinephone and I'm having the same issues. It feels unstable.
I did a tail one .xsession-errors and it first learned me that the last 'errors' were that squeekboard didn't find yaml-files in .local/share/squeekboard/keyboards so I downloaded us.yaml, terminal.yaml and emoji.yaml to that location from https://source.puri.sm/btantau/squeekboa.../keyboards

It made my phone a bit more stable - but once in a while, I got that "^@"s too.

Where are other places to investigate?
#7
(05-22-2020, 01:42 PM)davidbe Wrote: I just installed pmOS on my pinephone and I'm having the same issues. It feels unstable.
I did a tail one .xsession-errors and it first learned me that the last 'errors' were that squeekboard didn't find yaml-files in .local/share/squeekboard/keyboards so I downloaded us.yaml, terminal.yaml and emoji.yaml to that location from https://source.puri.sm/btantau/squeekboa.../keyboards

It made my phone a bit more stable - but once in a while, I got that "^@"s too.

Where are other places to investigate?

Hate to hear you have this problem, but glad not to be the only one...

Have you tried the RAM speed change linked by a-wai?

It didn't solve my problem, but it did seem to stabilize it. Maybe combined with what you found it could make for a stable build. I will also have to try your fix too when I get a chance.
#8
Hey @davidbe, have you tried any of the newest phosh images? My phone seems to be working with the most current Mobian and PmOS. Dont know what was changed, but it's working flawlessly now.

Though I'm not sure what the anx phosh version is of PmOS, it also works, but I have no network in it. So I'd use pmbootstrap updated to the newest version.
#9
Hi @gotomech , I just installed current pmOS and indeed, it's stable again! :-)
Squeekboard is crashing quiet frequently (needed 6 tries to fill in WiFi-password).


Possibly Related Threads…
Thread Author Replies Views Last Post
  pmos/phosh edge update and audio disappears robthebold 9 1,829 07-10-2022, 03:26 AM
Last Post: arkadione
  How to delete single sms in phosh? bircoph 1 442 07-06-2022, 08:10 AM
Last Post: bircoph
  no screen rotation on pinephone pro with postmarketOS + phosh elode 2 1,180 07-03-2022, 09:13 AM
Last Post: a.h.littorin
  closing apps rather than leaving them running (phosh) lordearl 7 3,426 02-03-2022, 09:14 PM
Last Post: parry
  pinephone boots to green screen after running out of space costava 1 753 01-30-2022, 06:29 AM
Last Post: costava
  Application list PMOS-Phosh jmorris 6 3,514 12-04-2021, 02:26 AM
Last Post: Juergen
  Phosh beta 10, no send button on Chatty? Rainer 0 1,160 05-24-2021, 08:17 AM
Last Post: Rainer
  No camera app on PinePhone Postmarket Edition / Phosh Noah222 3 3,446 12-02-2020, 03:38 PM
Last Post: jmorris
  Phosh and Plasma together stozi 5 5,192 09-30-2020, 01:25 PM
Last Post: wibble
  Touch Screen Not Turning Off Skin 2 1,914 09-24-2020, 02:08 PM
Last Post: jmorris

Forum Jump:


Users browsing this thread: 1 Guest(s)