Pine64 will not turn on
#1
I followed the tutorial on the wiki to create a boot able sd-card with Phoenix card.  Put the card in the board and then plugged in a 1.5 amp power supply and nothing.  No screen output or no led on the board.
  Reply
#2
(05-03-2016, 02:54 PM)destroyer Wrote: no led on the board.

Then it's easy. Next step might be 'burning gone wrong' or 'fake/faulty SD card' or 'undervoltage and then crashing in early boot stage' or 'Ethernet connected on 1st boot when trying to use Android/RemixOS' or any of the other well known reasons why you could fail to boot this board. But if not even the led is lighting then it's simply no power at all (either caused by a DOA or by insufficient/broken PSU).
  Reply
#3
I have tried a couple of different sd cards. The power supply works fine I use it for other projects. Is 1.5 amps to small or should I get a bigger PSU?

If I plug in power to the board without a card inserted should the led turn on?
  Reply
#4
They recommend 2.0 amps or higher, but It worked for me with 1.2 amp LG charger from my nexus 5. It crashes if you connect something like usb hard drive, it doesn't crash with my 12 volt 2.1 amp Apple psu. Try different wire, different PSU if you have one, but most likely it's dead. It happens, I believe they will send you a new one.
  Reply
#5
Ok but shouldn't I at least get a light with no sd card installed when powered?
  Reply
#6
Yup, but it is possible that light is not working. So if you feeling optimistic you can keep trying, maybe try a different OS image.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Wrong language installed on PINE64 mobian edition Derek7 0 642 04-02-2021, 05:25 PM
Last Post: Derek7
  new Pine64 KDE2 Plasma - missing navigation buttons? DonF22 2 1,107 03-03-2021, 01:19 AM
Last Post: tllim
  Christmas pine64 2GB - DOA sendonline@yahoo.com 0 1,607 12-28-2016, 07:02 PM
Last Post: sendonline@yahoo.com
  My experience with the Pine64 edu2004eu 9 6,966 06-02-2016, 09:31 AM
Last Post: Luke
  DOA Pine64 ? gato38 44 27,703 05-20-2016, 06:51 AM
Last Post: sfltrack

Forum Jump:


Users browsing this thread: 1 Guest(s)