android permission query
#1
Hi all,


I have query regarding permissions for external drive on android TV and android 7.1 


Android TV 7.1 Community Build Image [microSD Boot] by ayufan
and 
Android 7.1.2 Stock Image [microSD Boot] [Rooted] [20171204]

In both cases external drive (2T ntfs partition) is mounted as read only Is there any possible to change that situation. I know that second release is rooted but I've tried use root account and change permission and owner with chmod and chown but without result.

 Or maybe I should you some other release? 

Thanks in advance. 
  Reply
#2
Have you checked with a computer to make sure the drive's partition doesn't have an read only flags, or write protection? How does it mount when plugged into a computer? Any write issues?
  Reply
#3
The main purpose for me to use android is flexibility. Us it to watch content + transmission and with transmission I've notice that external drive is mounted as read only.


After that I've start test libreelec and android but in order to use external drive on android I've format disk and create ntfs partition. During my test on libreelec there is no issue with permission to save anything on external drive.

Could you recommend which android version I should test to check permission for external drive.
  Reply
#4
To be hones it will be easier to maybe to add user to a correct group.


For now as a standard user u0_a51 I have a read access only.
As root there is no problem because hi is an owner of this directory.


There is also a group sdcard_rw with the same permissions as root.


It is possible to add a standard user to this group on android OS? or force to use root account for transmission app.

In linux there is a separate account for transmission.
  Reply
#5
If I recall correctly (been a bit since I booted his Android builds) ayufan includes root in his community images.

Personally, across the various devices I used them on, I've favored ayufan's builds over the stock ones.

Assuming this is a fresh drive, with no data yet, have you already tried using Android to format it? I've had the issue before where I formatted a drive as FAT, Android saw it but still wanted me to format it. Eventually, I caved and formatted through Android, and I had no issues using the drive afterward. Have you tried using FAT, yet? From what I understand, Android and NTFS can still be a bit dodgy.

I think in order to add users to groups, you'll need to muck around with android_manifest.xml. Looking into it, it looks like trying to set custom groups and permissions is a much harder task.
  Reply
#6
Unfortunately external disc is not empty.



 I will make some test next week with pendrive with FAT partition but as I remember such solution is very limited when we though about huge files.

I will try also format pendrive with android.


Regarding manifest.xml I found this file but also as root user this file was read only. Summarize first I will focus on tests with pendrive and different partition.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Google Play on Android 9.0 admiral_andersen 0 21 Yesterday, 08:04 AM
Last Post: admiral_andersen
  Can't boot android 9 on rock64 maks2204 2 214 03-05-2020, 07:58 PM
Last Post: maks2204
  Android TV 8 or 9 on Rock64 ? chrbar 2 230 03-03-2020, 04:13 PM
Last Post: chrbar
  Android 9 img 64gb and google (first post) user7654 0 244 01-21-2020, 10:07 AM
Last Post: user7654
  How to build Android 9 for the Rock64 dazza5000 11 1,626 09-23-2019, 01:13 PM
Last Post: AlexS
  Android Images (ROCK64) pineadmin 63 44,693 09-20-2019, 09:54 AM
Last Post: elik745i
  Android 9 for Rock64? Blinky 41 9,599 09-15-2019, 05:39 PM
Last Post: R_V
  Stock Android Oreo 8.1 release tllim 48 20,966 08-27-2019, 09:34 PM
Last Post: Trispy
  Latest Android Build and associated kernel source Vasant 4 481 08-20-2019, 07:01 PM
Last Post: Vasant
  Android 9 + DAC addon card with rock64 AlexS 0 185 08-08-2019, 03:10 AM
Last Post: AlexS

Forum Jump:


Users browsing this thread: 1 Guest(s)