GPU accelaration ubuntu 18.04
#1
Hey,

It seems to me that the GPU isn't used at all on Ubuntu 18.04 on my pbp.
At least powertop reports 100% idle for the GPU even when playing video (in browser and mpv).
Does anyone else have a similar experience?
  Reply
#2
(11-29-2019, 04:32 AM)ventus_orientis Wrote: Hey,

It seems to me that the GPU isn't used at all on Ubuntu 18.04 on my pbp.
At least powertop reports 100% idle for the GPU even when playing video (in browser and mpv).
Does anyone else have a similar experience?

Playing video involves VPU, not GPU which is for graphic processing.
  Reply
#3
Mine was working, then I think I broke it. Stellarium doesn't start properly anymore and 1080 videos are laggy.

glxinfo gives this at the beginning...

name of display: :0.0
libGL error: MESA-LOADER: failed to open rockchip (search paths /usr/lib/arm-linux-gnueabihf/dri:\$${ORIGIN}/dri:/usr/lib/dri)
libGL error: failed to load driver: rockchip
libGL error: MESA-LOADER: failed to open rockchip (search paths /usr/lib/arm-linux-gnueabihf/dri:\$${ORIGIN}/dri:/usr/lib/dri)
libGL error: failed to load driver: rockchip

There is nothing labeled "rockchip" in the path, but there are 22 drivers...

Any ideas?
On a clear disk you can seek forever...
  Reply
#4
Use MPV media player - that has accelerated video playack for files up-to [email protected]

You can also use SMplayer with 1080p files. For SMPlayer you just need to specify settings in the config.
You can find me on IRC, Discord and Twitter


  Reply
#5
(12-01-2019, 03:06 PM)Luke Wrote: Use MPV media player - that has accelerated video playack for files up-to [email protected]

You can also use SMplayer with 1080p files. For SMPlayer you just need to specify settings in the config.

Thanks, Luke!

smplayer works without lagging though it seems grainy.  I was using vlc.

Still can't get stellarium to work, though it worked right after I installed it.

Still works in the default debian build, but opens a small box and just sits there in Ubuntu/mate 18.04.

I was trying to get wine to work, when I started having video issues.  If I have to, I'll reflash the SD back to the original image and then reinstall stuff (carefully).

Thanks again!
On a clear disk you can seek forever...
  Reply
#6
(12-01-2019, 03:18 PM)Jeffersoniantoo Wrote:
(12-01-2019, 03:06 PM)Luke Wrote: Use MPV media player - that has accelerated video playack for files up-to [email protected]

You can also use SMplayer with 1080p files. For SMPlayer you just need to specify settings in the config.

Thanks, Luke!

smplayer works without lagging though it seems grainy.  I was using vlc.

Still can't get stellarium to work, though it worked right after I installed it.

Still works in the default debian build, but opens a small box and just sits there in Ubuntu/mate 18.04.

I was trying to get wine to work, when I started having video issues.  If I have to, I'll reflash the SD back to the original image and then reinstall stuff (carefully).

Thanks again!

Experiment and have fun Smile
You can find me on IRC, Discord and Twitter


  Reply
#7
glxinfo aso shows that there is an error loading the video driver (mpv does show the same error, rkmpv does the same).
also: the gpu is not used when running software like glxgears.
This is seems to be a problem with the video accelaration.
I hope it can be fixed?
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  S3 sleep / suspend to ram on Ubuntu 18.04 ventus_orientis 11 475 01-21-2020, 10:10 AM
Last Post: wasgurd
  0.9.14 Release: Ubuntu 18.04 with Mate & LXDE Desktop Luke 80 12,305 01-13-2020, 07:06 AM
Last Post: Wizzard
  Boot splash on ayufan's Ubuntu brent.thierens 1 168 12-22-2019, 12:10 PM
Last Post: aristocrat
  Ubuntu 64bit Bionic for PineBook Pro futurejones 3 438 12-17-2019, 04:32 AM
Last Post: [email protected]
  Ubuntu mate boot failure hdk 2 150 11-28-2019, 12:28 AM
Last Post: hdk
  Which keyboard config file with Ubuntu Mate Linux-Rob 1 90 11-19-2019, 01:57 PM
Last Post: agD0i7rY

Forum Jump:


Users browsing this thread: 1 Guest(s)