Oops! I messed up the graphics drivers
#1
Okay, I admit I'm in over my head a little bit here. I know messing with the graphics drivers wasn't a very clever idea this early in the software ecosystem's life, but I bear a certain curse of wild curiosity and can never leave anything alone. It's my cross to bear, but if anyone else has useful insight into what's going on with my unit, I would be quite grateful indeed.

I have ayufan's Bionic image running. The other day, I was poking around the list of packages, and I encountered three that were of interest:
Code:
libmali-rk-midgard-t86x-r14p0 [installed]
libmali-rk-midgard-t86x-r14p0-gbm
libmali-rk-midgard-t86x-r14p0-wayland

I'd previously tried to no success to get Wayland working, and here I thought - hey, there's what I need, I better install those other two drivers. So I did, and now Wayland appears to work (!) but... now a lot of other stuff is broken. Namely, sddm and lightdm won't work (the former exits with status 6), and KDE plasma (which worked fine before under X) will not start, popping up a nice little dialog box informing me that my OpenGL 2.0 is broken (when run from either X or Wayland). Xfce still works alright (using that now to post this) but the general status of the system's graphics is perplexing.

According to glxinfo, I have OpenGL 3.1 support:

Code:
% glxinfo | grep -i version

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Version: 19.0.8
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.0.8
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.1 Mesa 19.0.8
OpenGL shading language version string: 1.40
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

However, systemsettings5 (the KDE Plasma system configurator) crashes immediately on startup, and most utilities related to OpenGL seem to emit a similar error that may indicate the problem:

Code:
libGL error: MESA-LOADER: failed to open rockchip (search paths /usr/lib/arm-linux-gnueabihf/dri:\$${ORIGIN}/dri:/usr/lib/dri)

libGL error: failed to load driver: rockchip


I admit I don't really know what's going on here, but it looks like something is missing. I have searched through my apt logs to see if I accidentally autoremoved something important, but I can't find it.

My real question now is simply: what do? Have I hosed it to the point where I need to reimage, or is there just some little thing missing that I can install and be on my way, or what?

Thanks in advance for whatever advice any of you might have.
  Reply
#2
Information 
Okay! I hung out on IRC for a minute and got the solution.
The problem is apparently that the three driver packages I installed do, to some degree, overlap, and by installing them willy-nilly. I mucked it up. I fixed it by force-reinstalling the original driver package and all its dependencies, like this:
Code:
sudo apt-cache depends libmali-rk-midgard-t86x-r14p0 | grep Depends: | cut -d: -f2 | xargs sudo apt install --reinstall -y
sudo apt install --reinstall libmali-rk-midgard-r14p0
and now KDE and sddm both work again.

Perhaps with this new knowledge I will make another attempt to get KDE working in Wayland...
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)