Bluetooth headsets - what works?
#11
What y'all need is `pulseaudio-module-bluetooth` and `bluez-firmware`. (on Debian)
  Reply
#12
pulseaudio-module-bluetooth and bluez-firmware installed. Same bug: connexion OK after reboot, but disconnect few minutes later. Impossible to reconnect:

Code:
bluetoothctl
[NEW] Controller 43:45:C5:00:1F:AC Debian-Desktop [default]
[NEW] Device 24:D1:FE:E3:49:62 PowerLocus P2
[bluetooth]# connect 24:D1:FE:E3:49:62
Attempting to connect to 24:D1:FE:E3:49:62
Failed to connect: org.bluez.Error.NotReady

Code:
[bluetooth]# show
Controller 43:45:C5:00:1F:AC
[...]
       Powered: no
       Discoverable: yes
       Pairable: yes
[...]
       Discovering: no
[bluetooth]# power on
Failed to set power on: org.bluez.Error.Failed
  Reply
#13
I have Sennheiser HD 4.50 BTNC Bluetooth wireless noise cancelling headphones working well with Ubuntu Mate on my PBP.

Pairing was easy , although I sometimes have to connect to the device manually when I turn the headphones on. (Click on Bluetooth->Devices and select "HT 4.50BTNC").

In sound settings hardware tab, make sure that "High Fidelity Playback (A2DP Sink)" is the selected profile.

Sound quality is excellent.

These headphones also work on the PBP with their 3.5mm audio jack cable as an alternative to bluetooth.
  Reply
#14
Photo 
My COWIN SE7 bluetooth headphones connect without problem under the stock Debian OS, and work for regular audio playback when the device profile is set to "High Fidelity Playback" (vs the default Headset profile).  However, the input buttons (pause, skip, back, volume up & down) do not work when in High Fidelity Playback mode.  I haven't tried using it as an actual headset (it has a mic), but when I choose the headset profile I can't listen to audio through the headphones from either Chrome or Rythmbox*.  However, when in headset mode the volume buttons on the SE7 do change the output volume displayed for the device in Sound Preferences.  

It may be specific to this set of headphones, but I've found that Chrome and Rythmbox* don't respond well if I change the sound output while they are running.  Chrome tends to stutter/freeze playback, and Rythmbox starts fast forwarding through my mp3 library.

What I've found works best is to connect the headphones and (before opening an app to play audio**) open the Sound Preferences GUI.  From there I go to the "Hardware" tab, and select the speakers and set their profile to "off".  Then I do the same for HDMI.  Then I select the SE7 and set the profile to the High Fidelity Playback option.  By turning off the other two devices this defaults the input and output tabs to the right settings, so I don't have to make any changes there.  When I want to go back to speakers I follow the same basic process, setting the SE7 to off (if connected) and set the speakers to analog stereo output.

*The only two apps I've tried.
**This is counter intuitive because usually the best way to test whether you have come across the right configuration is to have something playing while poking around.  In addition, the "Test Speakers" button in the sound preferences GUI doesn't do anything, which makes it a more complicated process to find the settings you are looking for.
  Reply
#15
Problem solved after installing Manjaro. PowerLocus P2 now works very well.
Pinebook Pro, standard config (Manjaro)
  Reply
#16
(11-27-2019, 08:33 AM)astdenis Wrote: audio stutters when wifi is connected (even with local audio). Clues anyone?
Thanks for the hint! Mine also stuttered, and I hadn't tried disconnecting wifi. With wifi disconnected, they work perfectly.
(12-05-2019, 09:21 AM)astdenis Wrote:
(12-02-2019, 03:28 PM)electriccrowbar Wrote:
(11-27-2019, 08:33 AM)astdenis Wrote: Pairing also works with Manjaro. Selecting the A2DP profil requires a few steps (once paired, hit the play button on my headset and then manually select the A2DP profile), but audio stutters when wifi is connected (even with local audio). Clues anyone?

Note: for pairing to succeed, pulseaudio-bluetooth must be installed first.

Try the performance cpu governor. It's set to ondemand i think by default and it may not be aggressive enough to deal with things like youtube.

Quote:echo performance > /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

Thanks for the suggestion. Tried it, no changes. This likely is a software/tuning issue since my headset works flawlessly with the same hardware running the Android 7.1 image. Nevermind youtube, simply testing the headset from the audio panel also stutters.
My system was already using the performance cpu governor. Likewise, my headset works fine with my phone.
(12-29-2019, 01:51 PM)Jeremiah Cornelius Wrote: I haven't yet tested if this behavior is dependent on 2.5 vs 5 GHz networks. I hope that this is useful in your instance!
It think you might be on to something here. My house has a slightly older router which is 2.4GHz only, plus a newer access point to extend the coverage, which is 2.4GHz and 5GHz. When I'm connected on 2.4GHz (confirmed by iwconfig), I get stutters. When connected on 5GHz (also confirmed by iwconfig), I haven't observed any stutters. This is of course only anecdotal evidence.

I've been testing with a pair of PSB M4U TW1's, using MPD to play audio. My Pinebook Pro is running NixOS: current kernel built from tsys' 5.6-rc5 sources, but with a slightly different config to Manjaro. When not stuttering, sound quality is good. The headset's next/prev/pause controls aren't working with the PBP yet, but I haven't looked into configuring them yet, so I'm not too surprised.
  Reply
#17
(04-16-2020, 09:44 AM)Thra11 Wrote: It think you might be on to something here. My house has a slightly older router which is 2.4GHz only, plus a newer access point to extend the coverage, which is 2.4GHz and 5GHz. When I'm connected on 2.4GHz (confirmed by iwconfig), I get stutters.
I finally got round to fixing the issue by:
  1. Sorting out my wonky wireless network so that 5GHz is available everywhere.
  2. Configuring NetworkManager to only associate with the 5GHz network. I ran `nmcli connection modify <my wifi SSID> 802-11-wireless.band a` (a = 5GHz, bg = 2.4GHz), but you can probably configure it with the various NetworkManager GUIs too. Obviously, this is only useful for dual band networks: if the network is 5GHz only, there's no point setting the band, while if the network is 2.4GHz only, you can't disable the 2.4GHz band: you probably just have to live without simultaneous wifi and bluetooth audio.
Thra11 Wrote:The headset's next/prev/pause controls aren't working with the PBP yet, but I haven't looked into configuring them yet, so I'm not too surprised.
This was trivial to fix, I just needed to run mpris-proxy.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Bluetooth microphone not detected mjc 1 130 10-18-2020, 03:47 AM
Last Post: wrzomar
Thumbs Up 180 degree screen tilt mod - works for me! mil 2 774 08-21-2020, 05:28 AM
Last Post: polrus
  Soldering internal Wifi/Bluetooth antenna petet0n76 1 470 06-20-2020, 12:01 PM
Last Post: tllim
  NVME SSD Samsung 960 EVO Works! Tekchip 2 875 02-24-2020, 05:23 PM
Last Post: Tekchip
  Samsung 970 EVO SSD 1TB - M.2 NVMe works on workstation but not Pinebook Pro mgchristensen 4 1,256 12-30-2019, 10:20 AM
Last Post: belfastraven

Forum Jump:


Users browsing this thread: 1 Guest(s)