Horrible screen flicker/strobe on battery power
#11
I have had the same issue happening on my ANSI PBP. The interesting thing is that it only happens in the factory-installed OS. It does not happen when I run either version of Manjaro. What was the end result of Meatball and Mattjb?
#12
(01-23-2020, 06:13 PM)likefiftyninjas Wrote: I have had the same issue happening on my ANSI PBP. The interesting thing is that it only happens in the factory-installed OS. It does not happen when I run either version of Manjaro. What was the end result of Meatball and Mattjb?

I hadn't tried Manjaro until recently. I ended up sending my board in and getting a replacement earlier this year, the replacement had no issues with default Debian, ayufan's Ubuntu, or Android.
#13
Good morning all,
I received my PBP 3 days ago. The first 2 days with no issues, but on the 3rd day the screen back-light went out, I could see the log in screen was there and badly flickering, but could input user name and password. Unfortunately could not use any thing as it was not visible. This was happening regardless the battery condition and even when plug to the charger.
Shutting off and on several times got the PBP back to normal with some flickering on the back-light occasionally, I am writing now on my PBP.
It looks to me as a bad contact or connection at some point, as it is random.
I would appreciate if the Pine people can guide me where to check possible bad connections, as I am in Spain and it would be expensive and very difficult to send any part to be serviced in the actual emergency situation.
I have been using Ubuntu for many years now and consider myself a user with good knowledge but not a developer.
Also being an engineer I know the basics of hardware and have put together many computers over the years.(I do have measuring instruments including oscilloscope)
I hope I can solve this issue locally, with some guidance.
Thanks and regards,
#14
(03-30-2020, 03:40 AM)CLC Wrote: Good morning all,
I received my PBP 3 days ago. The first 2 days with no issues, but on the 3rd day the screen back-light went out, I could see the log in screen was there and badly flickering, but could input user name and password. Unfortunately could not use any thing as it was not visible. This was happening regardless the battery condition and even when plug to the charger.
Shutting off and on several times got the PBP back to normal with some flickering on the back-light occasionally, I am writing now on my PBP.
It looks to me as a bad contact or connection at some point, as it is random.
I would appreciate if the Pine people can guide me where to check possible bad connections, as I am in Spain and it would be expensive and very difficult to send any part to be serviced in the actual emergency situation.
I have been using Ubuntu for many years now and consider myself a user with good knowledge but not a developer.
Also being an engineer I know the basics of hardware and have put together many computers over the years.(I do have measuring instruments including oscilloscope)
I hope I can solve this issue locally, with some guidance.
Thanks and regards,

if your issue still happening, please file support ticket at http://support.pine64.org. Once identify with hardware having issue, they can file RMA and send the particular hardware so that you can exchange yourselves.
#15
(04-01-2020, 02:14 PM)tllim Wrote:
(03-30-2020, 03:40 AM)CLC Wrote: Good morning all,
I received my PBP 3 days ago. The first 2 days with no issues, but on the 3rd day the screen back-light went out, I could see the log in screen was there and badly flickering, but could input user name and password. Unfortunately could not use any thing as it was not visible. This was happening regardless the battery condition and even when plug to the charger.
Shutting off and on several times got the PBP back to normal with some flickering on the back-light occasionally, I am writing now on my PBP.
It looks to me as a bad contact or connection at some point, as it is random.
I would appreciate if the Pine people can guide me where to check possible bad connections, as I am in Spain and it would be expensive and very difficult to send any part to be serviced in the actual emergency situation.
I have been using Ubuntu for many years now and consider myself a user with good knowledge but not a developer.
Also being an engineer I know the basics of hardware and have put together many computers over the years.(I do have measuring instruments including oscilloscope)
I hope I can solve this issue locally, with some guidance.
Thanks and regards,

if your issue still happening, please file support ticket at http://support.pine64.org. Once identify with hardware having issue, they can file RMA and send the particular hardware so that you can exchange yourselves.

Hi Tllim, thanks for your answer.
After my post, the issue did happen about 4 times, but decreasing in intensity: once the login screen was passed, it would light up and the flickering was not seen. After that transition period, it disappeared.
I will keep watching and report.
#16
Hey

I'm new to both the forum, Pine-products and linux.
Just got a PBP second hand where i live in Denmark. Really like it so far, but i struggle with the screen either flickering or beeing very dim(unusablle at day time).

If i disconnect the battery and use the powersupply without the battery everything works fine. It could be the battery or maybe a charging circut? Any ideas i would really like to try the PBP as my daily driver
#17
This is happening to me to no matter if I am on battery or not.  The screen doesn't go 60 seconds without jittery flicker that makes the whole device unusable.
Just received this unit a few days ago.
#18
Interestingly mine was fine when I was using Manjaro KDE (pre-installed). I have installed Ayufan's Ubuntu with MATE and now I have this issue. I feel that it is more frequent, when the batter is low. Now it flickers like every 2-3 minutes.

Any points I should follow to solve this?
#19
(11-04-2019, 05:06 PM)fire219 Wrote:
(11-04-2019, 12:21 PM)cowsay Wrote: This should probably be moved to the main PBP forum instead of the accessories subforum.  Sounds like a pretty major issue.. I'm curious how many people are dealing with this?  I've seen a lot of posts about display issues

This is the Hardware and Accessories subforum. It's in the right place. Smile

This is a concerning issue though. Would be interested to hear from more people as to if they have this issue too.
I started having the same issue my Pinebook is new.  Really bad screen flicker with Mate Desktop.  Will try Android and report back, this is a DOA looks like:/
#20
Maythe the following help to clarify?

I've got the same flickering problem with Rock64 board. Everything was working fine before kernel update to the 5.8.0 (ArchLinux). I have to update uboot to the newer mainline version, in order to boot the new kernel. But with default u-boot source code the board became unstable and display started to flicker. I've solved stability issue by setting memory frequency in one of device tree source files to 600MHz instead of 800MHz (as was suggested at the ArchLinuxARM forum). But this does not heal flickering.

In the old u-boot image there was memory setting to the 768MHz frequency, and the system was working well. I've tried to set the frequency to the 768MHz in the aforementioned device tree file, but the system became unstable with this setting. As i suggest, it is needed to tweak other LPDDR parameters, and i have no expertise in this subject. Ayufan knows how to tweak the thing, but keeps silence.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Increasing the maximum power draw dsimic 12 4,483 06-11-2021, 10:34 AM
Last Post: dsimic
  Battery doesn't charge mspohr 5 201 06-11-2021, 08:42 AM
Last Post: mspohr
  Alternative Power supply options gallomimia 10 5,137 02-13-2021, 04:36 AM
Last Post: angryminer
Question UK Power Supply Feakster 11 5,432 02-09-2021, 12:30 PM
Last Post: dieselnutjob
  Screen offset nobodyinperson 7 3,174 01-26-2021, 04:55 PM
Last Post: KC9UDX
  Pinebook Pro screen failure? BBreeziN 1 860 01-08-2021, 03:21 PM
Last Post: member
  Blinking red light for charger, no power-on bifo 9 1,929 01-07-2021, 07:31 AM
Last Post: dsimic
  Pinebook Pro Dock Power Requirements calinb 9 3,125 12-16-2020, 09:24 AM
Last Post: dsimic
  Auto-wake behavior when external power is connected diodelass 7 3,142 12-05-2020, 01:19 AM
Last Post: dsimic
Question Why two power ports on a budget laptop?? gurk 58 23,204 11-26-2020, 02:40 PM
Last Post: dsimic

Forum Jump:


Users browsing this thread: 1 Guest(s)