Problems flashing u-boot on RockPRO64 eMMC
#1
Hi all,

I'm using a RockPro64 board with a eMMC.

I succesfully flashed an Armbian image to this emmc, and I can boot it without problems.

I tried to disable boot from SPI (placing a jumper on pins 25-23 on PI-2 connector) and I'm able to boot from eMMC (u-boot spl and u-boot are loaded from there).

I tried to compile a u-boot.itb from scratch using Ayufan's repo https://github.com/ayufan-rock64/linux-u-boot/ and I flashed it to eMMC using USB OTG cable and rkdeveloptool at offset 0x4000. But old bootloader stills boot, as my bootloader were flashed not in the right place.
Besides that, I can use rkdeveloptool only if I stop u-boot and then run command

rockusb 0 mmc 0

Additionally, only first of two scenarios reported here https://wiki.pine64.org/index.php/ROCKPr...e#OTG_mode is working, because if I disable SPI and eMMC with jumpers (so no bootloaders present) my board enter in MaskMode but rkdeveloptool does not work (seems unable to communicate with board).

What I'm doing wrong?

Thanks in advance, regards

mauro
#2
I've had a similar experience when trying to use my self-built U-Boot using the DDR blob, as well as when extracting the U-Boot image from the ayufan build .debs and flashing that.
The only thing I've managed to get to booting a kernel so far is when dd'ing the first 1.5MB of the Armbian image to the eMMC and putting my system on top of that, which is less than satisfying.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Other boot options than Sdcard for linux 5.x kernel? MisterA 2 192 07-14-2021, 02:37 PM
Last Post: TRS-80
Brick Maintained Linux booting from eMMC ootoovak 5 421 07-06-2021, 02:28 PM
Last Post: TRS-80
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 84 21,182 07-03-2021, 07:09 AM
Last Post: jtremblant
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 44 26,223 06-20-2021, 06:09 AM
Last Post: mara
  RockPro64 CRUX-ARM (aarch64) mara 0 261 06-05-2021, 11:29 AM
Last Post: mara
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 845 05-20-2021, 10:04 PM
Last Post: t4_4t
  Booting Linux/Debian from the eMMC linuxha 4 909 03-02-2021, 07:01 PM
Last Post: linuxha
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 866 02-18-2021, 04:27 PM
Last Post: TRS-80
  Rockpro64 not stable... crashes now and then. Pineapple 18 7,614 02-16-2021, 02:45 PM
Last Post: TRS-80
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 15,505 02-14-2021, 02:37 PM
Last Post: foresto

Forum Jump:


Users browsing this thread: 1 Guest(s)