HW Video Decoder
Has anybody been able to get the HW Video Decoder working?  I have been trying multiple Images and packages over the last few days, but to no avail.  The players I use all show errors when trying to open / use the decoder.

I've tried Armbian, Debian, and Ubuntu builds, and all of them fail to play a full screen 1080p video.  The players either fail outright or downgrade to using software decoding.  When watching the CPU utilization it is pretty obvious that it is using software decoding.

Even tried using the image from Mr.FixIT, but I can't find the username/password to log in. (https://forum.pine64.org/showthread.php?tid=7055)

Does anyone have a step by step process to implement after the initial image is burned? 

Here is an example of the output from rkmpv (~195% CPU):

rkmpv timecode.mp4
Playing: timecode.mp4
 (+) Video --vid=1 (*) (h264 1920x1080 30.000fps)
[vo/gpu] VT_GETMODE failed: Inappropriate ioctl for device
[vo/gpu/opengl] Failed to set up VT switcher. Terminal switching will be unavailable.
mpi: mpp version: 0b701fe author: Lawrence-Tang DEBIAN: prepare for release_20171218-3
hal_h264d_api: Assertion vcodec_type & ((0x00000200) | (0x00000001) | (0x00000002)) failed at hal_h264d_init:119
hal_h264d_api: hal_h264d_init hard mode error, value=0
hal_h264d_api: Assertion 0 failed at hal_h264d_init:169
mpp_device: mpp_device_init failed to find device for coding 0 type 7
hal_h264d_api: p_hal->vpu_socket <= 0
mpp_hal: mpp_hal_init hal h264d_rkdec init failed ret -2
mpp_hal: mpp_hal_init could not found coding type 7
mpp_dec: mpp_dec_init could not init hal
mpp_rt: NOT found ion allocator
mpp_rt: found drm allocator
mpp: error found on mpp initialization
mpp: WARNING: setup buffer group before decoder init
mpp: command 310002 param 0x559d7f7a80 ret -1
[ffmpeg] h264_rkmpp: Failed to assign buffer group (code = -1)
[ffmpeg] h264_rkmpp: Failed to initialize RKMPP decoder.
Could not open codec.
VO: [gpu] 1920x1080 yuv420p
V: 00:00:12 / 00:01:00 (20%) Dropped: 24

and here is the output from mplayer (~98% CPU):

mplayer -fs timecode.mp4 
MPlayer 1.3.0 (Debian), built with gcc-7 (C) 2000-2016 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing timecode.mp4.
libavformat version 57.83.100 (external)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f7d442e60]Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol
[lavf] stream 0: video (h264), -vid 0
VIDEO:  [H264]  1920x1080  24bpp  30.000 fps  5229.3 kbps (638.3 kbyte/s)
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
libGL error: unable to load driver: rockchip_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: rockchip
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 57.107.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
Clip info:
 major_brand: isom
 minor_version: 512
 compatible_brands: isomiso2avc1mp41
 encoder: Lavf56.40.101
Load subtitles in ./
Audio: no sound
Starting playback...
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [x11] 1920x1080 => 1920x1080 Planar YV12  [fs]
[swscaler @ 0x7f7d4f5de0]bicubic scaler, from yuv420p to bgra using C
[swscaler @ 0x7f7d4f5de0]No accelerated colorspace conversion found from yuv420p to bgra.
[swscaler @ 0x7f7d4f5de0]using unscaled yuv420p -> bgra special converter
(01-14-2019, 10:50 PM)jzullo Wrote: Has anybody been able to get the HW Video Decoder working?  I have been trying multiple Images and packages over the last few days, but to no avail.  The players I use all show errors when trying to open / use the decoder.
log in credentials: rock/rock 
I tried couple of month back but ayufan's kernels so not have the rkdec modules added.

The way I managed to get it working was to use LibreELEC kernel, libraries, .... manually compiled to get kodi working.

Tge other choice is using mainline kernel which has support for hw decoding.

Possibly Related Threads…
Thread Author Replies Views Last Post
  USB Type-C Display cable support (for 2 in 1: Video + Power) Paprika88 0 2,435 02-12-2020, 06:47 AM
Last Post: Paprika88
Video Video Tutorials Requests NightCrawler504 5 5,416 05-02-2019, 08:33 PM
Last Post: NightCrawler504
  Rock64 OMV video question / same for RockPro64 I would assume RockPro64Newbie 0 16,636 08-19-2018, 04:11 AM
Last Post: RockPro64Newbie

Forum Jump:

Users browsing this thread: 1 Guest(s)