[Feb 26] Recalbox beta v3.1- Rock64 |[Feb 26] Recalbox 190222- RockPro64 / Minimal Debian by mrfixit2001 - 190222 - RockPro64 |[Feb 26] Q4OS 2.7-r2 - Pinebook 1080P / Pinebook |[Feb 22] Batocera Linux 5.20-20190121- RockPro64 | [Feb 19] Manjaro KDE 19.02 / Manjaro LXQT 19.02 - Pinebook1080P / Pinebook | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - RockPro | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - Rock64

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


KDE Neon problems persisting (1080)
#1
I'm having some problems with the install of KDE Neon which I probably shouldn't be.

Although I followed the day zero fixes thread, and linked other thread, it still likes to go into the black screen death sleep. Sometimes it actually needs a hard reboot to get the display back. Sleep and resume doesn't always do it.

Graphics acceleration of any type seems to be broken. SMPlayer with it's configured video type of "gpu" doesn't render properly. It renders some of the top of the video frames then it kind of explodes into the framebuffer filling the whole width of the screen with what I assume to be the video frame with the lines end to end. After that is the rest of the screen, further down and offset.

I tried building an SDL program that I use. When running one of it's executables it told me something interesting.

Code:
MESA-LOADER: failed to retrieve device information
libGL error: unable to load driver: sunxi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: sunxi

That's not great. why is sunxi_dri not working?
Should I just cut my losses and re-image, or is it an easy fix?
Reply
#2
check power settings. the turn screen off after 10 minute option CAN NOT be turned off. you can uncheck and apply but it does not "stick" and if your screen gets turned off after the 10 minutes you pretty much have to hold power long enough to power down and reboot. I am trying to set the 10 minute time to 90 minutes to see if that "sticks". KDE bug?
Reply
#3
It seems like there was an update in the last couple of days which fixed the GPU driver as far as SMPlayer is concerned at least. The window draw seems to be corrupted but that's no big deal. The contents are rendered properly now.

I just ended up turning off the option to turn off the screen and set it just to dim after a while. It was too much of a headache.

Just a note here. I didn't reinstall the KDE neon image. I did however try it from MicroSD while the eMMC install still had problems. I guess the Day 0 release had a few other issues too, as the downloaded image is newer.

For anyone considering reinstalling. Careful! I haven't found a straightforward set of docs. There's a few things that need to be noted. The eMMC has two smaller partitions which are only visible with fdisk. They don't show with programs based on parted.

When a MicroSD is inserted, the name of the eMMC shifts to mmcblk1 from 0. (I can't remember the exact name sorry). When the MicroSD also has a bootable image installed this can be confusing because they will both have the same volume names for the main partition.

There are instructions floating around on how to copy to eMMC, but I haven't tried them yet. Seeing the two extra partitions on the eMMC that aren't in the downloadable images put me off.

Lastly, don't change the session properties to Plasma (Wayland). It'll lock the Pinebook up. I saw the option and was curious.
Reply
#4
I tried a few random video files and got ~50% chance to play it properly on pinebook. Looks like the video decoder from day 0 KDE installation is quite picky. It plays smoothly 720p [email protected]/s but then fails (displays some random lines) with 480p [email protected]/s file.
Changelog for the latest release from ayufan says something about "sunxidrm performance", so its probably worth to make an update
https://github.com/ayufan-pine64/linux-build/releases/
Reply
#5
(11-15-2018, 11:30 AM)fitter Wrote: I tried a few random video files and got ~50% chance to play it properly on pinebook. Looks like the video decoder from day 0 KDE installation is quite picky. It plays smoothly 720p [email protected]/s but then fails (displays some random lines) with 480p [email protected]/s file.
Changelog for the latest release from ayufan says something about "sunxidrm performance", so its probably worth to make an update
https://github.com/ayufan-pine64/linux-build/releases/

SMPlayer plays everything I threw at it fine, strange.
  If you manage to click this link you'll join in the IRC channel
Reply
#6
I tried to play 4 video files, two of them glitched, rest was ok. But as I said, I'm still on default KDE, I have no time for update now (I'm using it for work Wink ).

Btw. do you know the changelog of the newest KDE Neon release? Does it include ayufan changes?
Reply
#7
this is what happens if i try to play video in KDE on my pinebook. smplayer just flips out.

https://i.imgur.com/PI5jheLr.jpg

is this related?
Reply
#8
(11-16-2018, 08:27 AM)caps Wrote: this is what happens if i try to play video in KDE on my pinebook. smplayer just flips out.

https://i.imgur.com/PI5jheLr.jpg

is this related?

Make it full-screen, it'll go away and play normally. You can resize after.
  If you manage to click this link you'll join in the IRC channel
Reply
#9
(11-16-2018, 08:27 AM)caps Wrote: this is what happens if i try to play video in KDE on my pinebook. smplayer just flips out.

https://i.imgur.com/PI5jheLr.jpg

is this related?

That's what was happening to me. It stopped doing it after an update. The same videos that did it before no longer did it.

Regarding the DRI issue, I haven' found anything clear on it except maybe I have to use the binary on the Wiki or build a version to go with this build.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Problems putting Ubuntu (Xenial Mate) on my replacement eMMC. frank-zappa 0 52 03-18-2019, 05:50 PM
Last Post: frank-zappa
  KDE Neon Pinebook remix edition RC image bshah 64 17,304 02-06-2019, 06:04 AM
Last Post: soupbowl
  MAME on Standard KDE Neon Corkonian 2 175 12-19-2018, 02:06 AM
Last Post: Corkonian
  Pinebook 1080 brand new kde Neon Snaps jwp1000 0 150 11-21-2018, 06:38 AM
Last Post: jwp1000
  how do I boot to SD? (1080) tedder 7 376 11-16-2018, 03:15 AM
Last Post: Surehand53
  activate repository in kde neon Luca Tansini 1 90 11-15-2018, 09:57 AM
Last Post: Luke
  How to get text boot on KDE Neon maldus 5 261 11-13-2018, 04:29 AM
Last Post: maldus
Music Problems using Spotify Web version because DRM (Firefox & Chromium) Ekkaia 7 1,208 09-07-2018, 02:23 AM
Last Post: JerrySmith1021
  Problems to install qemu on Xenial Mate (for EMMC) demian 1 312 03-14-2018, 08:43 AM
Last Post: xalius
  Flakey WIFI (problems authenticating, etc.) robbiemacg 5 568 01-11-2018, 12:44 PM
Last Post: naviathan

Forum Jump:


Users browsing this thread: 1 Guest(s)