u-boot serial port speed?
#1
I recently got a RockPro64 and I'm assuming it's using u-boot. I have a USB serial port adapter attached to my board and I can log in at 115200.

However, when I power cycle the board I see that it's outputting something with different serial port parameters. What are the serial port settings to be able to interact with u-boot? And what is the command sequence to get into the u-boot command line?


Thanks!
#2
(10-06-2018, 08:26 AM)zener Wrote: I recently got a RockPro64 and I'm assuming it's using u-boot. I have a USB serial port adapter attached to my board and I can log in at 115200.

However, when I power cycle the board I see that it's outputting something with different serial port parameters. What are the serial port settings to be able to interact with u-boot? And what is the command sequence to get into the u-boot command line?


Thanks!
  • Baudrate: 1500000
  • Data bits: 8
  • Parity: N
  • Stop bits: 1
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing

3. Quartz64 Model A with 4GB RAM

https://linux-nerds.org/category/14/rockpro64
#3
Wow, I tried 115200 and down to 9600. 1500000 works great. Thanks!


Possibly Related Threads…
Thread Author Replies Views Last Post
  enble boot after power loss/restore dkebler 4 633 04-18-2022, 03:58 AM
Last Post: ok38
  no boot white led flashing moserwi 3 428 03-28-2022, 07:26 PM
Last Post: Rocklobster
  Cannot get my board to boot deutschlmao 10 1,182 03-19-2022, 07:45 PM
Last Post: Rocklobster
  Enabling secure boot arturkow 4 966 11-25-2021, 04:57 AM
Last Post: arturkow
  Device unable to boot Lunix33 9 3,529 09-23-2021, 01:38 AM
Last Post: LMM
  Flashed SPI, able to ping RP64 but not boot from sdcard/usb korefuji 2 1,305 08-26-2021, 11:41 AM
Last Post: LMM
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 103 63,463 07-08-2021, 04:55 PM
Last Post: Mentaluproar
  First boot - no fan, no display... is it broken? rantoie 1 1,306 04-28-2021, 04:41 PM
Last Post: rantoie
  PXE boot - unable to login LMM 2 1,007 04-22-2021, 02:59 PM
Last Post: LMM
  unable to boot from SDCard Charles Tarkowski 4 3,008 12-16-2020, 11:11 AM
Last Post: Charles Tarkowski

Forum Jump:


Users browsing this thread: 1 Guest(s)