Ethernet Slow Download
#1
Hi, 

I'm running the latest version of Android I found on the wiki page: 20160216

My problem is the download speed over ethernet, which is really slow (~1Mbps), but my upload speed is (~15Mbps).
As a reference my pc has a download speed of 200Mbps and upload of 15Mbps.

How do I fix the slow download speed on the pine?

Thx,
  Reply
#2
(04-09-2016, 01:15 PM)Ascotg Wrote: Hi, 

I'm running the latest version of Android I found on the wiki page: 20160216

My problem is the download speed over ethernet, which is really slow (~1Mbps), but my upload speed is (~15Mbps).
As a reference my pc has a download speed of 200Mbps and upload of 15Mbps.

How do I fix the slow download speed on the pine?

Thx,

Hi,

Do you use the Wifi or the onboard cabled Ethernet LAN?
If with cable, how did you get a network connection?

It seems i am unable to get any LAN connection (2GB version)
  Reply
#3
(04-09-2016, 04:27 PM)Roverius Wrote:
(04-09-2016, 01:15 PM)Ascotg Wrote: Hi, 

I'm running the latest version of Android I found on the wiki page: 20160216

My problem is the download speed over ethernet, which is really slow (~1Mbps), but my upload speed is (~15Mbps).
As a reference my pc has a download speed of 200Mbps and upload of 15Mbps.

How do I fix the slow download speed on the pine?

Thx,

Hi,

Do you use the Wifi or the onboard cabled Ethernet LAN?
If with cable, how did you get a network connection?

It seems i am unable to get any LAN connection (2GB version)
There are still issues with the Android and RemixOS Ethernet implementation on the 2GB board. With debian, things are shaping up nicely. 

Code:
root@debianpine64:~# iperf -c 192.168.0.45 -t 60
------------------------------------------------------------
Client connecting to 192.168.0.45, TCP port 5001
TCP window size: 22.5 KByte (default)
------------------------------------------------------------
[  3] local 192.168.0.164 port 58323 connected with 192.168.0.45 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   615 MBytes  85.9 Mbits/sec

A little bit of time and this board will be screaming.
  Reply
#4
Shocked 
Hi!

I have a Pine64+ 2 GB with Debian8, Ubuntu Xenial, ...

I have the same problem! The down speed too slow "Download: 2.33 Mbit/s", the up speed is normal "Upload: 4.84 Mbit/s". My ISP give me 60/10 (30/5) bandwidth.

I did ethtool (100/full duplex autoneg off), took iperf3 8-(.

What can I do anything else?!
  Reply
#5
I'm using 3.10.65-5-pine64-longsleep (Ubuntu-xenial). I've got 4 pines connected to a gigabit switch. Transfer speeds between them are flaky. Just scp'd a 50MB file which took almost 11 minutes. Sometimes the ethernet just completely disappears for about 30s from all of them. They don't reboot, just lose ethernet connectivity.

Is there a way to assist in debugging this?
  Reply
#6
utdrcmac can you tell me if your pine model is the 2gb or 1gb variant?
If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#7
All 4 are the 2GB model. A64-DB-2G-Rev B / 2016-02-25 as printed on the boards.
  Reply
#8
it's on one of the bug reports for the 3.10.65 BSP kernel.

Something myself and others are trying to address, but if you set the link speed to 100mbits it will atleast give you a much more stable connection for the time being until the ethernet issues get patched up Wink
If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#9
I used this and added it to /etc/rc.local so it is applied at boot:

Code:
ethtool -s eth0 speed 100 duplex full

Have you noticed if half duplex makes it any more stable? I noticed that if I turn off auto-negotiation, eth won't come back online.
  Reply
#10
(04-27-2016, 06:06 PM)utdrmac Wrote: I used this and added it to /etc/rc.local so it is applied at boot:

Code:
ethtool -s eth0 speed 100 duplex full

Have you noticed if half duplex makes it any more stable? I noticed that if I turn off auto-negotiation, eth won't come back online.

I did like this, it's OK  Wink
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Ethernet port down afert 1 day jeda 0 180 11-12-2022, 06:48 AM
Last Post: jeda
  Ethernet --> Causing boot loop podtofs 3 4,396 05-16-2017, 03:41 AM
Last Post: m17
  GbE Ethernet Port Issue Data Gathering Statistics Intel MarkHaysHarris777 19 20,263 01-17-2017, 01:17 AM
Last Post: DrunkTank
  What will it take to get the Ethernet port working? clarkss12 10 13,194 10-17-2016, 03:42 PM
Last Post: waldo
  Pine64+ 1GB Ethernet Port spec ecotack 13 12,044 08-20-2016, 09:28 PM
Last Post: pfeerick
  If you have had difficulty with the GbE ethernet please take the poll MarkHaysHarris777 0 2,008 08-17-2016, 05:44 PM
Last Post: MarkHaysHarris777
  Ethernet works on Arch Linux. Nothing elese pfunk237 4 5,023 07-23-2016, 03:07 PM
Last Post: SuperArmySoldiers

Forum Jump:


Users browsing this thread: 7 Guest(s)