x11 vnc black screen
#1
Hello everyone,

I just installed the xenial-mate-rock64-0.5.15-136-20180102-arm64-sd2emmc.img and after setting up my x11vnc, I noticed that when I connect to it, I get a black screen and the only thing visible is my mouse cursor.

I am using the following command:

Code:
x11vnc -speeds dsl -bg -nevershared -forever -usepw -ssl SAVE -rfbport 5925 -display :0

My /etc/X11/xorg.conf.d/20-modesetting.conf

Code:
Section "Device"
   Identifier  "Rockchip Graphics"
   Driver      "modesetting"
   Option      "AccelMethod"    "glamor"
   Option      "Dri2Vsync"      "false"
EndSection

I also tried to modify the xorg.conf file by adding the following... Same result Sad

Code:
Section "Device"
    Identifier  "Rockchip Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "Dri2Vsync"      "false"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
        HorizSync 31.5-48.5
        VertRefresh 50-70
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        DefaultDepth 24
        SubSection "Display"
        Depth 24
        Modes "1920x1080"
        EndSubSection
EndSection


Thank you in advance.
  Reply
#2
do you think there may be a log somewhere that could provide some clues? i don't use vnc or many x11 commands so i have never looked but my guess is there would be one. maybe /var/logs or another location.
  Reply
#3
In vnc4server you have to remove the #from one of the top lines in ~/.vnc 

I believe its 
Code:
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup

For it to work I remember it required a reboot.
You can find me on IRC, Discord and Twitter


  Reply
#4
(01-17-2018, 04:08 PM)Luke Wrote: In vnc4server you have to remove the #from one of the top lines in ~/.vnc 

I believe its 
Code:
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup

For it to work I remember it required a reboot.

Hello Luke,
Thank you for your answer but unfortunately, I am not using vnc4server but instead, I use X11VNC.

This black screen behavior is very strange because I am using the same version with the same configurations on my Odroid XU4 and it works great.

At this point, I am going to compile X11VNC from source https://github.com/LibVNC/x11vnc .... and If that does not work either, I will just try vnc4server.
  Reply
#5
After spending more than 4 hours looking for a possible solution, I might know what could cause this issue.

I think the problem is related to the GPU video driver that for what I saw, they are not working and/or not installed by default by Ubuntu.

This is the only difference between my Odroid XU4 and the Rock64 (I have used the same configuration files).

Anyhow, I have tested the GPU acceleration on my Rock64 with https://webglsamples.org/aquarium/aquarium.html and I get 1 fps with 1 fish.

In addition to this, I also noticed that if I select any Marco with GPU compositor, my desktop turn all black and only the mouse cursor is visible (same behavior as x11vnc). That's why, I do not think this is a coincidence. Of course, I may be wrong...

At this point I have a question... Is not Ubuntu suppose to install the driver for the ARM Mali-450MP2 automatically?

I just tried out DietPi and X11vnc works wonderfully. Also, the GPU acceleration works much better. I have much more frame/sec with glxgears especially in full screen mode. Also, when I set the Marco GPU compositor, it works. (very slow though)
  Reply
#6
i'm thinking it might have something to do with a combination of how the rock64 handles the gl code, how well the browser handles webgl and perhaps if one has emmc or sd card and if sd card what size and manufacturer. but for sure something going on with that page. on my windows laptop using chrome i can get up to 10,000 at 30fps, up to 1000 at 60fps. on the rock64 chromium won't even process it and with firefox 100 at 3fps, 500 at 2fps, 1000 at 2fps, 5000 at 1fps. i'm using 32gb samsung evo sdcard. another thing, after 10 minutes at 100 fish at 3fps the temp was 80C. i have just a passive aluminum fin heatsink and it is warmer than it's been. i'm not sure when it throttles but health report shows 1296Mhz. thanks for the link.
  Reply
#7
I have x11vnc working fine on the Rock and also had the black screen issue for a while. *If* I remember correctly it can be fixed by compiling and installing x11vnc yourself.

Here's my startup command: x11vnc -noxrecord -noxfixes -noxdamage -shared -forever -usepw -o /home/debian/x11vnc.log -display :0 -ultrafilexfer
  Reply
#8
(01-18-2018, 02:41 AM)dontpostalot Wrote: I have x11vnc working fine on the Rock and also had the black screen issue for a while. *If* I remember correctly it can be fixed by compiling and installing x11vnc yourself.

Here's my startup command: x11vnc -noxrecord -noxfixes -noxdamage -shared -forever -usepw -o /home/debian/x11vnc.log -display :0 -ultrafilexfer

Hello dontpostalot,

As you suggested, I compiled from source the x11vnc but still, the black screen issue remains even with your x11vnc options.

At this point, unless I did not enable some extra parameters, this is how I compiled x11vnc
Code:
./autogen.sh && ./configure && make -j4 && sudo make install

I am just trying one more thing.... I really hope it will not work otherwise I will get REALLY upset...

I will keep you posted.
  Reply
#9
Here are my notes on the x11vnc compile:

sudo apt-get install -y libxtst-dev libssl-dev libjpeg-dev zlib1g-dev
cd ~
wget http://x11vnc.sourceforge.net/dev/x11vnc...dev.tar.gz
gzip -dc x11vnc-0.9.14-dev.tar.gz | tar -xvf -
cd x11vnc-0.9.14/
./configure --build=aarch64-unknown-linux-gnu --prefix=/usr/local CFLAGS='-g -O2 -fno-stack-protector -Wall'
make
sudo make install
x11vnc -storepasswd

It could be that '-fno-stack-protector' option, I'm not sure but this is how I got it working. Please do post back if you figure out what the exact issue was.
  Reply
#10
(01-19-2018, 06:58 AM)dontpostalot Wrote: Here are my notes on the x11vnc compile:

sudo apt-get install -y libxtst-dev libssl-dev libjpeg-dev zlib1g-dev
cd ~
wget http://x11vnc.sourceforge.net/dev/x11vnc...dev.tar.gz
gzip -dc x11vnc-0.9.14-dev.tar.gz | tar -xvf -
cd x11vnc-0.9.14/
./configure --build=aarch64-unknown-linux-gnu --prefix=/usr/local CFLAGS='-g -O2 -fno-stack-protector -Wall'
make
sudo make install
x11vnc -storepasswd

It could be that '-fno-stack-protector' option, I'm not sure but this is how I got it working. Please do post back if you figure out what the exact issue was.

Same thing as before... Black screen. At this point I really think is related to the video driver.

For some reason, the video driver under Ubuntu are not activated and/or working properly.

With both DietPI and Debian stretch the glxgears is smooth and fast but with Ubuntu, is laggy and slow.

At this point, I will just set aside my rock64 and wait for an emmc version of DietPI that for what I saw and tested, if the fastest distro out there for the rock64.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Screen blinking pRcCjl4 0 386 05-08-2021, 12:16 AM
Last Post: pRcCjl4
  Screen lock fail Bionic-lxde-rock64-0.7.8-1061-arm64 electrique 0 988 12-28-2018, 11:00 PM
Last Post: electrique
  Screen flickering when playing multiple videos with rkximagesink matwey 2 1,474 05-15-2018, 02:09 AM
Last Post: matwey

Forum Jump:


Users browsing this thread: 1 Guest(s)