Newbie question - should a Rock64 with no mmc card still output some video ?
#1
My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?
#2
When the unit is powered on, it will first look for the valid boot image in either SD or eMMC to load. What did you install on your SD card? Android? Debian Jessie? Xenial?
#3
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Yes, as with most SBC's, there is no video output without a bootable image either on EMMC or SDC.

Good luck!
#4
(08-20-2017, 10:52 AM)blue Wrote:
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Yes, as with most SBC's, there is no video output without a bootable image either on EMMC or SDC.

Good luck!


There is no firmware at all;  nothing!  no bios, no eufi, nothing;   everything is in the image and that lives on the SD or the eMMC;   eventually we will have uboot on the on-board SPI flash, but not yet....
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
#5
Fwiw, I had this problem on my main monitor (no signal). I tried every combination of mmc / sdcard with no luck but when i plugged it into my 4k TV I had no problem at all. Maybe it was trying to output 4k video which isn't supported in my monitor (over hdmi at least). EDID broken?
#6
(08-23-2017, 02:16 PM)Bloop Wrote: Fwiw, I had this problem on my main monitor (no signal). I tried every combination of mmc / sdcard with no luck but when i plugged it into my 4k TV I had no problem at all. Maybe it was trying to output 4k video which isn't supported in my monitor (over hdmi at least). EDID broken?

I just installed a ran Debian Stretch on my Rock64 last night.  It happily output console text through HDMI to my non-4K computer monitor and so my experience is different from yours.
#7
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Hi

I followed the guide on wiki for booting android on emmc:

http://wiki.pine64.org/index.php/ROCK64_...se_version
http://files.pine64.org/doc/rock64/guide...o_eMMC.pdf

Please note that before flashing firmware, there won't be any signal coming out from hdmi port.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 kernel panics clay 15 391 10-17-2021, 06:30 PM
Last Post: Rocklobster
  Pine Rock64 eMMC lifespan moonspell79 3 501 08-19-2021, 06:46 PM
Last Post: bcnaz
  Rock64 No Audio - Solved wbecks 12 17,712 08-13-2021, 01:23 PM
Last Post: blakeadam
Question Hardware issues with Rock64 grobbs 11 3,004 07-24-2021, 10:23 AM
Last Post: robinkyle11
  Trustzone support for Rock64 capablegh 1 409 07-17-2021, 10:15 AM
Last Post: capablegh
  Python GPIO Library for the Rock64 (R64.GPIO) Leapo 37 41,285 07-02-2021, 03:20 PM
Last Post: klausfelix
  rock64, compile problems "illegal instruction", "memory fault" -> ddr_333Mhz? klausfelix 0 349 07-02-2021, 03:13 PM
Last Post: klausfelix
Information Serial Console for the Rock64 MarkHaysHarris777 33 34,916 06-24-2021, 12:24 PM
Last Post: mikeklien
  lost eletronic component rock64 marvin1986 1 635 06-01-2021, 06:27 PM
Last Post: 8bit
Shocked Rock64 - Reboots after few minutes addezai 2 913 04-22-2021, 07:03 PM
Last Post: addezai

Forum Jump:


Users browsing this thread: 1 Guest(s)