Can not boot from eMMC
#1
Can the Ubuntu Mate [20170306] image for the SOPINE boot from a eMMC module? I have written the image twice successfully using Etcher to a eMMC module from the Pine store, but the SOPINE will not boot. It will boot from a micro SD card.
#2
I think that early image does not have the magical devicetree swapping for the eMMC/sdcard device and so the boot entries for the rootfs point to the wrong thing (would need manual fixing of boot.cmd and fstab), the latest image from Ayufan should work like for the Pinebook, e.g. boot from sdcard, then use the script in /usr/local/sbin to write the eMMC...

https://github.com/ayufan-pine64/linux-build/releases
Come have a chat in the Pine IRC channel >>
#3
I installed xenial-minimal-sopine-bspkernel-0.5.5-65.img (from the link you gave) on a  micro SD card, but it would not boot. I downloaded it again since there was no way to check if there was a bad download, and installed it again but still the SOPINE would not boot. I tried version 0.6.0 when it was released, but that would not boot either. I went back to Ubuntu Mate [20170306] and it boots fine.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Warning: Boot regression in latest kernels (4.19, 5.10 etc.) kuleszdl 4 2,076 08-22-2021, 01:27 PM
Last Post: kuleszdl
  No HDMI output on standard Debian install / no boot sagada 2 3,564 09-06-2020, 03:54 AM
Last Post: kuleszdl
  SOPINE Network boot Ninazu 1 2,973 05-11-2020, 12:40 PM
Last Post: lbruno
  Trying to boot archlinux-minimal-sopine-20170708-1.img kris240376 0 2,156 05-25-2018, 10:30 AM
Last Post: kris240376
  Cannot boot into Xenial Mate Jacob5146 4 5,281 04-22-2018, 11:00 AM
Last Post: Jacob5146
  [SOLVED] Boot from SD works, no boot with eMMC gkkpch 4 5,868 11-25-2017, 07:25 PM
Last Post: gkkpch
  PXE boot w/ SPI Flash bourg 2 3,918 09-12-2017, 03:24 AM
Last Post: ayufan
  No boot on any Linux image :/ oxomoxo 2 2,428 08-11-2017, 09:44 AM
Last Post: oxomoxo

Forum Jump:


Users browsing this thread: 1 Guest(s)