Facing difficulty in getting started with Ubuntu image
#1
1. I downloaded longsleep image (xenial-pine64-bspkernel-20161218-1.img.xz) ! 
I burned image and booted too.


I do not have any monitor with me. I do not have any keyboard with me. (actually i do not want to use it.)
How, can i do it. I used different hardware, where device was connected to Laptop. When C.H.I.P. was connected to laptop, using usb cable, I do not need cable. I just need to use screen utility to login on any tty

I connected a monitor and keyboard to what is available.. after login, I tried, ifconfig. ifconfig do not show any wlan0. I have connected my wifi module to Pine64. so, ideally it should show wlan0 too. unable to find instruction on how to connect wifi.
the worst thing, I tried to connect with LAN cable.  router is very far from Work table. If I connect LAN cable, I cannot connect keyboard. So I thought , I can do ssh and let Pine64 to be connected on LAN cable without any keyboard.
When I connected with a LAN cable, It do not get any ip address. It should get ip address automatically, so that I can do a ssh. 
I am highly frustrated, I cannot get stated on this board.
  Reply
#2
Somehow, It is getting ip address. I can do a remote ssh and login too.
But problem is still same..
trying to get connected with Wifi !!
  Reply
#3
My Wifi is not working, I am using original Wifi module from Pine. I am also using original charge from Pine.
Here are my logs

[email protected]:~$ dmesg | grep wlan
[ 8.933130] sunxi-wlan wlan.27: wlan_busnum (1)
[ 8.938176] sunxi-wlan wlan.27: Missing wlan_power.
[ 8.943618] sunxi-wlan wlan.27: wlan_power_name ((null))
[ 8.949535] sunxi-wlan wlan.27: io_regulator_name (vcc-wifi-io)
[ 8.956150] sunxi-wlan wlan.27: wlan_regon gpio=354 mul-sel=1 pull=-1 drv_level=-1 data=0
[ 8.965684] sunxi-wlan wlan.27: wlan_hostwake gpio=355 mul-sel=6 pull=-1 drv_level=-1 data=0
[ 8.975497] sunxi-wlan wlan.27: clk not config
[ 13.730099] sunxi-wlan wlan.27: bus_index: 1
[ 13.745621] sunxi-wlan wlan.27: check wlan io_regulator voltage: 1800000
[ 14.193745] RTL871X: rtw_ndev_init(wlan0)
[ 14.207622] RTL871X: rtw_ndev_init(wlan1)


[email protected]:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 36:d5:2b:db:21:7b
inet addr:192.168.1.203 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::34d5:2bff:fedb:217b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:512 errors:0 dropped:0 overruns:0 frame:0
TX packets:332 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:44625 (44.6 KB) TX bytes:43405 (43.4 KB)
Interrupt:114

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5920 (5.9 KB) TX bytes:5920 (5.9 KB)


Detailed logs available at - https://gist.github.com/nsisodiya/925b80...9ae26b9ee4
  Reply
#4
Wifi working... - followed instructions on - http://forum.pine64.org/showthread.php?t...&pid=18823
  Reply
#5
Glad you got it working. For these sort of questions, if you can't find the answer in the forum, it may be a good idea to ask in the chat first --- there is a chance that someone will know the answer or will be able to point you to the right forum thread.
You can find me on IRC, Discord and Twitter


  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Allwinner A64 RTC bug fix on bionic image? tkaivola 1 177 02-01-2019, 05:09 AM
Last Post: tllim
  Xenial Minimal Image (PINE A64(+)) 0.6.2-77 pineadmin 3 5,676 01-14-2019, 01:46 PM
Last Post: brigmohan
  SPI on ubuntu IlyaM 4 1,314 07-16-2018, 03:00 AM
Last Post: kingflab
  Ubuntu password not working joemassimino 4 728 05-18-2018, 03:33 PM
Last Post: Luke
  After flashing Ubuntu- how to get graphical desktop Partymack711 6 1,639 02-01-2018, 09:45 AM
Last Post: Partymack711
  (ARCHIVED) Ubuntu Xenial Image (BSP Kernel) longsleep 337 150,389 01-31-2018, 11:58 AM
Last Post: Luke
  PPTP doesnt work with ubuntu escovedo 2 2,088 08-23-2017, 09:28 AM
Last Post: gilbertotcc
Question HELP Ubuntu Mate password recovery procedure Captain Anni Hilator 5 1,980 08-03-2017, 03:52 PM
Last Post: Luke
  Ubuntu boot very slow with wifi driver remainder 9 2,131 08-03-2017, 07:23 AM
Last Post: victorssantos
  Recovering root access in Ubuntu Scientomancer 3 691 07-28-2017, 02:53 PM
Last Post: Scientomancer

Forum Jump:


Users browsing this thread: 1 Guest(s)